aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2004-05-31 12:55:04 +0800
committerdinoex <dinoex@FreeBSD.org>2004-05-31 12:55:04 +0800
commit257077de48ceb39261ea10c97f0a2124a1e7b225 (patch)
treeb7dcda125b3f1b601c80f15906ae940992fc0bc0 /lang
parent4b5152e56437aef3732c0f066479874c5036eb98 (diff)
downloadfreebsd-ports-gnome-257077de48ceb39261ea10c97f0a2124a1e7b225.tar.gz
freebsd-ports-gnome-257077de48ceb39261ea10c97f0a2124a1e7b225.tar.zst
freebsd-ports-gnome-257077de48ceb39261ea10c97f0a2124a1e7b225.zip
- fix configure for amd64
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc32/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/gcc32/Makefile b/lang/gcc32/Makefile
index f34c8f3581fc..541f34535a80 100644
--- a/lang/gcc32/Makefile
+++ b/lang/gcc32/Makefile
@@ -35,11 +35,6 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
-.else
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-.endif
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64" || ${ARCH} == "amd64"
# libgcj is built on all platforms except sparc64 and ia64 and amd64
@@ -52,8 +47,12 @@ BROKEN= gcj does not build.
.if ${PORTOBJFORMAT} == "aout"
CONFIGURE_TARGET= ${ARCH}-portbld-freebsdaout${OSREL}
.else
+.if ${ARCH} == "amd64"
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.else
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
.endif
+.endif
GCC_REV= ${PORTVERSION:C/\.0$//}
SRCDIR= ${WRKDIR}/gcc-${GCC_REV}