aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2012-10-14 07:19:36 +0800
committergerald <gerald@FreeBSD.org>2012-10-14 07:19:36 +0800
commit275c9d39b45275e82caf9cb66e04b3bc94f64e84 (patch)
tree9c360a9c942738e3a54b484edb3b34b1c31eebfd /lang
parentc68945d0a7d49f34a316fa12669417689ea71bf2 (diff)
downloadfreebsd-ports-gnome-275c9d39b45275e82caf9cb66e04b3bc94f64e84.tar.gz
freebsd-ports-gnome-275c9d39b45275e82caf9cb66e04b3bc94f64e84.tar.zst
freebsd-ports-gnome-275c9d39b45275e82caf9cb66e04b3bc94f64e84.zip
Replace the use of _GCC_BUILD_DEPENDS (which was never meant to be
used outside of Mk/bsd.gcc.mk) by _GCC_RUNTIME. This is still not ideal, but at least a documented stopgap, and it avoids the manual construction of the directory to be added to rpath. Remove -rpath= from _CFLAGS and _LDFLAGS since CFLAGS and LDFLAGS already have -Wl,-rpath= (and -rpath= itself is not even accepted by current versions of GCC). Approved by: maintainer timeout (6 weeks) Feature safe: yes
Diffstat (limited to 'lang')
-rw-r--r--lang/hiphop-php/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/lang/hiphop-php/Makefile b/lang/hiphop-php/Makefile
index 1bb22459e5a2..a7c8e0e836ab 100644
--- a/lang/hiphop-php/Makefile
+++ b/lang/hiphop-php/Makefile
@@ -119,12 +119,9 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-gettext
.include <bsd.port.pre.mk>
-_CFLAGS= -rpath=${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS} \
- ${CFLAGS}
-_CXXFLAGS= -rpath=${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS} \
- ${CXXFLAGS}
-_LDFLAGS= -rpath=${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS} \
- ${LDFLAGS}
+_CFLAGS= ${CFLAGS}
+_CXXFLAGS= -rpath=${_GCC_RUNTIME} ${CXXFLAGS}
+_LDFLAGS= ${LDFLAGS}
CONFIGURE_ENV+= ${CUSTOM_ENV}
MAKE_ENV+= ${CUSTOM_ENV}