aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjmmv <jmmv@FreeBSD.org>2015-11-09 04:31:51 +0800
committerjmmv <jmmv@FreeBSD.org>2015-11-09 04:31:51 +0800
commit27e08b158d27a12b6a0693a8441cb68d45c765b2 (patch)
tree114b7b6eb802705f51af793ffafa63a9055438c2 /lang
parentd3d9e32990d3a851f219eb6233d7ea269fac1252 (diff)
downloadfreebsd-ports-gnome-27e08b158d27a12b6a0693a8441cb68d45c765b2.tar.gz
freebsd-ports-gnome-27e08b158d27a12b6a0693a8441cb68d45c765b2.tar.zst
freebsd-ports-gnome-27e08b158d27a12b6a0693a8441cb68d45c765b2.zip
Revert r401072.
I'm not sure what happened exactly but I think I committed the change from the wrong client. The applied change enabled the MULTILIB option for all architectures and not only powerpc64. Let's just revert the commit and do it properly from scratch; other things might be wrong so I wanna take a closer look, and it's best to just revert quickly.
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc/Makefile9
-rw-r--r--lang/gcc48/Makefile9
-rw-r--r--lang/gcc49/Makefile9
-rw-r--r--lang/gcc5/Makefile11
4 files changed, 1 insertions, 37 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index f67439703172..3af4bab4c988 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -3,7 +3,6 @@
PORTNAME= gcc
PORTVERSION= 4.8.5
-PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
@@ -47,14 +46,6 @@ OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
OPTIONS_EXCLUDE_DragonFly= JAVA
BOOTSTRAP_DESC= Build using a full bootstrap
-.if exists(/usr/lib32/libc.so)
-OPTIONS_DEFINE+= MULTILIB
-OPTIONS_DEFAULT+= MULTILIB
-MULTILIB_DESC= Build support for 32-bit and 64-bit target types
-MULTILIB_CONFIGURE_ENABLE= multilib
-.else
-CONFIGURE_ARGS+= --disable-multilib
-.endif
.include <bsd.port.pre.mk>
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index f9c3aa94d8e7..2739fb9c12c8 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -3,7 +3,6 @@
PORTNAME= gcc
PORTVERSION= 4.8.5
-PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}
@@ -50,14 +49,6 @@ OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
OPTIONS_EXCLUDE_DragonFly= JAVA
BOOTSTRAP_DESC= Build using a full bootstrap
-.if exists(/usr/lib32/libc.so)
-OPTIONS_DEFINE+= MULTILIB
-OPTIONS_DEFAULT+= MULTILIB
-MULTILIB_DESC= Build support for 32-bit and 64-bit target types
-MULTILIB_CONFIGURE_ENABLE= multilib
-.else
-CONFIGURE_ARGS+= --disable-multilib
-.endif
.include <bsd.port.pre.mk>
diff --git a/lang/gcc49/Makefile b/lang/gcc49/Makefile
index 269738f33122..30b82b46005d 100644
--- a/lang/gcc49/Makefile
+++ b/lang/gcc49/Makefile
@@ -3,7 +3,6 @@
PORTNAME= gcc
PORTVERSION= 4.9.4.s20151028
-PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= GCC/snapshots/${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}
@@ -51,14 +50,6 @@ OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
OPTIONS_EXCLUDE_DragonFly= JAVA
BOOTSTRAP_DESC= Build using a full bootstrap
-.if exists(/usr/lib32/libc.so)
-OPTIONS_DEFINE+= MULTILIB
-OPTIONS_DEFAULT+= MULTILIB
-MULTILIB_DESC= Build support for 32-bit and 64-bit target types
-MULTILIB_CONFIGURE_ENABLE= multilib
-.else
-CONFIGURE_ARGS+= --disable-multilib
-.endif
.include <bsd.port.pre.mk>
diff --git a/lang/gcc5/Makefile b/lang/gcc5/Makefile
index 06567f2c9fea..a06dd7606f72 100644
--- a/lang/gcc5/Makefile
+++ b/lang/gcc5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gcc
PORTVERSION= 5.2.0
-PORTREVISION= 2
+PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}
@@ -52,15 +52,6 @@ OPTIONS_DEFAULT_amd64= JAVA
OPTIONS_EXCLUDE_DragonFly= JAVA
BOOTSTRAP_DESC= Build using a full bootstrap
-.if exists(/usr/lib32/libc.so)
-OPTIONS_DEFINE_powerpc64= MULTILIB
-OPTIONS_DEFAULT_powerpc64= MULTILIB
-MULTILIB_DESC= Build support for 32-bit and 64-bit targets
-MULTILIB_CONFIGURE_ENABLE= multilib
-.else
-CONFIGURE_ARGS+= --disable-multilib
-.endif
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"