aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorrezny <rezny@FreeBSD.org>2017-05-13 02:46:53 +0800
committerrezny <rezny@FreeBSD.org>2017-05-13 02:46:53 +0800
commit2a86e9db0353764dd454ec2e2a6825d74211aee3 (patch)
tree6651ec21aaf32f47dda7b92dcfb61385f580c8c9 /lang
parent1bdd19c4ec73c7795ca2ddcdfd72887bbca8bdd6 (diff)
downloadfreebsd-ports-gnome-2a86e9db0353764dd454ec2e2a6825d74211aee3.tar.gz
freebsd-ports-gnome-2a86e9db0353764dd454ec2e2a6825d74211aee3.tar.zst
freebsd-ports-gnome-2a86e9db0353764dd454ec2e2a6825d74211aee3.zip
Consolidate the Mesa ports, update to 17.0.4, and add Wayland option
* libGL, libEGL, libglesv2, libglapi, and gbm have been moved into mesa-libs, graphics/dri has been renamed to mesa-dri, and USE_GL has been adjusted * mesa-libs has a new WAYLAND option that enables platform support in libEGL * mesa-dri now depends on graphics/s2tc for compressed texture support [1] * re-remove obsolete dependency on makedepends [2] * correct sed fix backported from 17.1 [3] PR: 218799 (exp-run), 212762 [1], 218552 [2], 218562 [3] Submitted by: dbn [1], jbeich [2,3] Reported by: afiskon@devzen.ru [1] Reviewed by: kwm, johalun0@gmail.com Approved by: portmgr, swills (mentor) Differential Revision: https://reviews.freebsd.org/D10448
Diffstat (limited to 'lang')
-rw-r--r--lang/clover/Makefile34
-rw-r--r--lang/clover/pkg-descr5
-rw-r--r--lang/clover/pkg-plist3
3 files changed, 24 insertions, 18 deletions
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index 03fec26f22ac..365496ee2024 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -2,30 +2,40 @@
PORTNAME= clover
PORTVERSION= ${MESAVERSION}
-PORTREVISION= 0
CATEGORIES= lang
COMMENT= Mesa "Clover" OpenCL library
-BUILD_DEPENDS= opencl>=0:devel/opencl
+BUILD_DEPENDS= libclc>=0.2.0.20160915:devel/libclc \
+ opencl>=0:devel/opencl \
+ ${LOCALBASE}/libdata/pkgconfig/pthread-stubs.pc:devel/libpthread-stubs
LIB_DEPENDS= libdrm.so:graphics/libdrm \
- libOpenCL.so:devel/ocl-icd \
- libexpat.so:textproc/expat2
+ libexpat.so:textproc/expat2 \
+ libOpenCL.so:devel/ocl-icd
RUN_DEPENDS= opencl>=0:devel/opencl
-USE_XORG= dri2proto dri3proto glproto presentproto x11 xdamage xext \
- xfixes xshmfence xvmc xxf86vm
-
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= Clover needs a graphics driver supported by the Radeon KMS driver
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= Clover needs a GPU supported by the Radeon KMS driver
.include <bsd.port.options.mk>
-.include "${.CURDIR}/../../graphics/libGL/Makefile.common"
+.include "${.CURDIR}/../../graphics/mesa-dri/Makefile.common"
+
+CONFIGURE_ARGS+= --enable-opencl --enable-opencl-icd --disable-dri \
+ --disable-egl --disable-gbm --disable-glx \
+ --disable-va --disable-vdpau --disable-xvmc \
+ --with-gallium-drivers=r600,radeonsi
-#MESA_BUILD_WRKSRC= src/util src/glsl src/mesa src/gallium
+#MESA_BUILD_WRKSRC= src/util src/compiler src/mesa src/gallium
MESA_INSTALL_WRKSRC= src/gallium/targets/opencl src/gallium/targets/pipe-loader
-.include "${.CURDIR}/../../graphics/libGL/Makefile.targets"
+.include "${.CURDIR}/../../graphics/mesa-dri/Makefile.targets"
+
+pre-configure:
+ @if [ -e ${LOCALBASE}/bin/llvm-config${MESA_LLVM_VER} ] && \
+ ! [ -e ${LOCALBASE}/bin/clang${MESA_LLVM_VER} ]; then \
+ ${ECHO_MSG} "Your llvm${MESA_LLVM_VER} is not built with clang support, which is required."; \
+ ${FALSE}; \
+ fi
post-install:
@${MV} ${STAGEDIR}/etc/OpenCL ${STAGEDIR}${PREFIX}/etc/
diff --git a/lang/clover/pkg-descr b/lang/clover/pkg-descr
index 0385eee7880f..d2afb15cfebc 100644
--- a/lang/clover/pkg-descr
+++ b/lang/clover/pkg-descr
@@ -1,5 +1,4 @@
-This package contains the Mesa "Clover" libOpenCL implementation. This
-implementation is build onto GALLIUM and as such can only be used on Radeon
-cards.
+This package contains Mesa's libOpenCL implementation "Clover".
+It is built upon GALLIUM and currently only supports Radeon GPUs.
WWW: http://dri.freedesktop.org/wiki/GalliumCompute/
diff --git a/lang/clover/pkg-plist b/lang/clover/pkg-plist
index 5686603b7ee4..eb9d5242ea4b 100644
--- a/lang/clover/pkg-plist
+++ b/lang/clover/pkg-plist
@@ -1,9 +1,6 @@
etc/OpenCL/vendors/mesa.icd
-lib/gallium-pipe/pipe_r300.so
lib/gallium-pipe/pipe_r600.so
lib/gallium-pipe/pipe_radeonsi.so
-lib/gallium-pipe/pipe_swrast.so
-lib/gallium-pipe/pipe_vmwgfx.so
lib/libMesaOpenCL.so
lib/libMesaOpenCL.so.1
lib/libMesaOpenCL.so.1.0.0