aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
committeradamw <adamw@FreeBSD.org>2015-03-14 01:29:58 +0800
commit3285716aaeafc0b799b7d0f09455fb838f7423eb (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /lang
parent0e44743df6c6b7c3f4bc9ebe5b47c9868ff2ca6d (diff)
downloadfreebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.gz
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.tar.zst
freebsd-ports-gnome-3285716aaeafc0b799b7d0f09455fb838f7423eb.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Diffstat (limited to 'lang')
-rw-r--r--lang/p5-JSAN/Makefile12
-rw-r--r--lang/parrot/Makefile17
-rw-r--r--lang/parrot/pkg-plist20
3 files changed, 20 insertions, 29 deletions
diff --git a/lang/p5-JSAN/Makefile b/lang/p5-JSAN/Makefile
index 672bc1501afa..0021b5fb8c19 100644
--- a/lang/p5-JSAN/Makefile
+++ b/lang/p5-JSAN/Makefile
@@ -12,16 +12,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= JavaScript Archive Network (JSAN) Shell
-BUILD_DEPENDS= p5-Class-DBI-SQLite>=0:${PORTSDIR}/databases/p5-Class-DBI-SQLite \
- p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
- p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
- p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
+BUILD_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-Class-DBI-DATA-Schema>=0:${PORTSDIR}/databases/p5-Class-DBI-DATA-Schema \
p5-Class-DBI-Loader>=0:${PORTSDIR}/databases/p5-Class-DBI-Loader \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Class-DBI-SQLite>=0:${PORTSDIR}/databases/p5-Class-DBI-SQLite \
+ p5-Class-DBI>=0:${PORTSDIR}/databases/p5-Class-DBI \
+ p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite \
p5-SQL-Translator>=0:${PORTSDIR}/databases/p5-SQL-Translator \
+ p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
- p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
diff --git a/lang/parrot/Makefile b/lang/parrot/Makefile
index 55ccf45683b8..5b2cbca1a94b 100644
--- a/lang/parrot/Makefile
+++ b/lang/parrot/Makefile
@@ -35,27 +35,18 @@ MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
USES= bison gmake perl5 tar:bzip2
-PARROT_SHARE_DIR= share/doc/${PORTNAME}/${PORTVERSION}
-PARROT_DOCS= ${PARROT_SHARE_DIR}
-PLIST_SUB= PARROT_VER="${PORTVERSION}" \
- PARROT_DOCS="${PARROT_DOCS}"
+DOCSDIR= share/doc/${PORTNAME}/${PORTVERSION}
+PLIST_SUB= PARROT_VER="${PORTVERSION}"
BROKEN_ia64= Does not compile on ia64
-.include <bsd.port.options.mk>
-
-post-patch:
-.if ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '/^installable: / s| docs | |' ${WRKSRC}/config/gen/makefiles/root.in
-.endif
-
do-configure:
- cd ${WRKSRC} && ${PERL} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
+ (cd ${WRKSRC} && ${PERL} ${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/libparrot.so.${PORTVERSION} ${STAGEDIR}${PREFIX}/lib/parrot/${PORTVERSION}/dynext/*.so
regression-test test: build
- cd ${WRKSRC} && ${MAKE} test
+ (cd ${WRKSRC} && ${MAKE} test)
.include <bsd.port.mk>
diff --git a/lang/parrot/pkg-plist b/lang/parrot/pkg-plist
index 0ef0170cf8b7..7b8336ef9747 100644
--- a/lang/parrot/pkg-plist
+++ b/lang/parrot/pkg-plist
@@ -590,16 +590,16 @@ man/man1/pbc_merge.1.gz
man/man1/pbc_to_exe.1.gz
man/man1/plumage.1.gz
man/man1/winxed.1.gz
-%%PARROT_DOCS%%/CREDITS
-%%PARROT_DOCS%%/DONORS.pod
-%%PARROT_DOCS%%/LICENSE
-%%PARROT_DOCS%%/PBC_COMPAT
-%%PARROT_DOCS%%/PLATFORMS
-%%PARROT_DOCS%%/README.pod
-%%PARROT_DOCS%%/README_cygwin.pod
-%%PARROT_DOCS%%/README_win32.pod
-%%PARROT_DOCS%%/RESPONSIBLE_PARTIES
-%%PARROT_DOCS%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/DONORS.pod
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/PBC_COMPAT
+%%PORTDOCS%%%%DOCSDIR%%/PLATFORMS
+%%PORTDOCS%%%%DOCSDIR%%/README.pod
+%%PORTDOCS%%%%DOCSDIR%%/README_cygwin.pod
+%%PORTDOCS%%%%DOCSDIR%%/README_win32.pod
+%%PORTDOCS%%%%DOCSDIR%%/RESPONSIBLE_PARTIES
+%%PORTDOCS%%%%DOCSDIR%%/TODO
%%DATADIR%%/%%PARROT_VER%%/MANIFEST
%%DATADIR%%/%%PARROT_VER%%/MANIFEST.dev
src/parrot/%%PARROT_VER%%/config_lib.pir