aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-12-29 18:25:55 +0800
committermiwi <miwi@FreeBSD.org>2009-12-29 18:25:55 +0800
commit3708450bb42400f54c31b8a452a6bbfe12f2e374 (patch)
treec153f917419d736efeb14c47cd0b50b409caaeb7 /lang
parentd5c71b33378d6b11b684e90e24613de58b67592e (diff)
downloadfreebsd-ports-gnome-3708450bb42400f54c31b8a452a6bbfe12f2e374.tar.gz
freebsd-ports-gnome-3708450bb42400f54c31b8a452a6bbfe12f2e374.tar.zst
freebsd-ports-gnome-3708450bb42400f54c31b8a452a6bbfe12f2e374.zip
- Convert NOMANCOMPRESS to NO_MANCOMPRESS to sync with src
PR: ports/136065 ports/127469 Submitted by: N.J. Mann <njm@njm.me.uk> and Aldis Berjoza <killasmurf86@gmail.com> - Early identify port CONFLICTS PR: 137855 Submitted by: Piotr Smyrak <smyru@heron.pl> - Add --no-same-permissions to the EXTRACT_AFTER_ARGS command. Tijl Coosemans has been reported an issue that when root is extracting from the tarball, and the tarball contains world writable files (sysutils/policykit as an example), there is a chance that the files gets changed by malicious third parties right after the extraction, which makes it possible to inject code into the package thus compromise the system. Submitted by: Tijl Coosemans <tijl@coosemans.org> Xin LI (delphij@) - Fix some whitespaces Tested with: exp-run
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang/Makefile2
-rw-r--r--lang/erlang14/Makefile2
-rw-r--r--lang/gcc34/Makefile2
-rw-r--r--lang/gnat-gcc41/Makefile2
-rw-r--r--lang/gnat-gcc42/Makefile2
-rw-r--r--lang/gnat-gcc43/Makefile2
-rw-r--r--lang/gnat-gcc44/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 042dfaf75740..e5aa6ba7b2cf 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -100,7 +100,7 @@ MAKE_ARGS+= ARCH=x86
# Erlang man pages are more of internal documentation using the man format than
# actual system man pages. (erl.1 and epmd.1 perhaps being the exception).
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
MAN1PREFIX= ${PREFIX}/lib/erlang
MAN3PREFIX= ${PREFIX}/lib/erlang
diff --git a/lang/erlang14/Makefile b/lang/erlang14/Makefile
index 042dfaf75740..e5aa6ba7b2cf 100644
--- a/lang/erlang14/Makefile
+++ b/lang/erlang14/Makefile
@@ -100,7 +100,7 @@ MAKE_ARGS+= ARCH=x86
# Erlang man pages are more of internal documentation using the man format than
# actual system man pages. (erl.1 and epmd.1 perhaps being the exception).
-NOMANCOMPRESS= yes
+NO_MANCOMPRESS= yes
MAN1PREFIX= ${PREFIX}/lib/erlang
MAN3PREFIX= ${PREFIX}/lib/erlang
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index 3a2ee442356c..dac050d99773 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -33,7 +33,7 @@ USE_PERL5_BUILD=yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:C/${WRKDIR}//}/configure
-NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
+NO_MANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
diff --git a/lang/gnat-gcc41/Makefile b/lang/gnat-gcc41/Makefile
index a732fbfe8754..f0ffa5280d32 100644
--- a/lang/gnat-gcc41/Makefile
+++ b/lang/gnat-gcc41/Makefile
@@ -37,7 +37,7 @@ MAN1= cpp${gcc_suffix}.1 \
gcc${gcc_suffix}.1 \
gcov${gcc_suffix}.1
MAN7= ${fsf_mans:S/$/${fsf_suffix}.7/}
-NOMANCOMPRESS= yes # XXX 5-cur and releng4 problems?
+NO_MANCOMPRESS= yes # XXX 5-cur and releng4 problems?
INFO= gcc${gcc_suffix}/cpp \
gcc${gcc_suffix}/cppinternals \
gcc${gcc_suffix}/gcc \
diff --git a/lang/gnat-gcc42/Makefile b/lang/gnat-gcc42/Makefile
index b32765e78671..e75a363d8a8d 100644
--- a/lang/gnat-gcc42/Makefile
+++ b/lang/gnat-gcc42/Makefile
@@ -37,7 +37,7 @@ MAN1= cpp${gcc_suffix}.1 \
gcc${gcc_suffix}.1 \
gcov${gcc_suffix}.1
MAN7= ${fsf_mans:S/$/${fsf_suffix}.7/}
-NOMANCOMPRESS= yes # XXX 5-cur and releng4 problems?
+NO_MANCOMPRESS= yes # XXX 5-cur and releng4 problems?
INFO= gcc${gcc_suffix}/cpp \
gcc${gcc_suffix}/cppinternals \
gcc${gcc_suffix}/gcc \
diff --git a/lang/gnat-gcc43/Makefile b/lang/gnat-gcc43/Makefile
index fa5db3b7fa7b..bdd94cd2a5e3 100644
--- a/lang/gnat-gcc43/Makefile
+++ b/lang/gnat-gcc43/Makefile
@@ -40,7 +40,7 @@ MAN1= cpp${gcc_suffix}.1 \
gcc${gcc_suffix}.1 \
gcov${gcc_suffix}.1
MAN7= ${fsf_mans:S/$/${fsf_suffix}.7/}
-NOMANCOMPRESS= yes # XXX 5-cur and releng4 problems?
+NO_MANCOMPRESS= yes # XXX 5-cur and releng4 problems?
INFO= gcc${gcc_suffix}/cpp \
gcc${gcc_suffix}/cppinternals \
gcc${gcc_suffix}/gcc \
diff --git a/lang/gnat-gcc44/Makefile b/lang/gnat-gcc44/Makefile
index 3586f054c6ce..b77765573195 100644
--- a/lang/gnat-gcc44/Makefile
+++ b/lang/gnat-gcc44/Makefile
@@ -37,7 +37,7 @@ MAN1= cpp${gcc_suffix}.1 \
gcc${gcc_suffix}.1 \
gcov${gcc_suffix}.1
MAN7= ${fsf_mans:S/$/${fsf_suffix}.7/}
-NOMANCOMPRESS= yes # XXX 5-cur and releng4 problems?
+NO_MANCOMPRESS= yes # XXX 5-cur and releng4 problems?
INFO= gcc${gcc_suffix}/cpp \
gcc${gcc_suffix}/cppinternals \
gcc${gcc_suffix}/gcc \