aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-04 15:22:41 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-04-04 15:22:41 +0800
commit390dada2048d514426644ba867ce9680b3a765fe (patch)
tree768a85610ed343d7b1e33b188ccc79913fdf595b /lang
parent395bc5dcf9121996066a0781e4913ad023bf8bfe (diff)
downloadfreebsd-ports-gnome-390dada2048d514426644ba867ce9680b3a765fe.tar.gz
freebsd-ports-gnome-390dada2048d514426644ba867ce9680b3a765fe.tar.zst
freebsd-ports-gnome-390dada2048d514426644ba867ce9680b3a765fe.zip
Add py-lupa 1.9
Lupa integrates the runtimes of Lua or LuaJIT2 into CPython. It is a partial rewrite of LunaticPython in Cython with some additional features such as proper coroutine support. WWW: https://github.com/scoder/lupa
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/py-lupa/Makefile27
-rw-r--r--lang/py-lupa/distinfo3
-rw-r--r--lang/py-lupa/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 7d19f9c8fe95..d706e7309e1f 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -277,6 +277,7 @@
SUBDIR += ptoc
SUBDIR += purescript
SUBDIR += py-hy
+ SUBDIR += py-lupa
SUBDIR += py-mx-base
SUBDIR += py-qt5-qml
SUBDIR += py-textX
diff --git a/lang/py-lupa/Makefile b/lang/py-lupa/Makefile
new file mode 100644
index 000000000000..12aec62a49be
--- /dev/null
+++ b/lang/py-lupa/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= lupa
+PORTVERSION= 1.9
+CATEGORIES= lang python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python wrapper around Lua and LuaJIT
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= lua pkgconfig python
+USE_PYTHON= autoplist concurrent distutils
+
+MAKE_ARGS= --no-bundle
+
+post-patch:
+ @${RM} -fr ${WRKSRC}/third-party
+
+do-test:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py test
+
+.include <bsd.port.mk>
diff --git a/lang/py-lupa/distinfo b/lang/py-lupa/distinfo
new file mode 100644
index 000000000000..af819a4c9a7c
--- /dev/null
+++ b/lang/py-lupa/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585907186
+SHA256 (lupa-1.9.tar.gz) = a3e11d806ca02cf72e490ec1974f8b96a14a1091895c9dccebe0b8d52dd82e8e
+SIZE (lupa-1.9.tar.gz) = 1014812
diff --git a/lang/py-lupa/pkg-descr b/lang/py-lupa/pkg-descr
new file mode 100644
index 000000000000..f980a0244965
--- /dev/null
+++ b/lang/py-lupa/pkg-descr
@@ -0,0 +1,5 @@
+Lupa integrates the runtimes of Lua or LuaJIT2 into CPython. It is a partial
+rewrite of LunaticPython in Cython with some additional features such as proper
+coroutine support.
+
+WWW: https://github.com/scoder/lupa