aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-17 00:34:10 +0800
committerbapt <bapt@FreeBSD.org>2013-09-17 00:34:10 +0800
commit3fc1aa61219646e14f6f511b0448cd785b40d8ae (patch)
treea1d263a21302de503ce146483246c9d1ede8921c /lang
parentca8fd00c3d1e275bcbf43f4904799d17007c6310 (diff)
downloadfreebsd-ports-gnome-3fc1aa61219646e14f6f511b0448cd785b40d8ae.tar.gz
freebsd-ports-gnome-3fc1aa61219646e14f6f511b0448cd785b40d8ae.tar.zst
freebsd-ports-gnome-3fc1aa61219646e14f6f511b0448cd785b40d8ae.zip
Only the default package will be named ruby-<version> now, to stop confusing users
Approved by: ruby (swills)
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby18/Makefile18
-rw-r--r--lang/ruby19/Makefile2
-rw-r--r--lang/ruby20/Makefile2
3 files changed, 4 insertions, 18 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 6f7aec4844fa..e257f339e1a3 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ruby18
-# Date created: 6 May 2001
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
@@ -59,25 +55,14 @@ _SUF2= ,${PORTEPOCH}
_SUF1= _${PORTREVISION}
.endif
-PKGNAMESUFFIX= #empty
-
-#
-# pthreads in earlier versions has problems with malloc after fork
-#
-.if ${OSVERSION} < 702000
-WITHOUT_PTHREADS= yes
-.endif
-
.if defined(WITHOUT_PTHREADS)
CONFIGURE_ARGS+=--disable-pthread
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+nopthreads
.else
LDFLAGS+= ${PTHREAD_LIBS}
CONFIGURE_ARGS+=--enable-pthread
.endif
.if ${PORT_OPTIONS:MONIGURUMA}
-PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+oniguruma
BUILD_DEPENDS+= ${NONEXISTENT}:${ONIGURUMA_PORTDIR}:patch
ONIGURUMA_PORTDIR=${PORTSDIR}/devel/oniguruma
ONIGURUMA_WRKSRC=`cd ${ONIGURUMA_PORTDIR}; ${MAKE} -V WRKSRC`
@@ -99,6 +84,7 @@ CONFIGURE_ARGS+= --disable-install-doc
MLINKS= ${RUBY_NAME}.1 ruby.1
PLIST_SUB+= IF_DEFAULT=""
.else
+PKGNAMESUFFIX= ${RUBY_VER:C/\.//}
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
diff --git a/lang/ruby19/Makefile b/lang/ruby19/Makefile
index d41bd0c062e2..97f334e01008 100644
--- a/lang/ruby19/Makefile
+++ b/lang/ruby19/Makefile
@@ -60,7 +60,6 @@ _SUF2= ,${PORTEPOCH}
_SUF1= _${PORTREVISION}
.endif
-PKGNAMESUFFIX= #empty
CFLAGS+= ${PTHREAD_CFLAGS} # Keep this, else ruby will fail to load
LDFLAGS+= ${PTHREAD_LIBS} # libraries dependent op libpthread.
@@ -81,6 +80,7 @@ CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
MLINKS= ${RUBY_NAME}.1 ruby.1
PLIST_SUB+= IF_DEFAULT=""
.else
+PKGNAMESUFFIX= ${RUBY_VER:C/\.//}
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index 4015f91a3a21..67fb7d24b45c 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -60,7 +60,6 @@ _SUF2= ,${PORTEPOCH}
_SUF1= _${PORTREVISION}
.endif
-PKGNAMESUFFIX= #empty
CFLAGS+= ${PTHREAD_CFLAGS} # Keep this, else ruby will fail to load
LDFLAGS+= ${PTHREAD_LIBS} # libraries dependent op libpthread.
@@ -85,6 +84,7 @@ CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
MLINKS= ${RUBY_NAME}.1 ruby.1
PLIST_SUB+= IF_DEFAULT=""
.else
+PKGNAMESUFFIX= ${RUBY_VER:C/\.//}
PLIST_SUB+= IF_DEFAULT="@comment "
.endif