aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2006-01-08 10:52:06 +0800
committervanilla <vanilla@FreeBSD.org>2006-01-08 10:52:06 +0800
commit4004831c45068cd53262e268ecb4119a2602a660 (patch)
treedcc9d58e9064e6fba143262538db5ea7c2968c1a /lang
parent50625595bddc995ea74da2fc40a1ec15b8c4ee42 (diff)
downloadfreebsd-ports-gnome-4004831c45068cd53262e268ecb4119a2602a660.tar.gz
freebsd-ports-gnome-4004831c45068cd53262e268ecb4119a2602a660.tar.zst
freebsd-ports-gnome-4004831c45068cd53262e268ecb4119a2602a660.zip
1: Upgrade to 7.6.64.
2: use ONLY_FOR_ARCHS, and it's compileable on my amd64 box. PR: ports/91452 Submitted by: maintainer
Diffstat (limited to 'lang')
-rw-r--r--lang/pike76/Makefile8
-rw-r--r--lang/pike76/distinfo6
-rw-r--r--lang/pike76/files/patch-lib-modules-Parser.pmod-XML.pmod-Tree.pmod68
-rw-r--r--lang/pike76/files/patch-modules-Odbc-odbc_result.c73
-rw-r--r--lang/pike76/files/patch-stralloc.c28
-rw-r--r--lang/pike76/files/patch-threads.c30
-rw-r--r--lang/pike76/pkg-plist7
7 files changed, 5 insertions, 215 deletions
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
index d5bcdcd5791a..4c5d04fc92f7 100644
--- a/lang/pike76/Makefile
+++ b/lang/pike76/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pike76
-PORTVERSION= 7.6.50
-PORTREVISION= 2
+PORTVERSION= 7.6.64
CATEGORIES= lang
MASTER_SITES= ftp://pike.ida.liu.se/pub/pike/beta/${PORTVERSION}/ \
ftp://pike.ida.liu.se/pub/pike/all/${PORTVERSION}/ \
@@ -84,10 +83,7 @@ USE_GMAKE= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Build fails on !i386"
-.endif
-
+ONLY_FOR_ARCHS= i386 amd64
PLIST_SUB+= PORTVERSION=${PORTVERSION}
# FreeBSD 5.0 Needs to have libgmp port to support gmp.
diff --git a/lang/pike76/distinfo b/lang/pike76/distinfo
index aefade1fa1db..5325abfbc202 100644
--- a/lang/pike76/distinfo
+++ b/lang/pike76/distinfo
@@ -1,3 +1,3 @@
-MD5 (Pike-v7.6.50.tar.gz) = 20aa2b8ff088733b6c5fc048d47aa712
-SHA256 (Pike-v7.6.50.tar.gz) = 0282adfcdc43dc7feced18415ce165ffc1a1ea288cfb9b343368b170f6445711
-SIZE (Pike-v7.6.50.tar.gz) = 17521150
+MD5 (Pike-v7.6.64.tar.gz) = a325b63a3d8778da3d89961889493c9b
+SHA256 (Pike-v7.6.64.tar.gz) = 79c57c698d05d8979a3db475d35995a62f0a290d552866e5b765c988d8284591
+SIZE (Pike-v7.6.64.tar.gz) = 15197522
diff --git a/lang/pike76/files/patch-lib-modules-Parser.pmod-XML.pmod-Tree.pmod b/lang/pike76/files/patch-lib-modules-Parser.pmod-XML.pmod-Tree.pmod
deleted file mode 100644
index 207094700710..000000000000
--- a/lang/pike76/files/patch-lib-modules-Parser.pmod-XML.pmod-Tree.pmod
+++ /dev/null
@@ -1,68 +0,0 @@
---- lib/modules/Parser.pmod/XML.pmod/Tree.pmod.old Wed Nov 16 12:29:10 2005
-+++ lib/modules/Parser.pmod/XML.pmod/Tree.pmod Wed Nov 16 12:29:14 2005
-@@ -1,7 +1,7 @@
- #pike __REAL_VERSION__
-
- /*
-- * $Id: Tree.pmod,v 1.53 2004/12/21 16:07:07 grubba Exp $
-+ * $Id: Tree.pmod,v 1.54 2005/11/07 14:21:17 nilsson Exp $
- *
- */
-
-@@ -757,11 +757,15 @@
- //!
- static void create(int type, string name, mapping attr, string text)
- {
-- if (name) {
-+ if (name && has_value(name, ":")) {
- sscanf(reverse(name), "%[^/:]", mTagName);
- mTagName=reverse(mTagName);
- mNamespace=name[..sizeof(name)-(1+sizeof(mTagName))];
- }
-+ else {
-+ mTagName = name;
-+ mNamespace = "";
-+ }
- mNodeType = type;
- // mTagCode = kTagMapping[name] || kUnsupportedTagMapping[name];
- mAttributes = attr;
-@@ -1447,25 +1451,27 @@
- // the W3 spec. This is necessary since CDATA sections are
- // converted to text nodes which might need to be concatenated
- // with neighboring text nodes.
-+
- Node text_node;
-- foreach(contents, Node child) {
-+ int(0..1) modified;
-+
-+ foreach(contents; int i; Node child) {
- if (child->get_node_type() == XML_TEXT) {
-- if (text_node)
-+ if (text_node) {
- // Add this text string to the previous text node.
- text_node->_add_to_text (child->get_text());
-+ contents[i]=0;
-+ modified=1;
-+ }
- else
- text_node = child;
-- } else {
-- // Process buffered text before this child is added
-- if (text_node) {
-- node->add_child(text_node);
-- text_node = 0;
-- }
-- node->add_child(child);
-- }
-+ } else
-+ text_node = 0;
- }
-- if (text_node)
-- node->add_child(text_node);
-+
-+ if( modified )
-+ contents -= ({ 0 });
-+ node->replace_children( contents );
- return (node);
-
- case "error":
diff --git a/lang/pike76/files/patch-modules-Odbc-odbc_result.c b/lang/pike76/files/patch-modules-Odbc-odbc_result.c
deleted file mode 100644
index 3e4d39ede5d9..000000000000
--- a/lang/pike76/files/patch-modules-Odbc-odbc_result.c
+++ /dev/null
@@ -1,73 +0,0 @@
---- src/modules/Odbc/odbc_result.c.old Wed Nov 16 10:55:43 2005
-+++ src/modules/Odbc/odbc_result.c Wed Nov 16 10:55:48 2005
-@@ -2,7 +2,7 @@
- || This file is part of Pike. For copyright information see COPYRIGHT.
- || Pike is distributed under GPL, LGPL and MPL. See the file COPYING
- || for more information.
--|| $Id: odbc_result.c,v 1.37 2003/05/02 12:54:37 grubba Exp $
-+|| $Id: odbc_result.c,v 1.38 2005/11/09 13:12:35 grubba Exp $
- */
-
- /*
-@@ -21,7 +21,7 @@
- #include "config.h"
- #endif /* HAVE_CONFIG_H */
-
--RCSID("$Id: odbc_result.c,v 1.37 2003/05/02 12:54:37 grubba Exp $");
-+RCSID("$Id: odbc_result.c,v 1.38 2005/11/09 13:12:35 grubba Exp $");
-
- #include "interpret.h"
- #include "object.h"
-@@ -442,6 +442,18 @@
- push_int(0);
- }
- break;
-+ } else if (code == SQL_SUCCESS_WITH_INFO) {
-+ /* Data truncated. */
-+ num_strings++;
-+#ifdef ODBC_DEBUG
-+ fprintf(stderr, "[%d] ", num_strings);
-+#endif /* ODBC_DEBUG */
-+ if (PIKE_ODBC_RES->field_info[i].type == SQL_C_BINARY) {
-+ push_string(make_shared_binary_string(blob_buf, BLOB_BUFSIZ));
-+ } else {
-+ /* SQL_C_CHAR's are NUL-terminated... */
-+ push_string(make_shared_binary_string(blob_buf, BLOB_BUFSIZ - 1));
-+ }
- } else {
- num_strings++;
- #ifdef ODBC_DEBUG
-@@ -453,15 +465,27 @@
- #endif /* SQL_NO_TOTAL */
- ) {
- push_string(make_shared_binary_string(blob_buf, len));
-- break;
- } else {
-- if (PIKE_ODBC_RES->field_info[i].type == SQL_C_BINARY) {
-- push_string(make_shared_binary_string(blob_buf, BLOB_BUFSIZ));
-- } else {
-- /* SQL_C_CHAR's are NUL-terminated... */
-- push_string(make_shared_binary_string(blob_buf, BLOB_BUFSIZ - 1));
-+ /* Truncated, but no support for chained SQLGetData calls. */
-+ char *buf = xalloc(len+2);
-+ SQLLEN newlen = 0;
-+ code = SQLGetData(PIKE_ODBC_RES->hstmt, (SQLUSMALLINT)(i+1),
-+ PIKE_ODBC_RES->field_info[i].type,
-+ buf, len+1, &newlen);
-+ if (code != SQL_SUCCESS) {
-+ Pike_error("odbc->fetch_row(): "
-+ "Unexpected code from SQLGetData(): %d\n",
-+ code);
- }
-+ if (len != newlen) {
-+ Pike_error("odbc->fetch_row(): "
-+ "Unexpected length from SQLGetData(): "
-+ "%d (expected %d)\n", newlen, len);
-+ }
-+ push_string(make_shared_binary_string(buf, len));
-+ free(buf);
- }
-+ break;
- }
- }
- if (num_strings > 1) {
diff --git a/lang/pike76/files/patch-stralloc.c b/lang/pike76/files/patch-stralloc.c
deleted file mode 100644
index 50c28ad6bd4e..000000000000
--- a/lang/pike76/files/patch-stralloc.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/stralloc.c.old Fri Nov 18 11:06:05 2005
-+++ src/stralloc.c Fri Nov 18 11:06:10 2005
-@@ -2,7 +2,7 @@
- || This file is part of Pike. For copyright information see COPYRIGHT.
- || Pike is distributed under GPL, LGPL and MPL. See the file COPYING
- || for more information.
--|| $Id: stralloc.c,v 1.169 2005/01/19 13:06:57 grubba Exp $
-+|| $Id: stralloc.c,v 1.170 2005/11/18 01:14:22 nilsson Exp $
- */
-
- #include "global.h"
-@@ -24,7 +24,7 @@
- #include <ctype.h>
- #include <math.h>
-
--RCSID("$Id: stralloc.c,v 1.169 2005/01/19 13:06:57 grubba Exp $");
-+RCSID("$Id: stralloc.c,v 1.170 2005/11/18 01:14:22 nilsson Exp $");
-
- /* #define STRALLOC_USE_PRIMES */
-
-@@ -1596,6 +1596,7 @@
- add_ref(a = old);
- } else {
- link_pike_string(a, a->hval);
-+ add_ref(a);
- }
- return a;
- }else{
diff --git a/lang/pike76/files/patch-threads.c b/lang/pike76/files/patch-threads.c
deleted file mode 100644
index b5fe8507c97e..000000000000
--- a/lang/pike76/files/patch-threads.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/threads.c.old Wed Nov 16 10:58:57 2005
-+++ src/threads.c Wed Nov 16 10:59:00 2005
-@@ -2,12 +2,12 @@
- || This file is part of Pike. For copyright information see COPYRIGHT.
- || Pike is distributed under GPL, LGPL and MPL. See the file COPYING
- || for more information.
--|| $Id: threads.c,v 1.238 2005/05/18 12:36:54 mast Exp $
-+|| $Id: threads.c,v 1.239 2005/11/15 10:31:56 grubba Exp $
- */
-
- #ifndef CONFIGURE_TEST
- #include "global.h"
--RCSID("$Id: threads.c,v 1.238 2005/05/18 12:36:54 mast Exp $");
-+RCSID("$Id: threads.c,v 1.239 2005/11/15 10:31:56 grubba Exp $");
-
- PMOD_EXPORT int num_threads = 1;
- PMOD_EXPORT int threads_disabled = 0;
-@@ -1460,9 +1460,10 @@
- THIS_KEY->mutex_obj = NULL;
- if (mut->num_waiting)
- co_signal(&mut->condition);
-- else if (!mutex_obj->prog)
-+ else if (mutex_obj && !mutex_obj->prog)
- co_destroy (&mut->condition);
-- free_object(mutex_obj);
-+ if (mutex_obj)
-+ free_object(mutex_obj);
- }
- }
-
diff --git a/lang/pike76/pkg-plist b/lang/pike76/pkg-plist
index 7c0ab52a443d..06382ec4b711 100644
--- a/lang/pike76/pkg-plist
+++ b/lang/pike76/pkg-plist
@@ -13,24 +13,17 @@ pike/%%PORTVERSION%%/lib/modules/Parser.pmod/Pike.pmod
pike/%%PORTVERSION%%/lib/modules/Parser.pmod/C.pmod
pike/%%PORTVERSION%%/lib/modules/Parser.pmod/module.pmod
pike/%%PORTVERSION%%/lib/modules/Java.pmod
-pike/%%PORTVERSION%%/lib/modules/___Java.so
pike/%%PORTVERSION%%/lib/modules/MIME.pmod/ext_to_media_type.pmod.o
pike/%%PORTVERSION%%/lib/modules/MIME.pmod/ext_to_media_type.pmod
pike/%%PORTVERSION%%/lib/modules/MIME.pmod/module.pmod.o
pike/%%PORTVERSION%%/lib/modules/MIME.pmod/module.pmod
pike/%%PORTVERSION%%/lib/modules/Math.pmod
-pike/%%PORTVERSION%%/lib/modules/___Math.so
pike/%%PORTVERSION%%/lib/modules/Mird.pmod
-pike/%%PORTVERSION%%/lib/modules/___Mird.so
pike/%%PORTVERSION%%/lib/modules/Oracle.pmod
-pike/%%PORTVERSION%%/lib/modules/___Oracle.so
pike/%%PORTVERSION%%/lib/modules/__builtin_dirnode.pmod
pike/%%PORTVERSION%%/lib/modules/Regexp.pmod
-pike/%%PORTVERSION%%/lib/modules/___Regexp.so
pike/%%PORTVERSION%%/lib/modules/Yp.pmod
-pike/%%PORTVERSION%%/lib/modules/___Yp.so
pike/%%PORTVERSION%%/lib/modules/_Charset.pmod
-pike/%%PORTVERSION%%/lib/modules/____Charset.so
%%SYBASE:%%pike/%%PORTVERSION%%/lib/modules/sybase.so
pike/%%PORTVERSION%%/lib/modules/Colors.pmod
pike/%%PORTVERSION%%/lib/modules/Array.pmod