aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
committermadpilot <madpilot@FreeBSD.org>2013-09-05 02:06:07 +0800
commit41290677b018da2819144b0188ac8bd1b91a88e4 (patch)
treef71b3671c7729b9cbc9368cea2f2fede7b20d5c8 /lang
parent02239bfdfc92a832c32cc57d07d3a1a4b3fc4ad9 (diff)
downloadfreebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.gz
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.tar.zst
freebsd-ports-gnome-41290677b018da2819144b0188ac8bd1b91a88e4.zip
- Make ports use the libc provided iconv implementation on 10-CURRENT
after r254273 - Fix a bunch of ports to properly work after this - Mark converters/libiconv as IGNORE for systems with iconv in libc Reviewed by: bapt Approved by: portmgr (bapt) Discussed with: bapt, bsam (who both contributed ideas and code)
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile.ext5
-rw-r--r--lang/php52/Makefile.ext6
-rw-r--r--lang/php53/Makefile.ext5
-rw-r--r--lang/php55/Makefile.ext5
4 files changed, 8 insertions, 13 deletions
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index f044b0794128..a054d0229dfe 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -126,7 +126,7 @@ CONFIGURE_ARGS+=--enable-hash \
.endif
.if ${PHP_MODNAME} == "iconv"
-CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
+CONFIGURE_ARGS+=--with-iconv
USES+= iconv
.endif
@@ -424,8 +424,7 @@ USE_PHP_BUILD= yes
.if ${PHP_MODNAME} == "xmlrpc"
CONFIGURE_ARGS+=--with-xmlrpc \
- --with-libxml-dir=${LOCALBASE} \
- --with-iconv-dir=${LOCALBASE}
+ --with-libxml-dir=${LOCALBASE}
USES+= iconv
USE_GNOME= libxml2
diff --git a/lang/php52/Makefile.ext b/lang/php52/Makefile.ext
index ae1c4a11e001..af2a744054e9 100644
--- a/lang/php52/Makefile.ext
+++ b/lang/php52/Makefile.ext
@@ -135,8 +135,7 @@ CONFIGURE_ARGS+=--enable-hash
.endif
.if ${PHP_MODNAME} == "iconv"
-CONFIGURE_ARGS+=--with-iconv=${LOCALBASE} \
- --with-iconv-dir=${LOCALBASE}
+CONFIGURE_ARGS+=--with-iconv
USES+= iconv
.endif
@@ -482,8 +481,7 @@ USE_PHP_BUILD= yes
.if ${PHP_MODNAME} == "xmlrpc"
CONFIGURE_ARGS+=--with-xmlrpc \
- --with-libxml-dir=${LOCALBASE} \
- --with-iconv-dir=${LOCALBASE}
+ --with-libxml-dir=${LOCALBASE}
USES+= iconv
USE_GNOME= libxml2
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index bffe0ed6a8e7..753324cf47a6 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -125,7 +125,7 @@ CONFIGURE_ARGS+=--enable-hash \
.endif
.if ${PHP_MODNAME} == "iconv"
-CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
+CONFIGURE_ARGS+=--with-iconv
USES+= iconv
.endif
@@ -429,8 +429,7 @@ USE_PHP_BUILD= yes
.if ${PHP_MODNAME} == "xmlrpc"
CONFIGURE_ARGS+=--with-xmlrpc \
- --with-libxml-dir=${LOCALBASE} \
- --with-iconv-dir=${LOCALBASE}
+ --with-libxml-dir=${LOCALBASE}
USES+= iconv
USE_GNOME= libxml2
diff --git a/lang/php55/Makefile.ext b/lang/php55/Makefile.ext
index daabaef48fcf..934ba6572d96 100644
--- a/lang/php55/Makefile.ext
+++ b/lang/php55/Makefile.ext
@@ -126,7 +126,7 @@ CONFIGURE_ARGS+=--enable-hash \
.endif
.if ${PHP_MODNAME} == "iconv"
-CONFIGURE_ARGS+=--with-iconv=${LOCALBASE}
+CONFIGURE_ARGS+=--with-iconv
USES+= iconv
.endif
@@ -424,8 +424,7 @@ USE_PHP_BUILD= yes
.if ${PHP_MODNAME} == "xmlrpc"
CONFIGURE_ARGS+=--with-xmlrpc \
- --with-libxml-dir=${LOCALBASE} \
- --with-iconv-dir=${LOCALBASE}
+ --with-libxml-dir=${LOCALBASE}
USES+= iconv
USE_GNOME= libxml2