aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2016-08-25 11:00:13 +0800
committerwen <wen@FreeBSD.org>2016-08-25 11:00:13 +0800
commit4b014fb9c8606095dde98e0eabd1b774a4142467 (patch)
tree3aa618fcdc2e73cb6a2f2cd2ead4b103fb94cfb2 /lang
parent64d28d41f61d3874de3c4627d29d175da1942a15 (diff)
downloadfreebsd-ports-gnome-4b014fb9c8606095dde98e0eabd1b774a4142467.tar.gz
freebsd-ports-gnome-4b014fb9c8606095dde98e0eabd1b774a4142467.tar.zst
freebsd-ports-gnome-4b014fb9c8606095dde98e0eabd1b774a4142467.zip
- Update to 0.8.12
- Switch to USE_GITHUB - Add missing BUILD_DEPENDS PR: 210447 Submitted by: estrabd@gmail.com(maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/qore/Makefile26
-rw-r--r--lang/qore/distinfo5
-rw-r--r--lang/qore/pkg-plist68
3 files changed, 58 insertions, 41 deletions
diff --git a/lang/qore/Makefile b/lang/qore/Makefile
index 03c0b3e7980a..cef5a3c5fc60 100644
--- a/lang/qore/Makefile
+++ b/lang/qore/Makefile
@@ -1,26 +1,28 @@
# $FreeBSD$
PORTNAME= qore
-PORTVERSION= 0.8.11
+PORTVERSION= 0.8.12
CATEGORIES= lang
-MASTER_SITES= SF/qore/qore/${PORTVERSION}/
MAINTAINER= estrabd@gmail.com
-COMMENT= The Qore Programming Language
+COMMENT= Qore Programming Language
-LICENSE= GPLv2
-
-BROKEN_powerpc64= Does not build
+LICENSE= MIT
LIB_DEPENDS= libpcre.so:devel/pcre \
libmpfr.so:math/mpfr
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:textproc/flex \
- ${LOCALBASE}/bin/bison:devel/bison
+ ${LOCALBASE}/bin/bison:devel/bison \
+ ${LOCALBASE}/bin/bash:shells/bash
-USES= gmake iconv libtool pathfix tar:bzip2
+BROKEN_powerpc64= Does not build
+
+USES= gmake iconv libtool:build pathfix autoreconf
USE_OPENSSL= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= qorelanguage
CONFIGURE_ENV= LEX="${LOCALBASE}/bin/flex" PTHREAD_LIBS="-lpthread"
CONFIGURE_ARGS= --disable-debug --disable-static --with-doxygen=no
@@ -32,10 +34,14 @@ INSTALL_TARGET= install-strip
.include <bsd.port.pre.mk>
.if ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
+BROKEN= Does not compile on powerpc
.endif
-post-patch:
+pre-configure:
+ cd ${WRKSRC}; ./reconf.sh
+
+post-configure:
${REINPLACE_CMD} -e 's|; make|; $${MAKE}|g' ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e 's#$$(libdir)/pkgconfig#${PREFIX}/libdata/pkgconfig#g' ${WRKSRC}/Makefile.in
.include <bsd.port.post.mk>
diff --git a/lang/qore/distinfo b/lang/qore/distinfo
index 9fc05a840aba..698c502f5525 100644
--- a/lang/qore/distinfo
+++ b/lang/qore/distinfo
@@ -1,2 +1,3 @@
-SHA256 (qore-0.8.11.tar.bz2) = ce55fe2fa2bb85fd77cefe45d190d431fa5c6dcbd00cc4be499082130b755ae3
-SIZE (qore-0.8.11.tar.bz2) = 20074057
+TIMESTAMP = 1471951711
+SHA256 (qorelanguage-qore-0.8.12_GH0.tar.gz) = e5e59753810736bafe57f15d1035bc3d12a612d3768f9ae6d7b9bdc8fab94ad6
+SIZE (qorelanguage-qore-0.8.12_GH0.tar.gz) = 2489956
diff --git a/lang/qore/pkg-plist b/lang/qore/pkg-plist
index 1dc06f19e522..542b1d4e7ab7 100644
--- a/lang/qore/pkg-plist
+++ b/lang/qore/pkg-plist
@@ -28,7 +28,8 @@ include/qore/QoreFloatNode.h
include/qore/QoreFtpClient.h
include/qore/QoreHTTPClient.h
include/qore/QoreHashNode.h
-include/qore/QoreQueueHelper.h
+include/qore/QoreHttpClientObject.h
+include/qore/QoreIteratorBase.h
include/qore/QoreLib.h
include/qore/QoreListNode.h
include/qore/QoreNamespace.h
@@ -39,12 +40,15 @@ include/qore/QoreNullNode.h
include/qore/QoreNumberNode.h
include/qore/QoreObject.h
include/qore/QoreProgram.h
+include/qore/QoreQueue.h
+include/qore/QoreQueueHelper.h
include/qore/QoreRWLock.h
include/qore/QoreReferenceCounter.h
include/qore/QoreSSLBase.h
include/qore/QoreSSLCertificate.h
include/qore/QoreSSLPrivateKey.h
include/qore/QoreSocket.h
+include/qore/QoreSocketObject.h
include/qore/QoreString.h
include/qore/QoreStringNode.h
include/qore/QoreThreadLocalStorage.h
@@ -52,6 +56,8 @@ include/qore/QoreThreadLock.h
include/qore/QoreType.h
include/qore/QoreTypeSafeReferenceHelper.h
include/qore/QoreURL.h
+include/qore/QoreValue.h
+include/qore/QoreValueList.h
include/qore/ReferenceArgumentHelper.h
include/qore/ReferenceHolder.h
include/qore/ReferenceNode.h
@@ -62,49 +68,53 @@ include/qore/SystemEnvironment.h
include/qore/common.h
include/qore/macros-i386.h
include/qore/macros-ia64.h
+include/qore/macros-parisc.h
include/qore/macros-powerpc.h
include/qore/macros-sparc.h
include/qore/macros-x86_64.h
include/qore/macros.h
include/qore/node_types.h
include/qore/params.h
+include/qore/qlist
include/qore/qore-version.h
include/qore/qore_bitopts.h
include/qore/qore_thread.h
include/qore/safe_dslist
include/qore/support.h
-include/qore/QoreHttpClientObject.h
-include/qore/QoreIteratorBase.h
-include/qore/QoreQueue.h
-include/qore/QoreSocketObject.h
-include/qore/qlist
lib/cmake/Qore/QoreConfig.cmake
lib/cmake/Qore/QoreConfigVersion.cmake
lib/cmake/Qore/QoreMacros.cmake
lib/libqore.so
lib/libqore.so.5
-lib/libqore.so.5.12.2
-lib/qore-modules/%%PORTVERSION%%/CsvUtil.qm
-lib/qore-modules/%%PORTVERSION%%/HttpServer.qm
-lib/qore-modules/%%PORTVERSION%%/MailMessage.qm
-lib/qore-modules/%%PORTVERSION%%/Mapper.qm
-lib/qore-modules/%%PORTVERSION%%/Mime.qm
-lib/qore-modules/%%PORTVERSION%%/MysqlSqlUtil.qm
-lib/qore-modules/%%PORTVERSION%%/OracleSqlUtil.qm
-lib/qore-modules/%%PORTVERSION%%/PgsqlSqlUtil.qm
-lib/qore-modules/%%PORTVERSION%%/Pop3Client.qm
-lib/qore-modules/%%PORTVERSION%%/Qorize.qm
-lib/qore-modules/%%PORTVERSION%%/RestClient.qm
-lib/qore-modules/%%PORTVERSION%%/RestHandler.qm
-lib/qore-modules/%%PORTVERSION%%/Schema.qm
-lib/qore-modules/%%PORTVERSION%%/SmtpClient.qm
-lib/qore-modules/%%PORTVERSION%%/SqlUtil.qm
-lib/qore-modules/%%PORTVERSION%%/TableMapper.qm
-lib/qore-modules/%%PORTVERSION%%/TelnetClient.qm
-lib/qore-modules/%%PORTVERSION%%/Util.qm
-lib/qore-modules/%%PORTVERSION%%/WebSocketClient.qm
-lib/qore-modules/%%PORTVERSION%%/WebSocketHandler.qm
-lib/qore-modules/%%PORTVERSION%%/WebSocketUtil.qm
-lib/qore-modules/%%PORTVERSION%%/WebUtil.qm
+lib/libqore.so.5.13.0
libdata/pkgconfig/qore.pc
man/man1/qore.1.gz
+%%DATADIR%%-modules/%%PORTVERSION%%/BulkSqlUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/CsvUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/Diff.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/FilePoller.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/FixedLengthUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/FreetdsSqlUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/HttpServer.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/HttpServerUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/MailMessage.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/Mapper.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/Mime.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/MysqlSqlUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/OracleSqlUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/PgsqlSqlUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/Pop3Client.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/QUnit.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/Qorize.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/RestClient.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/RestHandler.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/Schema.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/SmtpClient.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/SqlUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/TableMapper.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/TelnetClient.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/Util.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/WebSocketClient.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/WebSocketHandler.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/WebSocketUtil.qm
+%%DATADIR%%-modules/%%PORTVERSION%%/WebUtil.qm