aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-04-04 19:11:50 +0800
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2020-04-04 19:11:50 +0800
commit4dba87e83cd94e5593da562cc5153b9686d37572 (patch)
tree90c83c9808b30cfb525694f31c0f7c54f388a724 /lang
parent5e8038848ae8e76f61e0a767d8cfdeef40c794b7 (diff)
downloadfreebsd-ports-gnome-4dba87e83cd94e5593da562cc5153b9686d37572.tar.gz
freebsd-ports-gnome-4dba87e83cd94e5593da562cc5153b9686d37572.tar.zst
freebsd-ports-gnome-4dba87e83cd94e5593da562cc5153b9686d37572.zip
lang/nim: Update to 1.2.0
- Remove files/patch-koch.nim (This patch is not needed to build nim and tools) - Update files/patch-install.sh and files/patch-config-nim.cfg - Unbreak arm (fixed upstream) [1] - Add all optional tools - Order pkg-plist - Move USES (pet portlint) [1] https://github.com/nim-lang/Nim/pull/13822 Changelog: - https://nim-lang.org/blog/2020/04/03/version-120-released.html PR: 245328 Approved by: tcberner (mentor), Neal Nelson (maintainer) Differential Revision: https://reviews.freebsd.org/D24294
Diffstat (limited to 'lang')
-rw-r--r--lang/nim/Makefile16
-rw-r--r--lang/nim/distinfo6
-rw-r--r--lang/nim/files/patch-config-nim.cfg19
-rw-r--r--lang/nim/files/patch-install.sh10
-rw-r--r--lang/nim/files/patch-koch.nim109
-rw-r--r--lang/nim/pkg-plist52
6 files changed, 60 insertions, 152 deletions
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index 6df9426b548e..74a5d67af6b2 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nim
-PORTVERSION= 1.0.6
+PORTVERSION= 1.2.0
CATEGORIES= lang
MASTER_SITES= https://nim-lang.org/download/
@@ -12,26 +12,26 @@ COMMENT= Nim programming language
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/copying.txt
-BROKEN_aarch64= fails to compile: crt1.c: undefined reference to main
-BROKEN_armv6= fails to compile: crt1.c: undefined reference to main
-BROKEN_armv7= fails to compile: crt1.c: undefined reference to main
BROKEN_mips64= fails to build: build.sh: clang: not found
BROKEN_sparc64= fails to build: build.sh: clang: not found
-TOOLS_DESC= Build and install nimgrep and nimsuggest
+USES= compiler tar:xz
+
+TOOLS_DESC= Build and install nim tools
OPTIONS_DEFINE= DOCS TOOLS
+OPTIONS_DEFAULT= DOCS TOOLS
+
OPTIONS_SUB= yes
MAKE_JOBS_UNSAFE= yes
-USES= compiler tar:xz
.include <bsd.port.pre.mk>
-TLIST= nimgrep nimsuggest
+TLIST= nimfind nimgrep nimpretty nimsuggest testament
.if ${ARCH} == "powerpc64"
-. if defined(PPC_ABI) && ${PPC_ABI} == ELFv1
+. if defined(PPC_ABI) && ${PPC_ABI} == ELFv1
EXTRA_PATCHES= ${PATCHDIR}/elfv1-patch-build.sh
. endif
.endif
diff --git a/lang/nim/distinfo b/lang/nim/distinfo
index dfdb3bcb45c8..707dd93bbd14 100644
--- a/lang/nim/distinfo
+++ b/lang/nim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1580488025
-SHA256 (nim-1.0.6.tar.xz) = 134e5751cf62fa189f76616a698ce0df4b4a0c1419ec0b582924087e585f66b3
-SIZE (nim-1.0.6.tar.xz) = 5153708
+TIMESTAMP = 1585934270
+SHA256 (nim-1.2.0.tar.xz) = 4e94583a373965821805e665e0a05f52fb610916676edb09148941415637c575
+SIZE (nim-1.2.0.tar.xz) = 5869428
diff --git a/lang/nim/files/patch-config-nim.cfg b/lang/nim/files/patch-config-nim.cfg
index 0ff00533ee84..f7959f5635bf 100644
--- a/lang/nim/files/patch-config-nim.cfg
+++ b/lang/nim/files/patch-config-nim.cfg
@@ -1,4 +1,4 @@
---- config/nim.cfg.orig 2019-07-22 09:41:23 UTC
+--- config/nim.cfg.orig 2020-04-03 17:22:53 UTC
+++ config/nim.cfg
@@ -8,7 +8,7 @@
# Environment variables can be accessed like so:
@@ -9,25 +9,16 @@
# additional options always passed to the compiler:
--parallel_build: "0" # 0 to auto-detect number of processors
-@@ -105,12 +105,6 @@ path="$lib/pure"
+@@ -118,12 +118,6 @@ path="$lib/pure"
+ clang.options.linker = "-ldl"
clang.cpp.options.linker = "-ldl"
tcc.options.linker = "-ldl"
- @end
+- @end
- @if bsd:
- # BSD got posix_spawn only recently, so we deactivate it for osproc:
- define:useFork
- # at least NetBSD has problems with thread local storage:
- tlsEmulation:on
-- @end
+ @end
@if haiku:
gcc.options.linker = "-Wl,--as-needed -lnetwork"
- gcc.cpp.options.linker = "-Wl,--as-needed -lnetwork"
-@@ -132,7 +126,7 @@ path="$lib/pure"
- @end
-
- @if nintendoswitch:
-- cc = "switch_gcc"
-+ cc = "switch_clang"
- switch_gcc.options.linker = "-g -march=armv8-a -mtune=cortex-a57 -mtp=soft -fPIE"
- switch_gcc.cpp.options.linker = "-g -march=armv8-a -mtune=cortex-a57 -mtp=soft -fPIE"
- switch_gcc.options.always = "-g -Wall -O2 -ffunction-sections -march=armv8-a -mtune=cortex-a57 -mtp=soft -fPIE -D__SWITCH__"
diff --git a/lang/nim/files/patch-install.sh b/lang/nim/files/patch-install.sh
index 61943d414f83..5b6a8f913327 100644
--- a/lang/nim/files/patch-install.sh
+++ b/lang/nim/files/patch-install.sh
@@ -1,4 +1,4 @@
---- install.sh.orig 2020-01-31 16:27:59 UTC
+--- install.sh.orig 2020-04-03 17:25:49 UTC
+++ install.sh
@@ -15,48 +15,14 @@ if [ $# -eq 1 ] ; then
"--help"|"-h"|"help"|"h")
@@ -19,7 +19,7 @@
- libdir=/usr/lib/nim
- docdir=/usr/share/nim/doc
- datadir=/usr/share/nim/data
-- nimbleDir="/opt/nimble/pkgs/compiler-1.0.6"
+- nimbleDir="/opt/nimble/pkgs/compiler-1.2.0"
- ;;
- "/usr/local/bin")
- bindir=/usr/local/bin
@@ -27,7 +27,7 @@
- libdir=/usr/local/lib/nim
- docdir=/usr/local/share/nim/doc
- datadir=/usr/local/share/nim/data
-- nimbleDir="/opt/nimble/pkgs/compiler-1.0.6"
+- nimbleDir="/opt/nimble/pkgs/compiler-1.2.0"
- ;;
- "/opt")
- bindir="/opt/nim/bin"
@@ -35,7 +35,7 @@
- libdir="/opt/nim/lib"
- docdir="/opt/nim/doc"
- datadir="/opt/nim/data"
-- nimbleDir="/opt/nimble/pkgs/compiler-1.0.6"
+- nimbleDir="/opt/nimble/pkgs/compiler-1.2.0"
- mkdir -p /opt/nim
- mkdir -p $bindir
- mkdir -p $configdir
@@ -54,7 +54,7 @@
nimbleDir="$1/nim"
mkdir -p $1/nim
mkdir -p $bindir
-@@ -923,13 +889,6 @@ chmod 644 $nimbleDir/compiler.nimble
+@@ -973,13 +939,6 @@ chmod 644 $nimbleDir/compiler.nimble
else
echo "Nim installation script"
echo "Usage: [sudo] sh install.sh DIR"
diff --git a/lang/nim/files/patch-koch.nim b/lang/nim/files/patch-koch.nim
deleted file mode 100644
index 3e8a494469fa..000000000000
--- a/lang/nim/files/patch-koch.nim
+++ /dev/null
@@ -1,109 +0,0 @@
---- koch.nim.orig 2019-07-22 09:56:30 UTC
-+++ koch.nim
-@@ -43,15 +43,11 @@ Usage:
- koch [options] command [options for command]
- Options:
- --help, -h shows this help and quits
-- --latest bundle the installers with a bleeding edge Nimble
-- --stable bundle the installers with a stable Nimble (default)
- Possible Commands:
- boot [options] bootstraps with given command line options
- distrohelper [bindir] helper for distro packagers
-- tools builds Nim related tools
-- toolsNoNimble builds Nim related tools (except nimble)
-+ tools builds Nim related tools (except nimble)
- doesn't require network connectivity
-- nimble builds the Nimble tool
- Boot options:
- -d:release produce a release version of the compiler
- -d:useLinenoise use the linenoise library for interactive mode
-@@ -127,41 +123,6 @@ proc bundleC2nim(args: string) =
- nimCompile("dist/c2nim/c2nim",
- options = "--noNimblePath --path:. " & args)
-
--proc bundleNimbleExe(latest: bool, args: string) =
-- if not dirExists("dist/nimble/.git"):
-- exec("git clone https://github.com/nim-lang/nimble.git dist/nimble")
-- if not latest:
-- withDir("dist/nimble"):
-- exec("git fetch")
-- exec("git checkout " & NimbleStableCommit)
-- # installer.ini expects it under $nim/bin
-- nimCompile("dist/nimble/src/nimble.nim",
-- options = "-d:release --nilseqs:on " & args)
--
--proc buildNimble(latest: bool, args: string) =
-- # if koch is used for a tar.xz, build the dist/nimble we shipped
-- # with the tarball:
-- var installDir = "dist/nimble"
-- if not latest and dirExists(installDir) and not dirExists("dist/nimble/.git"):
-- discard "don't do the git dance"
-- else:
-- if not dirExists("dist/nimble/.git"):
-- if dirExists(installDir):
-- var id = 0
-- while dirExists("dist/nimble" & $id):
-- inc id
-- installDir = "dist/nimble" & $id
-- exec("git clone https://github.com/nim-lang/nimble.git " & installDir)
-- withDir(installDir):
-- if latest:
-- exec("git checkout -f master")
-- exec("git pull")
-- else:
-- exec("git fetch")
-- exec("git checkout " & NimbleStableCommit)
-- nimCompile(installDir / "src/nimble.nim",
-- options = "--noNimblePath --nilseqs:on -d:release " & args)
--
- proc bundleNimsuggest(args: string) =
- nimCompileFold("Compile nimsuggest", "nimsuggest/nimsuggest.nim",
- options = "-d:release -d:danger " & args)
-@@ -182,7 +143,6 @@ proc bundleWinTools(args: string) =
- options = r"--cc:vcc --app:gui -d:ssl --noNimblePath --path:..\ui " & args)
-
- proc zip(latest: bool; args: string) =
-- bundleNimbleExe(latest, args)
- bundleNimsuggest(args)
- bundleWinTools(args)
- nimexec("cc -r $2 --var:version=$1 --var:mingw=none --main:compiler/nim.nim scripts compiler/installer.ini" %
-@@ -219,7 +179,6 @@ proc buildTools(args: string = "") =
- options = "-d:release " & args)
-
- proc nsis(latest: bool; args: string) =
-- bundleNimbleExe(latest, args)
- bundleNimsuggest(args)
- bundleWinTools(args)
- # make sure we have generated the niminst executables:
-@@ -466,8 +425,6 @@ proc runCI(cmd: string) =
- # boot without -d:nimHasLibFFI to make sure this still works
- kochExecFold("Boot in release mode", "boot -d:release -d:danger")
-
-- ## build nimble early on to enable remainder to depend on it if needed
-- kochExecFold("Build Nimble", "nimble")
-
- when false:
- execFold("nimble install -y libffi", "nimble install -y libffi")
-@@ -588,8 +545,6 @@ when isMainModule:
- case op.kind
- of cmdLongOption, cmdShortOption:
- case normalize(op.key)
-- of "latest": latest = true
-- of "stable": latest = false
- else: showHelp()
- of cmdArgument:
- case normalize(op.key)
-@@ -613,13 +568,9 @@ when isMainModule:
- of "temp": temp(op.cmdLineRest)
- of "xtemp": xtemp(op.cmdLineRest)
- of "wintools": bundleWinTools(op.cmdLineRest)
-- of "nimble": buildNimble(latest, op.cmdLineRest)
- of "nimsuggest": bundleNimsuggest(op.cmdLineRest)
-- of "toolsnonimble":
-- buildTools(op.cmdLineRest)
- of "tools":
- buildTools(op.cmdLineRest)
-- buildNimble(latest, op.cmdLineRest)
- of "pushcsource", "pushcsources": pushCsources()
- of "valgrind": valgrind(op.cmdLineRest)
- of "c2nim": bundleC2nim(op.cmdLineRest)
diff --git a/lang/nim/pkg-plist b/lang/nim/pkg-plist
index f9e4cbdbfaa5..1967fd91b2e6 100644
--- a/lang/nim/pkg-plist
+++ b/lang/nim/pkg-plist
@@ -1,18 +1,19 @@
bin/nim
-etc/nim/nim.cfg
-etc/nim/nimdoc.cfg
-etc/nim/nimdoc.tex.cfg
+%%TOOLS%%bin/nimfind
+%%TOOLS%%bin/nimgrep
+%%TOOLS%%bin/nimpretty
+%%TOOLS%%bin/nimsuggest
+%%TOOLS%%bin/testament
+%%ETCDIR%%/nim.cfg
+%%ETCDIR%%/nimdoc.cfg
+%%ETCDIR%%/nimdoc.tex.cfg
lib/arch/x86/amd64.S
lib/arch/x86/i386.S
-lib/core/allocators.nim
lib/core/hotcodereloading.nim
lib/core/locks.nim
lib/core/macrocache.nim
lib/core/macros.nim
lib/core/rlocks.nim
-lib/core/runtime_v2.nim
-lib/core/seqs.nim
-lib/core/strs.nim
lib/core/typeinfo.nim
lib/cycle.h
lib/deprecated/pure/LockFreeHash.nim
@@ -32,8 +33,6 @@ lib/impure/db_postgres.nim
lib/impure/db_sqlite.nim
lib/impure/nre.nim
lib/impure/nre/private/util.nim
-lib/impure/osinfo_posix.nim
-lib/impure/osinfo_win.nim
lib/impure/rdstdin.nim
lib/impure/re.nim
lib/js/asyncjs.nim
@@ -62,6 +61,7 @@ lib/posix/posix_linux_amd64_consts.nim
lib/posix/posix_macos_amd64.nim
lib/posix/posix_nintendoswitch.nim
lib/posix/posix_nintendoswitch_consts.nim
+lib/posix/posix_openbsd_amd64.nim
lib/posix/posix_other.nim
lib/posix/posix_other_consts.nim
lib/posix/posix_utils.nim
@@ -166,6 +166,7 @@ lib/pure/segfaults.nim
lib/pure/selectors.nim
lib/pure/smtp.nim
lib/pure/smtp.nim.cfg
+lib/pure/ssl_certs.nim
lib/pure/stats.nim
lib/pure/streams.nim
lib/pure/strformat.nim
@@ -186,30 +187,43 @@ lib/pure/uri.nim
lib/pure/volatile.nim
lib/pure/xmlparser.nim
lib/pure/xmltree.nim
+lib/std/compilesettings.nim
+lib/std/decls.nim
lib/std/editdistance.nim
+lib/std/logic.nim
lib/std/monotimes.nim
+lib/std/private/underscored_calls.nim
lib/std/sha1.nim
+lib/std/stackframes.nim
lib/std/sums.nim
lib/std/time_t.nim
lib/std/varints.nim
+lib/std/with.nim
lib/std/wordwrap.nim
+lib/std/wrapnils.nim
lib/stdlib.nimble
lib/system.nim
lib/system/alloc.nim
lib/system/ansi_c.nim
lib/system/arithm.nim
+lib/system/arithmetics.nim
lib/system/assertions.nim
lib/system/assign.nim
lib/system/atomics.nim
lib/system/avltree.nim
+lib/system/basic_types.nim
lib/system/cellsets.nim
lib/system/cgprocs.nim
lib/system/channels.nim
lib/system/chcks.nim
+lib/system/comparisons.nim
+lib/system/cyclebreaker.nim
+lib/system/cyclicrefs_v2.nim
lib/system/deepcopy.nim
lib/system/dollars.nim
lib/system/dyncalls.nim
lib/system/embedded.nim
+lib/system/exceptions.nim
lib/system/excpt.nim
lib/system/fatal.nim
lib/system/formatfloat.nim
@@ -217,25 +231,38 @@ lib/system/gc.nim
lib/system/gc2.nim
lib/system/gc_common.nim
lib/system/gc_hooks.nim
+lib/system/gc_interface.nim
lib/system/gc_ms.nim
lib/system/gc_regions.nim
lib/system/hti.nim
lib/system/inclrtl.nim
lib/system/indexerrors.nim
+lib/system/integerops.nim
lib/system/io.nim
lib/system/iterators.nim
+lib/system/iterators_1.nim
lib/system/jssys.nim
+lib/system/memalloc.nim
lib/system/memory.nim
lib/system/memtracker.nim
+lib/system/mm/boehm.nim
+lib/system/mm/go.nim
+lib/system/mm/malloc.nim
+lib/system/mm/none.nim
lib/system/mmdisp.nim
lib/system/nimscript.nim
lib/system/osalloc.nim
lib/system/platforms.nim
lib/system/profiler.nim
+lib/system/refs_v2.nim
lib/system/repr.nim
+lib/system/repr_v2.nim
lib/system/reprjs.nim
+lib/system/seqs_v2.nim
+lib/system/setops.nim
lib/system/sets.nim
lib/system/strmantle.nim
+lib/system/strs_v2.nim
lib/system/syslocks.nim
lib/system/sysspawn.nim
lib/system/sysstr.nim
@@ -283,7 +310,6 @@ nim/compiler/closureiters.nim
nim/compiler/cmdlinehelper.nim
nim/compiler/commands.nim
nim/compiler/condsyms.nim
-nim/compiler/configuration.nim
nim/compiler/debuginfo.nim
nim/compiler/depends.nim
nim/compiler/dfa.nim
@@ -383,7 +409,9 @@ nim/compiler/semtypes.nim
nim/compiler/semtypinst.nim
nim/compiler/sighashes.nim
nim/compiler/sigmatch.nim
+nim/compiler/sinkparameter_inference.nim
nim/compiler/sizealignoffsetimpl.nim
+nim/compiler/sourcemap.nim
nim/compiler/spawn.nim
nim/compiler/suggest.nim
nim/compiler/syntaxes.nim
@@ -405,7 +433,5 @@ nim/compiler/wordrecg.nim
nim/compiler/writetracking.nim
nim/doc/advopt.txt
nim/doc/basicopt.txt
-%%PORTDOCS%%@dir %%DOCSDIR%%
+nim/doc/nimdoc.css
%%PORTDOCS%%%%DOCSDIR%%/html/overview.html
-%%TOOLS%%bin/nimgrep
-%%TOOLS%%bin/nimsuggest