aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-09-22 02:11:14 +0800
committerleeym <leeym@FreeBSD.org>2004-09-22 02:11:14 +0800
commit4f368cee63aa0f77d1f44b224c0f9d69fb2fd8db (patch)
treef695e839843c06768301058cf703f4f3739a4b2b /lang
parent771f67e38da1c79f895fdafcf0955c3b363dfe00 (diff)
downloadfreebsd-ports-gnome-4f368cee63aa0f77d1f44b224c0f9d69fb2fd8db.tar.gz
freebsd-ports-gnome-4f368cee63aa0f77d1f44b224c0f9d69fb2fd8db.tar.zst
freebsd-ports-gnome-4f368cee63aa0f77d1f44b224c0f9d69fb2fd8db.zip
- install manpages only if WITH_TCL80_MAN is defined
- utilize MASTER_SITE_TCLTK PR: 71925 Submitted by: leeym Approved by: portmgr (marcus)
Diffstat (limited to 'lang')
-rw-r--r--lang/tcl80/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/lang/tcl80/Makefile b/lang/tcl80/Makefile
index 0e4bdbe1605b..3b6280aa1984 100644
--- a/lang/tcl80/Makefile
+++ b/lang/tcl80/Makefile
@@ -9,8 +9,9 @@ PORTNAME= tcl
PORTVERSION= 8.0.5
PORTREVISION= 1
CATEGORIES= lang tcl80
-MASTER_SITES= ftp://ftp.scriptics.com/pub/tcl/tcl8_0/
-DISTNAME= tcl8.0.5
+MASTER_SITES= ${MASTER_SITE_TCLTK}
+MASTER_SITE_SUBDIR=tcl8_0
+DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool Command Language
@@ -28,6 +29,7 @@ SHLIB_MAJOR= 1
SHLIB_MINOR= 5
MAKEFILE= makefile
TCL_LIB= libtcl80.so
+USE_REINPLACE= yes
.include <bsd.port.pre.mk>
@@ -46,6 +48,10 @@ TCL_LIB_FILE= ${TCL_LIB}.${SHLIB_MAJOR}.${SHLIB_MINOR}
post-configure:
@${CP} ${FILESDIR}/Makefile.lib ${WRKSRC}
@${CP} ${FILESDIR}/makefile ${WRKSRC}
+.if !defined(WITH_TCL80_MAN)
+ @${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
+ ${WRKSRC}/Makefile
+.endif
pre-build:
@cd ${WRKSRC} && ${MAKE} -f Makefile.lib PREFIX=${PREFIX} \