aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-04-27 05:39:06 +0800
committermarino <marino@FreeBSD.org>2014-04-27 05:39:06 +0800
commit4ff460d37812587b651b7250fdfcbda2a39b4594 (patch)
tree87140002ff06a08565ecbae004c31a331a8db088 /lang
parent99527210da7c961cfcfdccb6e4b2ac4d4e1643f1 (diff)
downloadfreebsd-ports-gnome-4ff460d37812587b651b7250fdfcbda2a39b4594.tar.gz
freebsd-ports-gnome-4ff460d37812587b651b7250fdfcbda2a39b4594.tar.zst
freebsd-ports-gnome-4ff460d37812587b651b7250fdfcbda2a39b4594.zip
lang/ocaml: Fix plist issues
These missing man page issues were seen on Redports and reported, then disappeared after the final patch. Unfortunately they weren't actually addresses, so it's a mystery why Redports didn't continue to catch the problem, nor the extra ocamldoc/custom directory (which is why the ocamldoc/custom/.keep file original existed). Add the 15 missing man pages to the plist and remove the empty directory in the post-install target. Strangely enough, Redports still shows an 8x pass. I'm losing a lot of confidence in Redports results... While here, remove the muting from the post-install target. This is against convention. PR: ports/188158
Diffstat (limited to 'lang')
-rw-r--r--lang/ocaml/Makefile9
-rw-r--r--lang/ocaml/pkg-plist15
2 files changed, 20 insertions, 4 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index bb4de13aa768..cef92685679d 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -3,6 +3,7 @@
PORTNAME= ocaml
PORTVERSION= 4.01.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/pub/distrib/${DISTNAME:R}/ \
${MASTER_SITE_GENTOO}
@@ -178,11 +179,11 @@ check test: install
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} report
post-install:
-# @${TOUCH} ${STAGEDIR}${PREFIX}/lib/ocaml/ocamldoc/custom/.keep
+ ${RMDIR} ${STAGEDIR}${PREFIX}/lib/ocaml/ocamldoc/custom
@${CHMOD} 755 ${STAGEDIR}${PREFIX}/lib/ocaml/expunge
.if ${PORT_OPTIONS:MTK}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @(cd ${WRKSRC}/otherlibs/labltk && \
+ (cd ${WRKSRC}/otherlibs/labltk && \
${COPYTREE_SHARE} examples_labltk ${STAGEDIR}${EXAMPLESDIR} \
"! -name .ignore" && \
${COPYTREE_SHARE} examples_camltk ${STAGEDIR}${EXAMPLESDIR} \
@@ -202,10 +203,10 @@ post-install:
.if ${PORT_OPTIONS:MOPT_DEF}
. for module in ${MODOPT}
# First, we save bytecode version
- @${MV} ${STAGEDIR}${PREFIX}/bin/${module} ${STAGEDIR}${PREFIX}/bin/${module}.byte
+ ${MV} ${STAGEDIR}${PREFIX}/bin/${module} ${STAGEDIR}${PREFIX}/bin/${module}.byte
# Next make .opt version be the default one (via link)
- @${LN} ${STAGEDIR}${PREFIX}/bin/${module}.opt ${STAGEDIR}${PREFIX}/bin/${module}
+ ${LN} ${STAGEDIR}${PREFIX}/bin/${module}.opt ${STAGEDIR}${PREFIX}/bin/${module}
@${ECHO_CMD} "bin/${module}.byte" >> ${TMPPLIST}
@${ECHO_CMD} "@exec ${LN} %D/${module}.opt %D/${module}" >> ${TMPPLIST}
. endfor
diff --git a/lang/ocaml/pkg-plist b/lang/ocaml/pkg-plist
index b4893de2fcaa..ce97af582830 100644
--- a/lang/ocaml/pkg-plist
+++ b/lang/ocaml/pkg-plist
@@ -1090,7 +1090,22 @@ lib/ocaml/weak.cmx
lib/ocaml/weak.ml
lib/ocaml/weak.mli
%%PROF%%lib/ocaml/weak.p.cmx
+man/man1/ocaml.1.gz
man/man1/ocamlbuild.1.gz
+man/man1/ocamlc.1.gz
+man/man1/ocamlc.opt.1.gz
+man/man1/ocamlcp.1.gz
+man/man1/ocamldebug.1.gz
+man/man1/ocamldep.1.gz
+man/man1/ocamldoc.1.gz
+man/man1/ocamllex.1.gz
+man/man1/ocamlmktop.1.gz
+man/man1/ocamlopt.1.gz
+man/man1/ocamlopt.opt.1.gz
+man/man1/ocamloptp.1.gz
+man/man1/ocamlprof.1.gz
+man/man1/ocamlrun.1.gz
+man/man1/ocamlyacc.1.gz
man/mann/Arg.3o.gz
man/mann/Array.3o.gz
man/mann/ArrayLabels.3o.gz