aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-11-24 13:20:58 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-11-24 13:20:58 +0800
commit52fd353b686d7b7fbb1e098ad2d4ee88a8223f47 (patch)
tree7d6f9a9078930c4a13be1154fc4cbe4c1d8eedd8 /lang
parent73579f3a21babfd2dbd2b878bf9e284eb4e64bb1 (diff)
downloadfreebsd-ports-gnome-52fd353b686d7b7fbb1e098ad2d4ee88a8223f47.tar.gz
freebsd-ports-gnome-52fd353b686d7b7fbb1e098ad2d4ee88a8223f47.tar.zst
freebsd-ports-gnome-52fd353b686d7b7fbb1e098ad2d4ee88a8223f47.zip
This module provides the capability to parse a string at runtime as
Perl source code, so that the resulting compiled code can be later executed. This is part of the job of the string form of the eval operator, but in this module it is separated out from the other jobs of eval. Parsing of Perl code is generally influenced by its lexical context, and this module provides some explicit control over this process, by reifying lexical environments as Perl objects. WWW: http://search.cpan.org/dist/Parse-Perl/ PR: ports/152447 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/p5-Parse-Perl/Makefile30
-rw-r--r--lang/p5-Parse-Perl/distinfo2
-rw-r--r--lang/p5-Parse-Perl/pkg-descr9
-rw-r--r--lang/p5-Parse-Perl/pkg-plist11
5 files changed, 53 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index ad8b4654a2da..4bda3224cf2c 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -232,6 +232,7 @@
SUBDIR += p5-JavaScript-Squish
SUBDIR += p5-List-MoreUtils
SUBDIR += p5-Modern-Perl
+ SUBDIR += p5-Parse-Perl
SUBDIR += p5-Perl6-Subs
SUBDIR += p5-Pugs-Compiler-Rule
SUBDIR += p5-Quantum-Superpositions
diff --git a/lang/p5-Parse-Perl/Makefile b/lang/p5-Parse-Perl/Makefile
new file mode 100644
index 000000000000..bd3dbf2dd907
--- /dev/null
+++ b/lang/p5-Parse-Perl/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Parse-Perl
+# Date created: 2010-11-21
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-Perl
+PORTVERSION= 0.005
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Interpret string as Perl source
+
+PERL_CONFIGURE= yes
+USE_PERL5_RUN= 5.8.4+
+
+MAN3= Parse::Perl.3 \
+ Parse::Perl::CopHintsHash.3 \
+ Parse::Perl::Environment.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/p5-Parse-Perl/distinfo b/lang/p5-Parse-Perl/distinfo
new file mode 100644
index 000000000000..f6077b3fa432
--- /dev/null
+++ b/lang/p5-Parse-Perl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Parse-Perl-0.005.tar.gz) = 42351e1a899d445895467e9c326ea7e07679b218f33c4f8e8b90b5e870e60245
+SIZE (Parse-Perl-0.005.tar.gz) = 23069
diff --git a/lang/p5-Parse-Perl/pkg-descr b/lang/p5-Parse-Perl/pkg-descr
new file mode 100644
index 000000000000..9df083b1d653
--- /dev/null
+++ b/lang/p5-Parse-Perl/pkg-descr
@@ -0,0 +1,9 @@
+This module provides the capability to parse a string at runtime as
+Perl source code, so that the resulting compiled code can be later
+executed. This is part of the job of the string form of the eval
+operator, but in this module it is separated out from the other jobs
+of eval. Parsing of Perl code is generally influenced by its lexical
+context, and this module provides some explicit control over this
+process, by reifying lexical environments as Perl objects.
+
+WWW: http://search.cpan.org/dist/Parse-Perl/
diff --git a/lang/p5-Parse-Perl/pkg-plist b/lang/p5-Parse-Perl/pkg-plist
new file mode 100644
index 000000000000..fa264bd83072
--- /dev/null
+++ b/lang/p5-Parse-Perl/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/Parse/Perl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Parse/Perl/CopHintsHash.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/Parse/Perl/Environment.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Perl/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Perl/Perl.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Perl/Perl.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Perl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Parse/Perl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Parse