aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-11-16 08:30:00 +0800
committergerald <gerald@FreeBSD.org>2015-11-16 08:30:00 +0800
commit5460b9367d5d517687a23e616ab09c2ee406ba27 (patch)
tree363506e7dd9e291951b16954bff2860dae770025 /lang
parent38112291e5d3544883030fdea903f53336d0117e (diff)
downloadfreebsd-ports-gnome-5460b9367d5d517687a23e616ab09c2ee406ba27.tar.gz
freebsd-ports-gnome-5460b9367d5d517687a23e616ab09c2ee406ba27.tar.zst
freebsd-ports-gnome-5460b9367d5d517687a23e616ab09c2ee406ba27.zip
Add GCC_DESC to Mk/bsd.options.desc.mk. Use this in a number of ports
instead of their own respective settings.
Diffstat (limited to 'lang')
-rw-r--r--lang/erlang-runtime15/Makefile1
-rw-r--r--lang/erlang-runtime16/Makefile1
-rw-r--r--lang/erlang-runtime17/Makefile1
-rw-r--r--lang/erlang-runtime18/Makefile1
-rw-r--r--lang/erlang/Makefile1
-rw-r--r--lang/ghc/Makefile1
-rw-r--r--lang/ghc/bsd.cabal.options.mk1
7 files changed, 0 insertions, 7 deletions
diff --git a/lang/erlang-runtime15/Makefile b/lang/erlang-runtime15/Makefile
index 79f0368d3e35..4e39dc254d12 100644
--- a/lang/erlang-runtime15/Makefile
+++ b/lang/erlang-runtime15/Makefile
@@ -30,7 +30,6 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/erlang-runtime16/Makefile b/lang/erlang-runtime16/Makefile
index 33682d16c151..652226a957d9 100644
--- a/lang/erlang-runtime16/Makefile
+++ b/lang/erlang-runtime16/Makefile
@@ -30,7 +30,6 @@ MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREADS WX
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/erlang-runtime17/Makefile b/lang/erlang-runtime17/Makefile
index 73de1c7deff1..b8e9f4379e5e 100644
--- a/lang/erlang-runtime17/Makefile
+++ b/lang/erlang-runtime17/Makefile
@@ -37,7 +37,6 @@ OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREAD
DIRTY_DESC= Enable Dirty schedulers (experimental)
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/erlang-runtime18/Makefile b/lang/erlang-runtime18/Makefile
index 0f6f20bc7793..96ccdb9faf1f 100644
--- a/lang/erlang-runtime18/Makefile
+++ b/lang/erlang-runtime18/Makefile
@@ -37,7 +37,6 @@ OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREAD
DIRTY_DESC= Enable Dirty schedulers (experimental)
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 7be4297c909f..b463618c88b0 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -42,7 +42,6 @@ OPTIONS_DEFINE= DOCS DTRACE GCC GS HIPE JAVA KQUEUE ODBC OPENSSL SCTP SMP THREAD
DIRTY_DESC= Enable Dirty schedulers (experimental)
DTRACE_DESC= Enable DTrace support
-GCC_DESC= Use current GCC
GS_DESC= Enable GS application (deprecated)
HIPE_DESC= Build native HiPE compiler
KQUEUE_DESC= Enable Kernel Poll (kqueue) support
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index b6166458f47c..0d81c9994cae 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -51,7 +51,6 @@ OPTIONS_DEFAULT= PROFILE DYNAMIC DOCS GCC
BOOT_DESC= Use installed GHC for bootstrapping
BOOTH_DESC= Use installed HsColour for bootstrapping
-GCC_DESC= Build with GCC (from ports)
PCLANG_DESC= Build with Clang from ports
BCLANG_DESC= Build with Clang from base
PROFILE_DESC= Add support for performance profiling
diff --git a/lang/ghc/bsd.cabal.options.mk b/lang/ghc/bsd.cabal.options.mk
index ae70ad7ec24e..471815fde632 100644
--- a/lang/ghc/bsd.cabal.options.mk
+++ b/lang/ghc/bsd.cabal.options.mk
@@ -25,7 +25,6 @@ HSCOLOUR_DESC?= Colorize generated documentation by HsColour
DYNAMIC_DESC?= Add support for dynamic linking
PROFILE_DESC?= Add support for profiling
LLVM_DESC?= Use the LLVM backend for code generation
-GCC_DESC= Build with GCC (from ports)
PCLANG_DESC= Build with Clang from ports
BCLANG_DESC= Build with Clang from base