aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-04-17 18:53:18 +0800
committerTobias Kortkamp <tobik@FreeBSD.org>2020-04-17 18:53:18 +0800
commit54f81f82919c2c89153c144c80dde31f80e8f6c4 (patch)
tree0c863ab18d002a4fc7f5e2e261b713bc751906ae /lang
parentdd11fd067032bbb28ce237a4d294a9a1ac25920c (diff)
downloadfreebsd-ports-gnome-54f81f82919c2c89153c144c80dde31f80e8f6c4.tar.gz
freebsd-ports-gnome-54f81f82919c2c89153c144c80dde31f80e8f6c4.tar.zst
freebsd-ports-gnome-54f81f82919c2c89153c144c80dde31f80e8f6c4.zip
lang/rust-nightly: Update to 1.44.0.20200417
- Add workaround to fix build when CC/CXX have "clang" in them [1] - Add patch to allow build with outdated libgit2 0.99.0 Changes: https://github.com/rust-lang/rust/compare/485c5fb6e1...7f3df57724 PR: 238556 [1]
Diffstat (limited to 'lang')
-rw-r--r--lang/rust-nightly/Makefile2
-rw-r--r--lang/rust-nightly/distinfo6
-rw-r--r--lang/rust-nightly/files/patch-vendor_cc_src_lib.rs42
-rw-r--r--lang/rust-nightly/files/patch-vendor_libgit2-sys_build.rs11
4 files changed, 57 insertions, 4 deletions
diff --git a/lang/rust-nightly/Makefile b/lang/rust-nightly/Makefile
index 9938fb9c938e..f25db0013b42 100644
--- a/lang/rust-nightly/Makefile
+++ b/lang/rust-nightly/Makefile
@@ -18,7 +18,7 @@ DISTINFO_FILE= ${.CURDIR}/distinfo
# Get latest from top level 'date' key in
# https://static.rust-lang.org/dist/channel-rust-nightly.toml
-NIGHTLY_DATE= 2020-04-09
+NIGHTLY_DATE= 2020-04-17
# See WRKSRC/src/stage0.txt for this date
BOOTSTRAPS_DATE= 2020-03-12
diff --git a/lang/rust-nightly/distinfo b/lang/rust-nightly/distinfo
index 8f0685b3ed17..74756a42bb79 100644
--- a/lang/rust-nightly/distinfo
+++ b/lang/rust-nightly/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1586404359
-SHA256 (rust/2020-04-09/rustc-nightly-src.tar.xz) = bd63d2138aaebfaad7ac01189e8df442192d714603d64e25f37eaab01205fc6e
-SIZE (rust/2020-04-09/rustc-nightly-src.tar.xz) = 94582740
+TIMESTAMP = 1587089218
+SHA256 (rust/2020-04-17/rustc-nightly-src.tar.xz) = 1fc625e21b860bed3ff52e7cd0e024d5459f3e9903c4e44c3ddf893605784ac8
+SIZE (rust/2020-04-17/rustc-nightly-src.tar.xz) = 94721724
SHA256 (rust/2020-03-12/rustc-beta-x86_64-unknown-freebsd.tar.xz) = 8a1fa4555d128dcf89958f7ea5ff476408903e76ea2f6c97f3da6d131b0c040f
SIZE (rust/2020-03-12/rustc-beta-x86_64-unknown-freebsd.tar.xz) = 35928800
SHA256 (rust/2020-03-12/rust-std-beta-x86_64-unknown-freebsd.tar.xz) = d1faf86633140c059ee6f6d7ba7ae3f637385a8a78b98a97f6084d001497d650
diff --git a/lang/rust-nightly/files/patch-vendor_cc_src_lib.rs b/lang/rust-nightly/files/patch-vendor_cc_src_lib.rs
new file mode 100644
index 000000000000..0c6b6f99cbe9
--- /dev/null
+++ b/lang/rust-nightly/files/patch-vendor_cc_src_lib.rs
@@ -0,0 +1,42 @@
+When the compiler has "clang" in its name the cc crate will pass
+an LLVM target triple to it. Rust uses a triple that lacks the OS
+version and LLVM will default to FreeBSD 9 behavior, i.e., it will
+default to libstdc++ which is no longer available in newer releases.
+
+To avoid this issue assume we have a GNU compatible toolchain instead
+until LLVM can be updated to use libc++ by default.
+
+https://reviews.llvm.org/D77776
+
+--- vendor/cc/src/lib.rs.orig 2020-04-14 08:55:10 UTC
++++ vendor/cc/src/lib.rs
+@@ -2353,28 +2353,7 @@ impl Tool {
+ }
+
+ fn with_features(path: PathBuf, clang_driver: Option<&str>, cuda: bool) -> Self {
+- // Try to detect family of the tool from its name, falling back to Gnu.
+- let family = if let Some(fname) = path.file_name().and_then(|p| p.to_str()) {
+- if fname.contains("clang-cl") {
+- ToolFamily::Msvc { clang_cl: true }
+- } else if fname.contains("cl")
+- && !fname.contains("cloudabi")
+- && !fname.contains("uclibc")
+- && !fname.contains("clang")
+- {
+- ToolFamily::Msvc { clang_cl: false }
+- } else if fname.contains("clang") {
+- match clang_driver {
+- Some("cl") => ToolFamily::Msvc { clang_cl: true },
+- _ => ToolFamily::Clang,
+- }
+- } else {
+- ToolFamily::Gnu
+- }
+- } else {
+- ToolFamily::Gnu
+- };
+-
++ let family = ToolFamily::Gnu;
+ Tool {
+ path: path,
+ cc_wrapper_path: None,
diff --git a/lang/rust-nightly/files/patch-vendor_libgit2-sys_build.rs b/lang/rust-nightly/files/patch-vendor_libgit2-sys_build.rs
new file mode 100644
index 000000000000..9a7a520b35c6
--- /dev/null
+++ b/lang/rust-nightly/files/patch-vendor_libgit2-sys_build.rs
@@ -0,0 +1,11 @@
+--- vendor/libgit2-sys/build.rs.orig 2020-04-17 09:21:48 UTC
++++ vendor/libgit2-sys/build.rs
+@@ -8,7 +8,7 @@ fn main() {
+ let ssh = env::var("CARGO_FEATURE_SSH").is_ok();
+
+ let mut cfg = pkg_config::Config::new();
+- if let Ok(lib) = cfg.atleast_version("1.0.0").probe("libgit2") {
++ if let Ok(lib) = cfg.atleast_version("0.99.0").probe("libgit2") {
+ for include in &lib.include_paths {
+ println!("cargo:root={}", include.display());
+ }