aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2014-06-10 17:22:26 +0800
committerpi <pi@FreeBSD.org>2014-06-10 17:22:26 +0800
commit55b8b6826889fc4452907d1d67ea983c3864e6a9 (patch)
tree683d4ff8f2d76da808d6ab1fe7c5a667abb948c6 /lang
parentd83ccd6fdbf0f51e64e2bf0c3615903828a8e248 (diff)
downloadfreebsd-ports-gnome-55b8b6826889fc4452907d1d67ea983c3864e6a9.tar.gz
freebsd-ports-gnome-55b8b6826889fc4452907d1d67ea983c3864e6a9.tar.zst
freebsd-ports-gnome-55b8b6826889fc4452907d1d67ea983c3864e6a9.zip
lang/perl5.18: fix warning in Math/BigInt.pm
See also https://rt.cpan.org/Public/Bug/Display.html?id=80182 PR: ports/185541 Approved-by: tobez (maintainer timeout), jadawin (mentor)
Diffstat (limited to 'lang')
-rw-r--r--lang/perl5.18/Makefile2
-rw-r--r--lang/perl5.18/files/patch-BigInt.pm11
2 files changed, 12 insertions, 1 deletions
diff --git a/lang/perl5.18/Makefile b/lang/perl5.18/Makefile
index 1cfa3af60018..c8f1a47a7bfc 100644
--- a/lang/perl5.18/Makefile
+++ b/lang/perl5.18/Makefile
@@ -3,7 +3,7 @@
PORTNAME= perl
PORTVERSION= ${PERL_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= lang devel perl5
MASTER_SITES= CPAN \
${MASTER_SITE_LOCAL:S/$/:local/} \
diff --git a/lang/perl5.18/files/patch-BigInt.pm b/lang/perl5.18/files/patch-BigInt.pm
new file mode 100644
index 000000000000..8c56e2859ff4
--- /dev/null
+++ b/lang/perl5.18/files/patch-BigInt.pm
@@ -0,0 +1,11 @@
+--- dist/Math-BigInt/lib/Math/BigInt.pm-orig 2014-06-09 16:22:23.000000000 +0200
++++ dist/Math-BigInt/lib/Math/BigInt.pm 2014-06-09 16:22:54.000000000 +0200
+@@ -62,7 +62,7 @@
+ '>>=' => sub { $_[0]->brsft($_[1]); },
+
+ # not supported by Perl yet
+-'..' => \&_pointpoint,
++# '..' => \&_pointpoint,
+
+ '<=>' => sub { my $rc = $_[2] ?
+ ref($_[0])->bcmp($_[1],$_[0]) :