aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2009-11-03 00:50:41 +0800
committerskv <skv@FreeBSD.org>2009-11-03 00:50:41 +0800
commit576fb990c2b75718b8a6174309af8a649ebae643 (patch)
tree5fb4dbee1c4396ef2cb74ea20774a55ac23723b4 /lang
parentfe3c8b40d4d54289696578e5dce652b35cab1c86 (diff)
downloadfreebsd-ports-gnome-576fb990c2b75718b8a6174309af8a649ebae643.tar.gz
freebsd-ports-gnome-576fb990c2b75718b8a6174309af8a649ebae643.tar.zst
freebsd-ports-gnome-576fb990c2b75718b8a6174309af8a649ebae643.zip
- Fix behaviour of USE_PERL option when it is "off"
- Add PORTSCOUT variable
Diffstat (limited to 'lang')
-rw-r--r--lang/perl5.10/Makefile11
-rw-r--r--lang/perl5.10/files/use.perl6
-rw-r--r--lang/perl5.12/Makefile11
-rw-r--r--lang/perl5.12/files/use.perl6
-rw-r--r--lang/perl5.14/Makefile11
-rw-r--r--lang/perl5.14/files/use.perl6
-rw-r--r--lang/perl5.16/Makefile11
-rw-r--r--lang/perl5.16/files/use.perl6
-rw-r--r--lang/perl5.8/Makefile11
-rw-r--r--lang/perl5.8/files/use.perl6
10 files changed, 60 insertions, 25 deletions
diff --git a/lang/perl5.10/Makefile b/lang/perl5.10/Makefile
index e19a12ad8d7e..b252b8e53272 100644
--- a/lang/perl5.10/Makefile
+++ b/lang/perl5.10/Makefile
@@ -32,6 +32,8 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
+PORTSCOUT= limitw:1,even
+
PERL_VERSION= 5.10.1
PERL_ARCH= mach
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
@@ -138,6 +140,12 @@ CONFIGURE_ARGS+= -Dusemultiplicity=y
CONFIGURE_ARGS+= -Dusesitecustomize
.endif
+.if defined(WITH_USE_PERL)
+LINK_USRBIN= yes
+.else
+LINK_USRBIN= no
+.endif
+
NO_LATEST_LINK= yes
.if defined(WITH_GDBM)
@@ -161,6 +169,7 @@ post-patch:
-e 's|%%PERL_VERSION%%|${PERL_VERSION}|g;' \
-e 's|%%PERL_ARCH%%|${PERL_ARCH}|g;' \
-e 's|%%MAKE_CONF%%|${__MAKE_CONF}|g;' \
+ -e 's|%%LINK_USRBIN%%|${LINK_USRBIN}|g;' \
${FILESDIR}/use.perl \
> ${WRKDIR}/use.perl
${SED} -e 's|%%PERL%%|${PERL}|g; s|%%PERL_VERSION%%|${PERL_VERSION}|g; s|%%PKGNAME%%|${PKGNAME}|g' \
@@ -198,9 +207,7 @@ post-install:
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
-.if defined(WITH_USE_PERL)
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
test: build
@(cd ${WRKSRC}; make test)
diff --git a/lang/perl5.10/files/use.perl b/lang/perl5.10/files/use.perl
index a75ac2641a65..59ee8ee0fce9 100644
--- a/lang/perl5.10/files/use.perl
+++ b/lang/perl5.10/files/use.perl
@@ -18,15 +18,15 @@ else
fi
if [ "$2" = "POST-INSTALL" ] ; then
- need_remove_links=yes
- need_create_links=yes
+ need_remove_links=%%LINK_USRBIN%%
+ need_create_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
need_spam_make_conf=yes
need_spam_manpath=yes
need_post_install=yes
elif [ "$2" = "POST-DEINSTALL" ] ; then
- need_remove_links=yes
+ need_remove_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
else
diff --git a/lang/perl5.12/Makefile b/lang/perl5.12/Makefile
index e19a12ad8d7e..b252b8e53272 100644
--- a/lang/perl5.12/Makefile
+++ b/lang/perl5.12/Makefile
@@ -32,6 +32,8 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
+PORTSCOUT= limitw:1,even
+
PERL_VERSION= 5.10.1
PERL_ARCH= mach
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
@@ -138,6 +140,12 @@ CONFIGURE_ARGS+= -Dusemultiplicity=y
CONFIGURE_ARGS+= -Dusesitecustomize
.endif
+.if defined(WITH_USE_PERL)
+LINK_USRBIN= yes
+.else
+LINK_USRBIN= no
+.endif
+
NO_LATEST_LINK= yes
.if defined(WITH_GDBM)
@@ -161,6 +169,7 @@ post-patch:
-e 's|%%PERL_VERSION%%|${PERL_VERSION}|g;' \
-e 's|%%PERL_ARCH%%|${PERL_ARCH}|g;' \
-e 's|%%MAKE_CONF%%|${__MAKE_CONF}|g;' \
+ -e 's|%%LINK_USRBIN%%|${LINK_USRBIN}|g;' \
${FILESDIR}/use.perl \
> ${WRKDIR}/use.perl
${SED} -e 's|%%PERL%%|${PERL}|g; s|%%PERL_VERSION%%|${PERL_VERSION}|g; s|%%PKGNAME%%|${PKGNAME}|g' \
@@ -198,9 +207,7 @@ post-install:
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
-.if defined(WITH_USE_PERL)
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
test: build
@(cd ${WRKSRC}; make test)
diff --git a/lang/perl5.12/files/use.perl b/lang/perl5.12/files/use.perl
index a75ac2641a65..59ee8ee0fce9 100644
--- a/lang/perl5.12/files/use.perl
+++ b/lang/perl5.12/files/use.perl
@@ -18,15 +18,15 @@ else
fi
if [ "$2" = "POST-INSTALL" ] ; then
- need_remove_links=yes
- need_create_links=yes
+ need_remove_links=%%LINK_USRBIN%%
+ need_create_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
need_spam_make_conf=yes
need_spam_manpath=yes
need_post_install=yes
elif [ "$2" = "POST-DEINSTALL" ] ; then
- need_remove_links=yes
+ need_remove_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
else
diff --git a/lang/perl5.14/Makefile b/lang/perl5.14/Makefile
index e19a12ad8d7e..b252b8e53272 100644
--- a/lang/perl5.14/Makefile
+++ b/lang/perl5.14/Makefile
@@ -32,6 +32,8 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
+PORTSCOUT= limitw:1,even
+
PERL_VERSION= 5.10.1
PERL_ARCH= mach
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
@@ -138,6 +140,12 @@ CONFIGURE_ARGS+= -Dusemultiplicity=y
CONFIGURE_ARGS+= -Dusesitecustomize
.endif
+.if defined(WITH_USE_PERL)
+LINK_USRBIN= yes
+.else
+LINK_USRBIN= no
+.endif
+
NO_LATEST_LINK= yes
.if defined(WITH_GDBM)
@@ -161,6 +169,7 @@ post-patch:
-e 's|%%PERL_VERSION%%|${PERL_VERSION}|g;' \
-e 's|%%PERL_ARCH%%|${PERL_ARCH}|g;' \
-e 's|%%MAKE_CONF%%|${__MAKE_CONF}|g;' \
+ -e 's|%%LINK_USRBIN%%|${LINK_USRBIN}|g;' \
${FILESDIR}/use.perl \
> ${WRKDIR}/use.perl
${SED} -e 's|%%PERL%%|${PERL}|g; s|%%PERL_VERSION%%|${PERL_VERSION}|g; s|%%PKGNAME%%|${PKGNAME}|g' \
@@ -198,9 +207,7 @@ post-install:
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
-.if defined(WITH_USE_PERL)
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
test: build
@(cd ${WRKSRC}; make test)
diff --git a/lang/perl5.14/files/use.perl b/lang/perl5.14/files/use.perl
index a75ac2641a65..59ee8ee0fce9 100644
--- a/lang/perl5.14/files/use.perl
+++ b/lang/perl5.14/files/use.perl
@@ -18,15 +18,15 @@ else
fi
if [ "$2" = "POST-INSTALL" ] ; then
- need_remove_links=yes
- need_create_links=yes
+ need_remove_links=%%LINK_USRBIN%%
+ need_create_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
need_spam_make_conf=yes
need_spam_manpath=yes
need_post_install=yes
elif [ "$2" = "POST-DEINSTALL" ] ; then
- need_remove_links=yes
+ need_remove_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
else
diff --git a/lang/perl5.16/Makefile b/lang/perl5.16/Makefile
index e19a12ad8d7e..b252b8e53272 100644
--- a/lang/perl5.16/Makefile
+++ b/lang/perl5.16/Makefile
@@ -32,6 +32,8 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
+PORTSCOUT= limitw:1,even
+
PERL_VERSION= 5.10.1
PERL_ARCH= mach
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
@@ -138,6 +140,12 @@ CONFIGURE_ARGS+= -Dusemultiplicity=y
CONFIGURE_ARGS+= -Dusesitecustomize
.endif
+.if defined(WITH_USE_PERL)
+LINK_USRBIN= yes
+.else
+LINK_USRBIN= no
+.endif
+
NO_LATEST_LINK= yes
.if defined(WITH_GDBM)
@@ -161,6 +169,7 @@ post-patch:
-e 's|%%PERL_VERSION%%|${PERL_VERSION}|g;' \
-e 's|%%PERL_ARCH%%|${PERL_ARCH}|g;' \
-e 's|%%MAKE_CONF%%|${__MAKE_CONF}|g;' \
+ -e 's|%%LINK_USRBIN%%|${LINK_USRBIN}|g;' \
${FILESDIR}/use.perl \
> ${WRKDIR}/use.perl
${SED} -e 's|%%PERL%%|${PERL}|g; s|%%PERL_VERSION%%|${PERL_VERSION}|g; s|%%PKGNAME%%|${PKGNAME}|g' \
@@ -198,9 +207,7 @@ post-install:
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
-.if defined(WITH_USE_PERL)
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
test: build
@(cd ${WRKSRC}; make test)
diff --git a/lang/perl5.16/files/use.perl b/lang/perl5.16/files/use.perl
index a75ac2641a65..59ee8ee0fce9 100644
--- a/lang/perl5.16/files/use.perl
+++ b/lang/perl5.16/files/use.perl
@@ -18,15 +18,15 @@ else
fi
if [ "$2" = "POST-INSTALL" ] ; then
- need_remove_links=yes
- need_create_links=yes
+ need_remove_links=%%LINK_USRBIN%%
+ need_create_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
need_spam_make_conf=yes
need_spam_manpath=yes
need_post_install=yes
elif [ "$2" = "POST-DEINSTALL" ] ; then
- need_remove_links=yes
+ need_remove_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
else
diff --git a/lang/perl5.8/Makefile b/lang/perl5.8/Makefile
index 16a6253b8831..8e88a66a83e2 100644
--- a/lang/perl5.8/Makefile
+++ b/lang/perl5.8/Makefile
@@ -36,6 +36,8 @@ OPTIONS= DEBUGGING "Build with debugging support" off \
SITECUSTOMIZE "Run-time customization of @INC" off \
USE_PERL "Rewrite links in /usr/bin" on
+PORTSCOUT= limitw:1,even
+
PERL_VERSION= 5.8.9
PERL_ARCH= mach
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VERSION}
@@ -138,6 +140,12 @@ CONFIGURE_ARGS+= -Duse64bitint
CONFIGURE_ARGS+= -Dusesitecustomize
.endif
+.if defined(WITH_USE_PERL)
+LINK_USRBIN= yes
+.else
+LINK_USRBIN= no
+.endif
+
LATEST_LINK= perl
PLIST_SUB+= NEED_USE_PERL="@comment "
@@ -163,6 +171,7 @@ post-patch:
-e 's|%%PERL_VERSION%%|${PERL_VERSION}|g;' \
-e 's|%%PERL_ARCH%%|${PERL_ARCH}|g;' \
-e 's|%%MAKE_CONF%%|${__MAKE_CONF}|g;' \
+ -e 's|%%LINK_USRBIN%%|${LINK_USRBIN}|g;' \
${FILESDIR}/use.perl \
> ${WRKDIR}/use.perl
${SED} -e 's|%%PERL%%|${PERL}|g; s|%%PERL_VERSION%%|${PERL_VERSION}|g; s|%%PKGNAME%%|${PKGNAME}|g' \
@@ -200,9 +209,7 @@ post-install:
${INSTALL} ${COPY} -o ${BINOWN} -g ${BINGRP} -m ${NOBINMODE} \
${BSDPAN_WRKSRC}/${files} ${BSDPAN_DEST}/${files}
.endfor
-.if defined(WITH_USE_PERL)
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.endif
test: build
@(cd ${WRKSRC}; make test)
diff --git a/lang/perl5.8/files/use.perl b/lang/perl5.8/files/use.perl
index 55b7f51ed148..23e21002eb80 100644
--- a/lang/perl5.8/files/use.perl
+++ b/lang/perl5.8/files/use.perl
@@ -20,14 +20,14 @@ fi
if [ "x$this" = "xuse.perl" ]; then
PKG_PREFIX="%%PREFIX%%"
if [ "$1" = "port" ] ; then
- need_remove_links=yes
- need_create_links=yes
+ need_remove_links=%%LINK_USRBIN%%
+ need_create_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
need_spam_make_conf=yes
need_spam_manpath=yes
elif [ "$1" = "system" ] ; then
- need_remove_links=yes
+ need_remove_links=%%LINK_USRBIN%%
need_cleanup_make_conf=yes
need_cleanup_manpath=yes
else