aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2005-02-05 12:59:26 +0800
committerknu <knu@FreeBSD.org>2005-02-05 12:59:26 +0800
commit584984a14cadb1bedf9e267effdafd4aac178618 (patch)
tree27e9d2d6bee9a8d90b9da0364a0514d6acc23097 /lang
parentbb4b58c482c462fe675e9cc2b457369555b0b634 (diff)
downloadfreebsd-ports-gnome-584984a14cadb1bedf9e267effdafd4aac178618.tar.gz
freebsd-ports-gnome-584984a14cadb1bedf9e267effdafd4aac178618.tar.zst
freebsd-ports-gnome-584984a14cadb1bedf9e267effdafd4aac178618.zip
The slippery pthread support for systems prior to 502102 has been
dropped and the lang/ruby16_r and lang/ruby18_r ports have been removed, since no one seems to appreciate the partially working solution. Good news is that the pthread support of lang/ruby18 is now enabled by default for newer systems, which means the ruby interpreter is linked with libpthread. This will allow threaded extension libraries to run and work properly on those systems. The --march=cputype flag is disabled because it gets ruby to malfunction and fail to build. I don't know if the problem is in libpthread or in gcc. (It really makes me wonder if they had actually tested before asking me to do this somewhat risky change ;-)
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile2
-rw-r--r--lang/ruby16/Makefile9
-rw-r--r--lang/ruby16/pkg-plist4
-rw-r--r--lang/ruby16_r/Makefile18
-rw-r--r--lang/ruby18/Makefile24
-rw-r--r--lang/ruby18/pkg-plist14
-rw-r--r--lang/ruby18_r/Makefile18
7 files changed, 30 insertions, 59 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 042d031f216e..69f9bc872f2c 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -234,10 +234,8 @@
SUBDIR += ruby-usersguide
SUBDIR += ruby16
SUBDIR += ruby16-shim-ruby18
- SUBDIR += ruby16_r
SUBDIR += ruby16_static
SUBDIR += ruby18
- SUBDIR += ruby18_r
SUBDIR += ruby18_static
SUBDIR += sbcl
SUBDIR += scheme48
diff --git a/lang/ruby16/Makefile b/lang/ruby16/Makefile
index 884e968e1b09..7212c8bb08ba 100644
--- a/lang/ruby16/Makefile
+++ b/lang/ruby16/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
#
-PORTNAME= ruby${RUBY_R}
+PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
PORTREVISION= 1
CATEGORIES= lang ruby ipv6
@@ -68,7 +68,7 @@ CONFIGURE_ARGS+= --enable-ipv6
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
-MLINKS= ${RUBY_NAME}.1 ruby${RUBY_R}.1
+MLINKS= ${RUBY_NAME}.1 ruby.1
IF_DEFAULT= ""
.else
IF_DEFAULT= "@comment "
@@ -115,10 +115,9 @@ post-install:
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
# Link just installed "ruby" to "ruby16", etc.
- ${LN} -f ${RUBY_WITH_SUFFIX} ${RUBY_WITHOUT_SUFFIX}${RUBY_R}
- ${LN} -f ${PREFIX}/man/man1/${RUBY_NAME}.1 ${PREFIX}/man/man1/ruby${RUBY_R}.1
+ ${LN} -f ${RUBY_WITH_SUFFIX} ${RUBY_WITHOUT_SUFFIX}
for f in ${INSTALLED_SCRIPTS}; do \
- ${LN} -f $${f}${RUBY_SUFFIX} $${f}${RUBY_R}; \
+ ${LN} -f $${f}${RUBY_SUFFIX} $${f}; \
done
.endif
${LDCONFIG} -m ${PREFIX}/lib
diff --git a/lang/ruby16/pkg-plist b/lang/ruby16/pkg-plist
index ece180bb53e8..8035fbe8e051 100644
--- a/lang/ruby16/pkg-plist
+++ b/lang/ruby16/pkg-plist
@@ -1,6 +1,6 @@
-%%IF_DEFAULT%%bin/irb%%RUBY_R%%
+%%IF_DEFAULT%%bin/irb
bin/irb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/ruby%%RUBY_R%%
+%%IF_DEFAULT%%bin/ruby
bin/ruby%%RUBY_SUFFIX%%
lib/lib%%RUBY_NAME%%.so
lib/lib%%RUBY_NAME%%.so.%%RUBY_SHLIBVER%%
diff --git a/lang/ruby16_r/Makefile b/lang/ruby16_r/Makefile
deleted file mode 100644
index 7e47ee16e543..000000000000
--- a/lang/ruby16_r/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-# New ports collection makefile for: ruby_r
-# Date created: 3 June 2001
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
-# $FreeBSD$
-#
-
-MASTERDIR= ${.CURDIR}/../ruby16
-
-BUILD_DEPENDS= ${RUBY_WITHOUT_SUFFIX}${RUBY_VER:S/.//}:${MASTERDIR}
-RUN_DEPENDS= ${RUBY_WITHOUT_SUFFIX}${RUBY_VER:S/.//}:${MASTERDIR}
-
-NOPORTDOCS= yes
-NORUBYLIB= yes
-
-RUBY_WITH_PTHREAD= yes
-
-.include "${MASTERDIR}/Makefile"
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index e1558869f663..5f82a9ac67df 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -1,13 +1,13 @@
-# New ports collection makefile for: ruby-devel
+# New ports collection makefile for: ruby18
# Date created: 6 May 2001
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
-PORTNAME= ruby${RUBY_R}
+PORTNAME= ruby
PORTVERSION= ${RUBY_PORTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang ruby ipv6
MASTER_SITES= ${MASTER_SITE_RUBY}
MASTER_SITE_SUBDIR= ${MASTER_SITE_SUBDIR_RUBY}
@@ -58,6 +58,17 @@ MAN1= ${RUBY_NAME}.1
LATEST_LINK= ruby-devel
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502102
+RUBY_ENABLE_PTHREAD?= public demand
+.endif
+
+.if defined(RUBY_ENABLE_PTHREAD) && ${RUBY_ENABLE_PTHREAD} != "no"
+CONFIGURE_ARGS+= --enable-pthread
+
+# There seems to be a bug in either gcc or libpthread that gets
+# (mini)ruby to malfunction..
+CFLAGS:= ${CFLAGS:N-march=*}
+.endif
.if ${ARCH} == "ia64"
BROKEN= "Segfault during build on ia64"
@@ -70,7 +81,7 @@ CONFIGURE_ARGS+= --enable-ipv6
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
-MLINKS= ${RUBY_NAME}.1 ruby${RUBY_R}.1
+MLINKS= ${RUBY_NAME}.1 ruby.1
IF_DEFAULT= ""
.else
IF_DEFAULT= "@comment "
@@ -145,10 +156,9 @@ post-install:
.endif
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
# Link just installed "ruby" to "ruby18", etc.
- ${LN} -f ${RUBY_WITH_SUFFIX} ${RUBY_WITHOUT_SUFFIX}${RUBY_R}
- ${LN} -f ${PREFIX}/man/man1/${RUBY_NAME}.1 ${PREFIX}/man/man1/ruby${RUBY_R}.1
+ ${LN} -f ${RUBY_WITH_SUFFIX} ${RUBY_WITHOUT_SUFFIX}
for f in ${INSTALLED_SCRIPTS}; do \
- ${LN} -f $${f}${RUBY_SUFFIX} $${f}${RUBY_R}; \
+ ${LN} -f $${f}${RUBY_SUFFIX} $${f}; \
done
.endif
${LDCONFIG} -m ${PREFIX}/lib
diff --git a/lang/ruby18/pkg-plist b/lang/ruby18/pkg-plist
index 5714dd82573a..6c733438a53b 100644
--- a/lang/ruby18/pkg-plist
+++ b/lang/ruby18/pkg-plist
@@ -1,16 +1,16 @@
-%%IF_DEFAULT%%bin/erb%%RUBY_R%%
+%%IF_DEFAULT%%bin/erb
bin/erb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/h2rb%%RUBY_R%%
+%%IF_DEFAULT%%bin/h2rb
bin/h2rb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/irb%%RUBY_R%%
+%%IF_DEFAULT%%bin/irb
bin/irb%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/rdoc%%RUBY_R%%
+%%IF_DEFAULT%%bin/rdoc
bin/rdoc%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/ri%%RUBY_R%%
+%%IF_DEFAULT%%bin/ri
bin/ri%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/ruby%%RUBY_R%%
+%%IF_DEFAULT%%bin/ruby
bin/ruby%%RUBY_SUFFIX%%
-%%IF_DEFAULT%%bin/testrb%%RUBY_R%%
+%%IF_DEFAULT%%bin/testrb
bin/testrb%%RUBY_SUFFIX%%
lib/lib%%RUBY_NAME%%-static.a
lib/lib%%RUBY_NAME%%.so
diff --git a/lang/ruby18_r/Makefile b/lang/ruby18_r/Makefile
deleted file mode 100644
index d5f4d5e76308..000000000000
--- a/lang/ruby18_r/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-# New ports collection makefile for: ruby_r-devel
-# Date created: 3 June 2001
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
-# $FreeBSD$
-#
-
-MASTERDIR= ${.CURDIR}/../ruby18
-
-BUILD_DEPENDS= ${RUBY_WITHOUT_SUFFIX}${RUBY_VER:S/.//}:${MASTERDIR}
-RUN_DEPENDS= ${RUBY_WITHOUT_SUFFIX}${RUBY_VER:S/.//}:${MASTERDIR}
-
-NOPORTDOCS= yes
-NORUBYLIB= yes
-
-RUBY_WITH_PTHREAD= yes
-
-.include "${MASTERDIR}/Makefile"