aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-05-01 00:55:22 +0800
committerbapt <bapt@FreeBSD.org>2014-05-01 00:55:22 +0800
commit5a19e63b322f2af9d0678d6490579dd855aa61ea (patch)
tree50a2e468564f8b293f18a82534bf2e1f1d85d268 /lang
parente053e7d4f6072367c32fe2d4966c94c404fd1cbd (diff)
downloadfreebsd-ports-gnome-5a19e63b322f2af9d0678d6490579dd855aa61ea.tar.gz
freebsd-ports-gnome-5a19e63b322f2af9d0678d6490579dd855aa61ea.tar.zst
freebsd-ports-gnome-5a19e63b322f2af9d0678d6490579dd855aa61ea.zip
Partially revert r352688 to actually do what was stated in the commit log
With hat: portmgr Pointyhat to: bapt
Diffstat (limited to 'lang')
-rw-r--r--lang/onyx/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/lang/onyx/Makefile b/lang/onyx/Makefile
index 0bde731ff3d8..429aeea98e86 100644
--- a/lang/onyx/Makefile
+++ b/lang/onyx/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= cook:${PORTSDIR}/devel/cook
LIB_DEPENDS= libedit.so:${PORTSDIR}/devel/libedit \
libpcre.so:${PORTSDIR}/devel/pcre
-USES= desthack tar:bzip2
+USES= tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-libedit-prefix=${LOCALBASE} \
--with-pcre-prefix=${LOCALBASE}
@@ -22,6 +22,10 @@ USE_LDCONFIG= yes
PLIST_SUB= ONYX_VERSION=${PORTVERSION}
+MAN1= onyx.1 onyx_config.1
+
+NO_STAGE= yes
+
BROKEN_ia64= Coredump during build on ia64
post-patch:
@@ -31,7 +35,10 @@ do-build:
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook)
do-install:
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} DESTDIR=${STAGEDIR} cook install)
+ @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} cook install)
+
+post-install:
@${STRIP_CMD} ${PREFIX}/bin/onyx
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>