aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjlaffaye <jlaffaye@FreeBSD.org>2018-08-19 21:25:05 +0800
committerjlaffaye <jlaffaye@FreeBSD.org>2018-08-19 21:25:05 +0800
commit5a88d1917fe6e8de410e9be483e03e7e50ac291f (patch)
tree0334d63772290b1b680e5cdd65aa99dd31d0ea61 /lang
parent52471ce0fb3743d6d77986b50f30dc0257408339 (diff)
downloadfreebsd-ports-gnome-5a88d1917fe6e8de410e9be483e03e7e50ac291f.tar.gz
freebsd-ports-gnome-5a88d1917fe6e8de410e9be483e03e7e50ac291f.tar.zst
freebsd-ports-gnome-5a88d1917fe6e8de410e9be483e03e7e50ac291f.zip
Build lang/go14 without SSE2
This allows to build lang/go14 on old x86 CPUs without SSE2 instructions. This has an impact on generated machine code performance, but lang/go14 is only useful to boostrap lang/go so it is ok to do so unconditionally. PR: 230733 Submitted by: Dmitri Goutnik <dg@syrec.org>
Diffstat (limited to 'lang')
-rw-r--r--lang/go14/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/go14/Makefile b/lang/go14/Makefile
index 31ee23d5812b..9ba624307bc2 100644
--- a/lang/go14/Makefile
+++ b/lang/go14/Makefile
@@ -2,7 +2,7 @@
PORTNAME= go14
PORTVERSION= 1.4.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang
MASTER_SITES= http://golang.org/dl/
DISTNAME= go${PORTVERSION}.src
@@ -62,6 +62,7 @@ do-build:
CC=${CC} \
GOROOT=${WRKSRC} GOROOT_FINAL=${PREFIX}/go14 \
GOBIN= GOARCH=${GOARCH} GOOS=${OPSYS:tl} \
+ GO386=387 \
CGO_ENABLED=0 \
${SH} make.bash