aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-12-25 03:40:55 +0800
committerriggs <riggs@FreeBSD.org>2016-12-25 03:40:55 +0800
commit5b24276e655e31e2062a9030565b6d753a307b95 (patch)
tree26d748c61260f7d22bb1911d8c5bae3fe23b379f /lang
parent8e1a04bcf5d355fe9bafaaaf732ae4f821226cb7 (diff)
downloadfreebsd-ports-gnome-5b24276e655e31e2062a9030565b6d753a307b95.tar.gz
freebsd-ports-gnome-5b24276e655e31e2062a9030565b6d753a307b95.tar.zst
freebsd-ports-gnome-5b24276e655e31e2062a9030565b6d753a307b95.zip
Update to upstream version 1.14.0
Diffstat (limited to 'lang')
-rw-r--r--lang/rust/Makefile6
-rw-r--r--lang/rust/distinfo.amd6410
-rw-r--r--lang/rust/distinfo.i38610
-rw-r--r--lang/rust/pkg-plist6
4 files changed, 17 insertions, 15 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 574db001cf28..9fca66f20ed0 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rust
-PORTVERSION?= 1.13.0
+PORTVERSION?= 1.14.0
CATEGORIES= lang
MASTER_SITES= http://static.rust-lang.org/dist/:src \
http://static.rust-lang.org/dist/:bootstrap \
@@ -38,7 +38,7 @@ CONFLICTS_BUILD?= rust-nightly
CONFLICTS_BUILD+= ${PKGBASE}
CONFLICTS_INSTALL?= rust-nightly
-RUST_BOOT_VERSION?= 1.12.1
+RUST_BOOT_VERSION?= 1.13.0
RUST_BOOT= rustc-${RUST_BOOT_VERSION}-${RUST_TARGET}.tar.gz
# Rust's libraries are named librustc_${component}-${RUST_VSN_HASH}.so.
@@ -84,7 +84,7 @@ LLNEXTGEN_BUILD_DEPENDS= LLnextgen:devel/llnextgen
PORT_LLVM_DESC= Build against devel/llvm${LLVM_VER} instead of bundled version
PORT_LLVM_BUILD_DEPENDS= ${LLVM_PREFIX}/bin/FileCheck:devel/llvm${LLVM_VER}
PORT_LLVM_CONFIGURE_ON= --llvm-root=${LLVM_PREFIX}
-LLVM_VER?= 38
+LLVM_VER?= 39
LLVM_PREFIX= ${LOCALBASE}/llvm${LLVM_VER}
# Note that make test does not work when rust is already installed
diff --git a/lang/rust/distinfo.amd64 b/lang/rust/distinfo.amd64
index 8b0ea6b85602..c591aeeb26aa 100644
--- a/lang/rust/distinfo.amd64
+++ b/lang/rust/distinfo.amd64
@@ -1,5 +1,5 @@
-TIMESTAMP = 1478803864
-SHA256 (rustc-1.13.0-src.tar.gz) = ecb84775ca977a5efec14d0cad19621a155bfcbbf46e8050d18721bb1e3e5084
-SIZE (rustc-1.13.0-src.tar.gz) = 27483805
-SHA256 (rustc-1.12.1-x86_64-unknown-freebsd.tar.gz) = 79a4d3b725486c52ab8911019b9f5a9800863dd747de8a5a741176f4b4901699
-SIZE (rustc-1.12.1-x86_64-unknown-freebsd.tar.gz) = 49682160
+TIMESTAMP = 1482570598
+SHA256 (rustc-1.14.0-src.tar.gz) = c790edd2e915bd01bea46122af2942108479a2fda9a6f76d1094add520ac3b6b
+SIZE (rustc-1.14.0-src.tar.gz) = 27572650
+SHA256 (rustc-1.13.0-x86_64-unknown-freebsd.tar.gz) = d471b5d06e3c9e5539ef29b851cb5640dee66a52289631726b1442a5d32a2b40
+SIZE (rustc-1.13.0-x86_64-unknown-freebsd.tar.gz) = 36972180
diff --git a/lang/rust/distinfo.i386 b/lang/rust/distinfo.i386
index 6b0f703659d7..6514e95b7d8b 100644
--- a/lang/rust/distinfo.i386
+++ b/lang/rust/distinfo.i386
@@ -1,5 +1,5 @@
-TIMESTAMP = 1478803885
-SHA256 (rustc-1.13.0-src.tar.gz) = ecb84775ca977a5efec14d0cad19621a155bfcbbf46e8050d18721bb1e3e5084
-SIZE (rustc-1.13.0-src.tar.gz) = 27483805
-SHA256 (rustc-1.12.1-i686-unknown-freebsd.tar.gz) = d4fec5ac025d6237187d9b1c60ee105c38189f517287b42f4364b7e4c09cb660
-SIZE (rustc-1.12.1-i686-unknown-freebsd.tar.gz) = 51262713
+TIMESTAMP = 1482570615
+SHA256 (rustc-1.14.0-src.tar.gz) = c790edd2e915bd01bea46122af2942108479a2fda9a6f76d1094add520ac3b6b
+SIZE (rustc-1.14.0-src.tar.gz) = 27572650
+SHA256 (rustc-1.13.0-i686-unknown-freebsd.tar.gz) = c6475f66b923e492de565d63ae5e0848474248dd7342660f3795e196e833741a
+SIZE (rustc-1.13.0-i686-unknown-freebsd.tar.gz) = 38709667
diff --git a/lang/rust/pkg-plist b/lang/rust/pkg-plist
index 5089bb343e0e..158f12240ce2 100644
--- a/lang/rust/pkg-plist
+++ b/lang/rust/pkg-plist
@@ -8,6 +8,8 @@ lib/libgetopts-%%RUST_VSN_HASH%%.so
lib/libgraphviz-%%RUST_VSN_HASH%%.so
lib/liblog-%%RUST_VSN_HASH%%.so
lib/libproc_macro-%%RUST_VSN_HASH%%.so
+lib/libproc_macro_plugin-%%RUST_VSN_HASH%%.so
+lib/libproc_macro_tokens-%%RUST_VSN_HASH%%.so
lib/librustc-%%RUST_VSN_HASH%%.so
lib/librustc_back-%%RUST_VSN_HASH%%.so
lib/librustc_borrowck-%%RUST_VSN_HASH%%.so
@@ -19,7 +21,6 @@ lib/librustc_errors-%%RUST_VSN_HASH%%.so
lib/librustc_incremental-%%RUST_VSN_HASH%%.so
lib/librustc_lint-%%RUST_VSN_HASH%%.so
lib/librustc_llvm-%%RUST_VSN_HASH%%.so
-lib/librustc_macro-%%RUST_VSN_HASH%%.so
lib/librustc_metadata-%%RUST_VSN_HASH%%.so
lib/librustc_mir-%%RUST_VSN_HASH%%.so
lib/librustc_passes-%%RUST_VSN_HASH%%.so
@@ -64,6 +65,8 @@ lib/rustlib/%%RUST_TARGET%%/lib/liblog-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/libpanic_abort-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libpanic_unwind-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/libproc_macro-%%RUST_VSN_HASH%%.so
+lib/rustlib/%%RUST_TARGET%%/lib/libproc_macro_plugin-%%RUST_VSN_HASH%%.so
+lib/rustlib/%%RUST_TARGET%%/lib/libproc_macro_tokens-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librand-%%RUST_VSN_HASH%%.rlib
lib/rustlib/%%RUST_TARGET%%/lib/librustc-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_back-%%RUST_VSN_HASH%%.so
@@ -77,7 +80,6 @@ lib/rustlib/%%RUST_TARGET%%/lib/librustc_errors-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_incremental-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_lint-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_llvm-%%RUST_VSN_HASH%%.so
-lib/rustlib/%%RUST_TARGET%%/lib/librustc_macro-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_metadata-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_mir-%%RUST_VSN_HASH%%.so
lib/rustlib/%%RUST_TARGET%%/lib/librustc_passes-%%RUST_VSN_HASH%%.so