aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorjoe <joe@FreeBSD.org>2001-04-28 23:08:08 +0800
committerjoe <joe@FreeBSD.org>2001-04-28 23:08:08 +0800
commit5b9b6f4eab02b42f0d6077d855308c0faaaa0de9 (patch)
treeb4f772d1c283800e004a3903b5c257f623ae464d /lang
parentfa8aa2f999e49cf40ad40ee7336048e84c92f329 (diff)
downloadfreebsd-ports-gnome-5b9b6f4eab02b42f0d6077d855308c0faaaa0de9.tar.gz
freebsd-ports-gnome-5b9b6f4eab02b42f0d6077d855308c0faaaa0de9.tar.zst
freebsd-ports-gnome-5b9b6f4eab02b42f0d6077d855308c0faaaa0de9.zip
Switch.pm provides the syntax and semantics for an explicit case
mechanism for Perl. The syntax is minimal, introducing only the keywords switch and case and conforming to the general pattern of existing Perl control structures. The semantics are particularly rich, allowing any one (or more) of nearly 30 forms of matching to be used when comparing a switch value with its various cases. PR: ports/26875
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/p5-Switch/Makefile25
-rw-r--r--lang/p5-Switch/distinfo1
-rw-r--r--lang/p5-Switch/pkg-comment1
-rw-r--r--lang/p5-Switch/pkg-descr9
-rw-r--r--lang/p5-Switch/pkg-plist4
6 files changed, 41 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index cba225e45e3d..ae4c6c64127b 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -84,6 +84,7 @@
SUBDIR += p5-Error
SUBDIR += p5-Expect
SUBDIR += p5-F77
+ SUBDIR += p5-Switch
SUBDIR += p5-Tcl
SUBDIR += p5-ePerl
SUBDIR += pbasic
diff --git a/lang/p5-Switch/Makefile b/lang/p5-Switch/Makefile
new file mode 100644
index 000000000000..b664c2ef85bd
--- /dev/null
+++ b/lang/p5-Switch/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: lang/p5-Switch
+# Date created: 26 April 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Switch
+PORTVERSION= 2.02
+CATEGORIES= lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/DCONWAY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Switch.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/lang/p5-Switch/distinfo b/lang/p5-Switch/distinfo
new file mode 100644
index 000000000000..7a27341a3a79
--- /dev/null
+++ b/lang/p5-Switch/distinfo
@@ -0,0 +1 @@
+MD5 (Switch-2.02.tar.gz) = 91e1d2dfb0b78e7a8ab1451f685fb94b
diff --git a/lang/p5-Switch/pkg-comment b/lang/p5-Switch/pkg-comment
new file mode 100644
index 000000000000..d80fcf71ae53
--- /dev/null
+++ b/lang/p5-Switch/pkg-comment
@@ -0,0 +1 @@
+Switch - A switch statement for Perl
diff --git a/lang/p5-Switch/pkg-descr b/lang/p5-Switch/pkg-descr
new file mode 100644
index 000000000000..a9faa6459402
--- /dev/null
+++ b/lang/p5-Switch/pkg-descr
@@ -0,0 +1,9 @@
+Switch.pm provides the syntax and semantics for an explicit case
+mechanism for Perl. The syntax is minimal, introducing only the
+keywords switch and case and conforming to the general pattern of
+existing Perl control structures. The semantics are particularly
+rich, allowing any one (or more) of nearly 30 forms of matching to
+be used when comparing a switch value with its various cases.
+
+-Anton
+<tobez@tobez.org>
diff --git a/lang/p5-Switch/pkg-plist b/lang/p5-Switch/pkg-plist
new file mode 100644
index 000000000000..71a1f25a70f6
--- /dev/null
+++ b/lang/p5-Switch/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Switch/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/demo.pl
+lib/perl5/site_perl/%%PERL_VER%%/Switch.pm
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Switch 2>/dev/null || true