aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2007-02-14 03:14:43 +0800
committeranray <anray@FreeBSD.org>2007-02-14 03:14:43 +0800
commit5c2987eca4cfecee75eecc1a36f70a385b54de16 (patch)
tree7f2049901de7aa04823c43dfb297f6dfeacd40de /lang
parent2e05395cd1736d2e7e4efb6fddd3b10db5e91d32 (diff)
downloadfreebsd-ports-gnome-5c2987eca4cfecee75eecc1a36f70a385b54de16.tar.gz
freebsd-ports-gnome-5c2987eca4cfecee75eecc1a36f70a385b54de16.tar.zst
freebsd-ports-gnome-5c2987eca4cfecee75eecc1a36f70a385b54de16.zip
Update to 2.2
PR: ports/109042 Submitted by: Hirohisa Yamaguchi(maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/haskell-mode.el/Makefile7
-rw-r--r--lang/haskell-mode.el/distinfo6
-rw-r--r--lang/haskell-mode.el/files/patch-haskell-indent.el11
3 files changed, 17 insertions, 7 deletions
diff --git a/lang/haskell-mode.el/Makefile b/lang/haskell-mode.el/Makefile
index b317d57f36c8..6d093f170e2d 100644
--- a/lang/haskell-mode.el/Makefile
+++ b/lang/haskell-mode.el/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= haskell-mode
-PORTVERSION= 2.1
+PORTVERSION= 2.2
CATEGORIES= lang elisp
-MASTER_SITES= http://www.iro.umontreal.ca/~monnier/elisp/ \
- http://macemacsjp.sourceforge.jp/package/20051117/GPL/
+MASTER_SITES= http://www.iro.umontreal.ca/~monnier/elisp/
MAINTAINER= umq@ueo.co.jp
COMMENT= An Emacs lisp mode for editing haskell programs
@@ -27,7 +26,7 @@ PLIST_FILES= ${ELISPFILES:C/^| [^ ]/${PLIST_DIRS}/g}
.if !defined(NOPORTDOCS)
PORTDOCS= ChangeLog NEWS fontlock.hs indent.hs \
- index.html installation-guide.html
+ README index.html
.endif
do-install:
diff --git a/lang/haskell-mode.el/distinfo b/lang/haskell-mode.el/distinfo
index 63192a2cf3e8..20a5078b47c3 100644
--- a/lang/haskell-mode.el/distinfo
+++ b/lang/haskell-mode.el/distinfo
@@ -1,3 +1,3 @@
-MD5 (haskell-mode-2.1.tar.gz) = df6c6d62777c2ea6cdd5455a0010e7e2
-SHA256 (haskell-mode-2.1.tar.gz) = 51c7529b217aafdf3cef843e0fc25b3735bebb259effd9c8bc6e8f72a4b65046
-SIZE (haskell-mode-2.1.tar.gz) = 73855
+MD5 (haskell-mode-2.2.tar.gz) = c911d1d2e8c7864834ab37e6cd7fcbbf
+SHA256 (haskell-mode-2.2.tar.gz) = 0bcc23ad01f88386b9e54f30a94b819761ee32ea4b0093f63cf9fea6b3e362cf
+SIZE (haskell-mode-2.2.tar.gz) = 77480
diff --git a/lang/haskell-mode.el/files/patch-haskell-indent.el b/lang/haskell-mode.el/files/patch-haskell-indent.el
new file mode 100644
index 000000000000..0144a3ecc91c
--- /dev/null
+++ b/lang/haskell-mode.el/files/patch-haskell-indent.el
@@ -0,0 +1,11 @@
+--- ./haskell-indent.el.orig Sat Feb 10 06:55:43 2007
++++ ./haskell-indent.el Mon Feb 12 00:05:35 2007
+@@ -316,7 +316,7 @@
+
+ (defcustom haskell-indent-look-past-empty-line t
+ "If nil, indentation engine will not look past an empty line for layout points."
+- :trype 'boolean)
++ :type 'boolean)
+
+ (defun haskell-indent-start-of-def ()
+ "Return the position of the start of a definition.