aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-20 23:07:07 +0800
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-20 23:07:07 +0800
commit63f363b5c91d72ad425fce37f14e64ac5aba0fe1 (patch)
treeebbce14d69f3c67021ea3463d0d410413d341dde /lang
parent1b18054d5ffc6141b810793ab144bb1d8ac2c4cc (diff)
downloadfreebsd-ports-gnome-63f363b5c91d72ad425fce37f14e64ac5aba0fe1.tar.gz
freebsd-ports-gnome-63f363b5c91d72ad425fce37f14e64ac5aba0fe1.tar.zst
freebsd-ports-gnome-63f363b5c91d72ad425fce37f14e64ac5aba0fe1.zip
Support staging
Diffstat (limited to 'lang')
-rw-r--r--lang/atlast/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/lang/atlast/Makefile b/lang/atlast/Makefile
index 34e9643e4010..2b34e977f253 100644
--- a/lang/atlast/Makefile
+++ b/lang/atlast/Makefile
@@ -14,19 +14,18 @@ PLIST_FILES= bin/${PORTNAME}
PORTDOCS= atlast.html atlast.pdf
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e "/^COPTIONS = /s, = .*, = ${CFLAGS}, " \
-e "/^CC = /s,= .*, = ${CC}," \
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>