aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2013-05-23 05:56:53 +0800
committerbrooks <brooks@FreeBSD.org>2013-05-23 05:56:53 +0800
commit6ade25d1bb792bbd5358a8574d92c50df51cedef (patch)
tree98f0d298831c1c29f9c21334beb4c941748ebdb8 /lang
parent90303fb2ef5e4bc1c4bc9f6d270e3d86fa3acd13 (diff)
downloadfreebsd-ports-gnome-6ade25d1bb792bbd5358a8574d92c50df51cedef.tar.gz
freebsd-ports-gnome-6ade25d1bb792bbd5358a8574d92c50df51cedef.tar.zst
freebsd-ports-gnome-6ade25d1bb792bbd5358a8574d92c50df51cedef.zip
Install a more complete set of intrinsics header files[0].
Add a couple upstream svn revs that have been comitted to base[1]: r172354: Refactor the x86 CPU name logic in the driver and pass -march and -mcpu flag information down from the Clang driver into the Gold linker plugin for LTO. This allows specifying -march on the linker commandline and should hopefully have it pass all the way through to the LTO optimizer. r175919: Driver: Pass down the -march setting down to -cc1as on x86 too. The assembler historically didn't make use of any target features, but this has changed when support for old CPUs that don't support long nops was added. Requested by: dim[1], eadler[0]
Diffstat (limited to 'lang')
-rw-r--r--lang/clang/Makefile17
1 files changed, 16 insertions, 1 deletions
diff --git a/lang/clang/Makefile b/lang/clang/Makefile
index b6845ccad5e4..9f5cbf438aca 100644
--- a/lang/clang/Makefile
+++ b/lang/clang/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clang
PORTVERSION= 3.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= lang devel
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
@@ -180,4 +180,19 @@ build-plist:
${SED} -e 's|${DATADIR}|@dirrm %%DATADIR%%|' \
-e 's|${DOCSDIR}|%%PORTDOCS%%@dirrm %%DOCSDIR%%|' >> ${PLIST}
+.if make(svn-patch)
+.if !defined(PATCH_REV)
+.error svn-patch requires that PATCH_REV be set
+.endif
+_PATCH_FILE=${FILESDIR}/patch-svn-${PATCH_REV}
+_LLVM_BASE=http://llvm.org/svn/llvm-project/cfe/trunk
+svn-patch:
+ printf "$$%s$$\n" FreeBSD > ${_PATCH_FILE}
+ svn log -c ${PATCH_REV} ${_LLVM_BASE} >> ${_PATCH_FILE}
+ svn diff -c ${PATCH_REV} ${_LLVM_BASE} | \
+ sed -e 's;^--- ;--- tools/clang/;' | \
+ sed -e 's;^+++ ;+++ tools/clang/;' >> \
+ ${_PATCH_FILE}
+.endif
+
.include <bsd.port.post.mk>
commitgraph'>* - Respect X11BASErafan2006-11-301-3/+5 * - Fix wrong ownership on some installed filesrafan2006-10-111-1/+2 * Allow package buildskris2006-09-031-1/+1 * "Personal use only" means no redistribution; mark RESTRICTEDkris2006-09-031-1/+1 * Remove USE_REINPLACE from ports in categories starting with A.edwin2006-05-031-1/+0 * . Work around the distributed Makefile formatting the manual page beforeglewis2006-04-071-0/+1 * Update to 3.7.1.osa2005-12-065-33/+98 * Fix plist.novel2005-06-171-2/+2 * - Update to 3.6.4pat2005-06-102-4/+4 * Update to 3.6.3vs2005-01-182-3/+3 * Update to 3.6.2arved2005-01-103-5/+6 * - Update to 3.6.1pav2004-10-122-3/+3 * Fix test for existence of DISTFILES. Be a bit more verbose in the IGNOREtg2004-07-231-2/+9 * Upgrade to 3.6.tg2004-06-25