aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>1999-05-01 00:36:22 +0800
committertaoka <taoka@FreeBSD.org>1999-05-01 00:36:22 +0800
commit6c10b00340e3623b8f21d934898688967d8b7a42 (patch)
tree9622115ed55ac0f653a87aa0035c0331485db311 /lang
parentb4d8b3a7dc919d623179c225a0d881523d59e985 (diff)
downloadfreebsd-ports-gnome-6c10b00340e3623b8f21d934898688967d8b7a42.tar.gz
freebsd-ports-gnome-6c10b00340e3623b8f21d934898688967d8b7a42.tar.zst
freebsd-ports-gnome-6c10b00340e3623b8f21d934898688967d8b7a42.zip
MIT Object Tcl
PR: 11338 Submitted by: Oscar Bonilla <obonilla@fisicc-ufm.edu>
Diffstat (limited to 'lang')
-rw-r--r--lang/otcl/Makefile19
-rw-r--r--lang/otcl/distinfo1
-rw-r--r--lang/otcl/pkg-comment1
-rw-r--r--lang/otcl/pkg-descr24
-rw-r--r--lang/otcl/pkg-plist5
5 files changed, 50 insertions, 0 deletions
diff --git a/lang/otcl/Makefile b/lang/otcl/Makefile
new file mode 100644
index 000000000000..e460383ce085
--- /dev/null
+++ b/lang/otcl/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: otcl
+# Version required: 1.0a4
+# Date created: 23 April 1999
+# Whom: obonilla
+#
+# $Id$
+#
+
+DISTNAME= otcl-1.0a4
+CATEGORIES= lang
+MASTER_SITES= http://www-mash.cs.berkeley.edu/dist/
+
+MAINTAINER= obonilla@fisicc-ufm.edu
+
+LIB_DEPENDS= tcl80.1:${PORTSDIR}/lang/tcl80
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --includedir=${PREFIX}/include/tcl8.0/generic
+.include <bsd.port.mk>
diff --git a/lang/otcl/distinfo b/lang/otcl/distinfo
new file mode 100644
index 000000000000..ebd64c3df6c4
--- /dev/null
+++ b/lang/otcl/distinfo
@@ -0,0 +1 @@
+MD5 (otcl-1.0a4.tar.gz) = 1aafd63973857991b90d08b9dcf29e03
diff --git a/lang/otcl/pkg-comment b/lang/otcl/pkg-comment
new file mode 100644
index 000000000000..d342245c25f3
--- /dev/null
+++ b/lang/otcl/pkg-comment
@@ -0,0 +1 @@
+MIT Object Tcl
diff --git a/lang/otcl/pkg-descr b/lang/otcl/pkg-descr
new file mode 100644
index 000000000000..638dca907aab
--- /dev/null
+++ b/lang/otcl/pkg-descr
@@ -0,0 +1,24 @@
+From the README:
+
+ OTcl, short for MIT Object Tcl, is an extension to Tcl/Tk for
+ object-oriented programming. It shouldn't be confused with the IXI
+ Object Tcl extension by Dean Sheenan. (Sorry, but we both like the
+ name and have been using it for a while.)
+
+ Some of OTcl's features as compared to alternatives are:
+ * designed to be dynamically extensible, like Tcl, from the ground
+ up
+ * builds on Tcl syntax and concepts rather than importing another
+ language
+ * compact yet powerful object programming system (draws on CLOS,
+ Smalltalk, and Self)
+ * fairly portable implementation (2000 lines of C, without core
+ hacks)
+
+ OTcl was presented at the Tcl/Tk Workshop '95. It constitutes a
+ standalone release of a system that has been in use, embedded in the
+ VuSystem, for two years. We made the release public (with free use,
+ distribution and modification under the MIT license) to meet the
+ demand for object-oriented programming in Tcl.
+
+-Oscar <obonilla@fisicc-ufm.edu>
diff --git a/lang/otcl/pkg-plist b/lang/otcl/pkg-plist
new file mode 100644
index 000000000000..f0f24c23686e
--- /dev/null
+++ b/lang/otcl/pkg-plist
@@ -0,0 +1,5 @@
+bin/otclsh
+bin/owish
+include/otcl.h
+lib/libotcl.a
+lib/libotcl.so.1