aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-05-18 18:15:44 +0800
committerkris <kris@FreeBSD.org>2003-05-18 18:15:44 +0800
commit6d1e80877eed5d77a731ac7a8f5ac22e9ce19487 (patch)
tree87a860d286ec42be4dbf00e6d5d1a72bd7cbe8b7 /lang
parente6337684a674e6c3f5a382f4ca7ec4fcfbd10a3f (diff)
downloadfreebsd-ports-gnome-6d1e80877eed5d77a731ac7a8f5ac22e9ce19487.tar.gz
freebsd-ports-gnome-6d1e80877eed5d77a731ac7a8f5ac22e9ce19487.tar.zst
freebsd-ports-gnome-6d1e80877eed5d77a731ac7a8f5ac22e9ce19487.zip
BROKEN on 5.1: does not compile
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc27/Makefile4
-rw-r--r--lang/ici/Makefile8
-rw-r--r--lang/nickle/Makefile8
3 files changed, 18 insertions, 2 deletions
diff --git a/lang/gcc27/Makefile b/lang/gcc27/Makefile
index d12d3432d3f4..e399f28dadf9 100644
--- a/lang/gcc27/Makefile
+++ b/lang/gcc27/Makefile
@@ -26,6 +26,10 @@ LATEST_LINK= gcc27
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
GCC_VER= 2.7.2.3
CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
PLIST_SUB= GNUHOST=${CONFIGURE_TARGET} GCC_VER=${GCC_VER}
diff --git a/lang/ici/Makefile b/lang/ici/Makefile
index 9387b5bb2954..a675284f72a3 100644
--- a/lang/ici/Makefile
+++ b/lang/ici/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= http://www.zeta.org.au/~atrn/ici/distfiles/
MAINTAINER= atrn@zeta.org.au
COMMENT= An interpretive language with C's overall feel combined with high level data types
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
MAKEFILE= Makefile.bsd
MAN1= ici3.1
MANCOMPRESSED= yes
@@ -53,4 +59,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/nickle/Makefile b/lang/nickle/Makefile
index a973154ac52e..ecaec8fb0e90 100644
--- a/lang/nickle/Makefile
+++ b/lang/nickle/Makefile
@@ -13,10 +13,16 @@ MASTER_SITES= http://www.nickle.org/release/
MAINTAINER= chrise@scardini.com
COMMENT= A desk calculator language
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile"
+.endif
+
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= nickle.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>