aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-11-20 03:33:10 +0800
committerriggs <riggs@FreeBSD.org>2016-11-20 03:33:10 +0800
commit6f4e645b302bf2f65a292847699b197afd613e3f (patch)
tree1e52002672fde396fde325ac0ccaa7e6daf991e4 /lang
parent108662aefc3a8a922f59edfa1c68f078c17c17eb (diff)
downloadfreebsd-ports-gnome-6f4e645b302bf2f65a292847699b197afd613e3f.tar.gz
freebsd-ports-gnome-6f4e645b302bf2f65a292847699b197afd613e3f.tar.zst
freebsd-ports-gnome-6f4e645b302bf2f65a292847699b197afd613e3f.zip
Add new port: lang/neko, the neko programming language and VM
PR: 204664 Submitted by: penzin.dev@gmail.com (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/neko/Makefile35
-rw-r--r--lang/neko/distinfo3
-rw-r--r--lang/neko/pkg-descr7
-rw-r--r--lang/neko/pkg-plist22
5 files changed, 68 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 3c5af8b1f1c5..dae04807dead 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -184,6 +184,7 @@
SUBDIR += nawk
SUBDIR += nbc
SUBDIR += nbfc
+ SUBDIR += neko
SUBDIR += nesasm
SUBDIR += newlisp
SUBDIR += newlisp-devel
diff --git a/lang/neko/Makefile b/lang/neko/Makefile
new file mode 100644
index 000000000000..e9c5b3aa0bd9
--- /dev/null
+++ b/lang/neko/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= neko
+PORTVERSION= 2.1.0
+CATEGORIES= lang
+
+MAINTAINER= penzin.dev@gmail.com
+COMMENT= Neko programming languages and virtual machine
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/git:devel/git ${LOCALBASE}/include/apache22/httpd.h:www/apache22
+LIB_DEPENDS= libgc-threaded.so:devel/boehm-gc-threaded \
+ libapr-1.so:devel/apr1 libaprutil-1.so:devel/apr1 \
+ libpcre.so:devel/pcre libpcreposix.so:devel/pcre \
+ libmbedtls.so:security/mbedtls libmbedcrypto.so:security/mbedtls libmbedx509.so:security/mbedtls \
+ libfontconfig.so:x11-fonts/fontconfig libfreetype.so:print/freetype2 \
+ libmysqlclient.so:databases/mysql56-client \
+ libsqlite3.so:databases/sqlite3
+
+BROKEN_FreeBSD_9= does not build
+
+USES= cmake pkgconfig
+
+USE_GNOME= gtk20 pango atk cairo gdkpixbuf2 glib20
+USE_GITHUB= yes
+GH_ACCOUNT= HaxeFoundation
+# GH_PROJECT is the same as port name
+GH_TAGNAME= f8d55f1
+
+USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/neko
+
+MAKE_JOBS_UNSAFE=yes
+
+.include <bsd.port.mk>
diff --git a/lang/neko/distinfo b/lang/neko/distinfo
new file mode 100644
index 000000000000..80e0dacbe8ef
--- /dev/null
+++ b/lang/neko/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1479575506
+SHA256 (HaxeFoundation-neko-2.1.0-f8d55f1_GH0.tar.gz) = bf4d115882c75ba138a3e7037896314243008d4a17620c77cb5666c58b7d7a3d
+SIZE (HaxeFoundation-neko-2.1.0-f8d55f1_GH0.tar.gz) = 508189
diff --git a/lang/neko/pkg-descr b/lang/neko/pkg-descr
new file mode 100644
index 000000000000..b420a70207f5
--- /dev/null
+++ b/lang/neko/pkg-descr
@@ -0,0 +1,7 @@
+The Neko Programming Language
+
+Neko is a high-level dynamically typed programming language which can
+also be used as an embedded scripting language. It has been designed to
+provide a common runtime for several different languages.
+
+WWW: http://nekovm.org/
diff --git a/lang/neko/pkg-plist b/lang/neko/pkg-plist
new file mode 100644
index 000000000000..9f36cd57c167
--- /dev/null
+++ b/lang/neko/pkg-plist
@@ -0,0 +1,22 @@
+bin/neko
+bin/nekoc
+bin/nekoml
+bin/nekotools
+include/neko.h
+include/neko_elf.h
+include/neko_mod.h
+include/neko_vm.h
+lib/libneko.so
+lib/libneko.so.2
+lib/libneko.so.2.1.0
+lib/neko/mod_neko2.ndll
+lib/neko/mod_tora2.ndll
+lib/neko/mysql.ndll
+lib/neko/mysql5.ndll
+lib/neko/nekoml.std
+lib/neko/regexp.ndll
+lib/neko/sqlite.ndll
+lib/neko/ssl.ndll
+lib/neko/std.ndll
+lib/neko/zlib.ndll
+lib/neko/ui.ndll