aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2002-11-13 22:39:52 +0800
committernetchild <netchild@FreeBSD.org>2002-11-13 22:39:52 +0800
commit71e376d2b1b4d1ed0406b0ba856164000ac1caa2 (patch)
treecb1e33950b597891ea7f8980ec662a3dbbd065e4 /lang
parent5a4f3619366375de1481a763823268ba8e157274 (diff)
downloadfreebsd-ports-gnome-71e376d2b1b4d1ed0406b0ba856164000ac1caa2.tar.gz
freebsd-ports-gnome-71e376d2b1b4d1ed0406b0ba856164000ac1caa2.tar.zst
freebsd-ports-gnome-71e376d2b1b4d1ed0406b0ba856164000ac1caa2.zip
- fix typo in message
- catch up with __sF change in -stable Tested by: marius@alchemy.franken.de
Diffstat (limited to 'lang')
-rw-r--r--lang/icc/Makefile5
-rw-r--r--lang/icc7/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 13349856529d..e11c54316ef4 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -45,7 +45,7 @@ IGNORE= "Please manually download ${DISTFILES} from ${ICC_SITE}, ${ICC_SITE}c60l
.if exists(${LINUXBASE}/boot/kernel.h) || \
exists(${PREFIX}/intel/compiler60/bin/ifc)
-BROKEN= Can not coexist with linux_devtools or ifc
+BROKEN= Cannot coexist with linux_devtools or ifc
.endif
post-extract:
@@ -114,7 +114,8 @@ do-build:
@cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/assert_fail.c \
${FILESDIR}/cxa_atexit.c ${FILESDIR}/cxa_finalize.c \
${FILESDIR}/errno_location.c ${FILESDIR}/mcount.S
-.if ${OSVERSION} < 500042
+.if ( ${OSVERSION} < 470101 ) || \
+ ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500042 )
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stderr.o ${FILESDIR}/stderr.c
.else
.for i in libcxa.a libimf.a libirc.a libircmt.a libunwind.a
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index 13349856529d..e11c54316ef4 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -45,7 +45,7 @@ IGNORE= "Please manually download ${DISTFILES} from ${ICC_SITE}, ${ICC_SITE}c60l
.if exists(${LINUXBASE}/boot/kernel.h) || \
exists(${PREFIX}/intel/compiler60/bin/ifc)
-BROKEN= Can not coexist with linux_devtools or ifc
+BROKEN= Cannot coexist with linux_devtools or ifc
.endif
post-extract:
@@ -114,7 +114,8 @@ do-build:
@cd ${WRKSRC} && ${CC} ${CFLAGS} -c ${FILESDIR}/assert_fail.c \
${FILESDIR}/cxa_atexit.c ${FILESDIR}/cxa_finalize.c \
${FILESDIR}/errno_location.c ${FILESDIR}/mcount.S
-.if ${OSVERSION} < 500042
+.if ( ${OSVERSION} < 470101 ) || \
+ ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500042 )
@${CC} ${CFLAGS} -c -o ${WRKSRC}/stderr.o ${FILESDIR}/stderr.c
.else
.for i in libcxa.a libimf.a libirc.a libircmt.a libunwind.a