aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2017-01-14 00:54:55 +0800
committermat <mat@FreeBSD.org>2017-01-14 00:54:55 +0800
commit7213ad9c4b6b590c338dd41e8ecbd08674020987 (patch)
tree545ac8faaf58a17f5075028cc7de936c43e387a2 /lang
parent280c6e4b964d25005485b5668428262f0a8f4ab4 (diff)
downloadfreebsd-ports-gnome-7213ad9c4b6b590c338dd41e8ecbd08674020987.tar.gz
freebsd-ports-gnome-7213ad9c4b6b590c338dd41e8ecbd08674020987.tar.zst
freebsd-ports-gnome-7213ad9c4b6b590c338dd41e8ecbd08674020987.zip
Fix ports using PREFIX in their depends instead of LOCALBASE.
With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'lang')
-rw-r--r--lang/clang37/Makefile2
-rw-r--r--lang/js_of_ocaml/Makefile2
-rw-r--r--lang/pypy/Makefile6
-rw-r--r--lang/rhino/Makefile2
4 files changed, 6 insertions, 6 deletions
diff --git a/lang/clang37/Makefile b/lang/clang37/Makefile
index 8ee3252a5cca..788ada95ae1c 100644
--- a/lang/clang37/Makefile
+++ b/lang/clang37/Makefile
@@ -10,7 +10,7 @@ PKGNAMESUFFIX= ${LLVM_SUFFIX}
MAINTAINER= brooks@FreeBSD.org
COMMENT= C, Objective-C, and C++ compiler (use devel/llvm${LLVM_SUFFIX})
-RUN_DEPENDS+= ${PREFIX}/bin/clang${LLVM_SUFFIX}:devel/llvm${LLVM_SUFFIX}
+RUN_DEPENDS+= ${LOCALBASE}/bin/clang${LLVM_SUFFIX}:devel/llvm${LLVM_SUFFIX}
LLVM_SUFFIX= 37
diff --git a/lang/js_of_ocaml/Makefile b/lang/js_of_ocaml/Makefile
index f350e61a2632..3f72a4455d52 100644
--- a/lang/js_of_ocaml/Makefile
+++ b/lang/js_of_ocaml/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ocaml-lwt>=2.3.0:devel/ocaml-lwt \
${SA_DIR}/deriving-ocsigen/deriving.a:devel/ocaml-deriving-ocsigen \
${SA_DIR}/cmdliner/cmdliner.a:devel/ocaml-cmdliner
-SA_DIR= ${PREFIX}/${OCAML_SITELIBDIR}
+SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
USES= gmake
USE_OCAML= yes
diff --git a/lang/pypy/Makefile b/lang/pypy/Makefile
index 5a862d6ccc31..aa5c5cec31b4 100644
--- a/lang/pypy/Makefile
+++ b/lang/pypy/Makefile
@@ -12,9 +12,9 @@ COMMENT= Fast, compliant implementation of the Python language
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libffi.so:devel/libffi
-TEST_DEPENDS= ${PREFIX}/${PYPY_DIR}/lib_pypy/_gdbm_cffi.${PYPY_CFFI_VER}.so:databases/pypy-gdbm \
- ${PREFIX}/${PYPY_DIR}/lib_pypy/_sqlite3_cffi.${PYPY_CFFI_VER}.so:databases/pypy-sqlite3 \
- ${PREFIX}/${PYPY_DIR}/lib_pypy/_tkinter/tklib_cffi.${PYPY_CFFI_VER}.so:x11-toolkits/pypy-tkinter
+TEST_DEPENDS= ${LOCALBASE}/${PYPY_DIR}/lib_pypy/_gdbm_cffi.${PYPY_CFFI_VER}.so:databases/pypy-gdbm \
+ ${LOCALBASE}/${PYPY_DIR}/lib_pypy/_sqlite3_cffi.${PYPY_CFFI_VER}.so:databases/pypy-sqlite3 \
+ ${LOCALBASE}/${PYPY_DIR}/lib_pypy/_tkinter/tklib_cffi.${PYPY_CFFI_VER}.so:x11-toolkits/pypy-tkinter
ONLY_FOR_ARCHS= i386 amd64 armv6 powerpc64
ONLY_FOR_ARCHS_REASON= PyPy JIT only supported on these architectures
diff --git a/lang/rhino/Makefile b/lang/rhino/Makefile
index 897aa592e83b..0413a7e67204 100644
--- a/lang/rhino/Makefile
+++ b/lang/rhino/Makefile
@@ -41,7 +41,7 @@ GH_ACCOUNT= mozilla
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MLINEDIT}
-JLINEJAR= ${JAVAJARDIR}/jline.jar
+JLINEJAR= ${JAVALIBDIR}/jline.jar
.else
JLINEJAR=""
.endif