aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-02-28 03:00:23 +0800
committerrafan <rafan@FreeBSD.org>2007-02-28 03:00:23 +0800
commit7563f5f145828b96696fefcd0af65a4697645e39 (patch)
tree60caf99f91f69fe69087163473359914c9d160de /lang
parent5309e8563c16e91f338236afe5adfec695b05aec (diff)
downloadfreebsd-ports-gnome-7563f5f145828b96696fefcd0af65a4697645e39.tar.gz
freebsd-ports-gnome-7563f5f145828b96696fefcd0af65a4697645e39.tar.zst
freebsd-ports-gnome-7563f5f145828b96696fefcd0af65a4697645e39.zip
- Force setup.py picks up readline and ncurses from base. This fixes build
when devel/ncurses installed. - Similar to python24, don't pick up ncursesw in python25. This results in both ncurses are linked into _curses.so Tested by: krion Approved by: alexbl (python@)
Diffstat (limited to 'lang')
-rw-r--r--lang/python24/files/patch-setup.py29
-rw-r--r--lang/python25/files/patch-setup.py40
-rw-r--r--lang/python26/files/patch-setup.py40
-rw-r--r--lang/python27/files/patch-setup.py40
-rw-r--r--lang/python30/files/patch-setup.py40
-rw-r--r--lang/python31/files/patch-setup.py40
-rw-r--r--lang/python32/files/patch-setup.py40
7 files changed, 249 insertions, 20 deletions
diff --git a/lang/python24/files/patch-setup.py b/lang/python24/files/patch-setup.py
index b01b73db560a..167e803a1290 100644
--- a/lang/python24/files/patch-setup.py
+++ b/lang/python24/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Mon Nov 27 03:33:44 2006
-+++ setup.py Mon Nov 27 03:35:40 2006
+--- setup.py.orig Tue Feb 27 20:10:53 2007
++++ setup.py Tue Feb 27 20:15:23 2007
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -18,6 +18,15 @@
readline_libs.append('ncursesw')
elif self.compiler.find_library_file(lib_dirs,
'ncurses'):
+@@ -465,7 +465,7 @@
+ readline_extra_link_args = ()
+
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
++ library_dirs=['/usr/lib', '/usr/lib/termcap'],
+ extra_link_args=readline_extra_link_args,
+ libraries=readline_libs) )
+ if platform not in ['mac']:
@@ -728,7 +728,7 @@
# Curses support, requiring the System V version of curses, often
# provided by the ncurses library.
@@ -27,3 +36,19 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
+@@ -738,6 +738,7 @@
+ elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
+ curses_libs = ['ncurses']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = curses_libs) )
+ elif (self.compiler.find_library_file(lib_dirs, 'curses')
+ and platform != 'darwin'):
+@@ -757,6 +758,7 @@
+ if (module_enabled(exts, '_curses') and
+ self.compiler.find_library_file(lib_dirs, panel_library)):
+ exts.append( Extension('_curses_panel', ['_curses_panel.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = [panel_library] + curses_libs) )
+
+
diff --git a/lang/python25/files/patch-setup.py b/lang/python25/files/patch-setup.py
index 9e4651e91aaa..baa0fcc0c0de 100644
--- a/lang/python25/files/patch-setup.py
+++ b/lang/python25/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Thu Aug 10 08:42:18 2006
-+++ setup.py Thu Oct 5 13:26:43 2006
+--- setup.py.orig Thu Aug 10 07:42:18 2006
++++ setup.py Tue Feb 27 20:27:07 2007
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,6 +9,24 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
+@@ -488,7 +488,7 @@
+
+ readline_libs = ['readline']
+ if self.compiler.find_library_file(lib_dirs,
+- 'ncursesw'):
++ 'xxxncursesw'):
+ readline_libs.append('ncursesw')
+ elif self.compiler.find_library_file(lib_dirs,
+ 'ncurses'):
+@@ -500,7 +500,7 @@
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
++ library_dirs=['/usr/lib', '/usr/lib/termcap'],
+ extra_link_args=readline_extra_link_args,
+ libraries=readline_libs) )
+ if platform not in ['mac']:
@@ -590,6 +590,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
@@ -27,7 +45,23 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
-@@ -1498,8 +1500,7 @@
+@@ -913,6 +915,7 @@
+ elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
+ curses_libs = ['ncurses']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = curses_libs) )
+ elif (self.compiler.find_library_file(lib_dirs, 'curses')
+ and platform != 'darwin'):
+@@ -932,6 +935,7 @@
+ if (module_enabled(exts, '_curses') and
+ self.compiler.find_library_file(lib_dirs, panel_library)):
+ exts.append( Extension('_curses_panel', ['_curses_panel.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = [panel_library] + curses_libs) )
+
+
+@@ -1515,8 +1519,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install
diff --git a/lang/python26/files/patch-setup.py b/lang/python26/files/patch-setup.py
index 9e4651e91aaa..baa0fcc0c0de 100644
--- a/lang/python26/files/patch-setup.py
+++ b/lang/python26/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Thu Aug 10 08:42:18 2006
-+++ setup.py Thu Oct 5 13:26:43 2006
+--- setup.py.orig Thu Aug 10 07:42:18 2006
++++ setup.py Tue Feb 27 20:27:07 2007
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,6 +9,24 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
+@@ -488,7 +488,7 @@
+
+ readline_libs = ['readline']
+ if self.compiler.find_library_file(lib_dirs,
+- 'ncursesw'):
++ 'xxxncursesw'):
+ readline_libs.append('ncursesw')
+ elif self.compiler.find_library_file(lib_dirs,
+ 'ncurses'):
+@@ -500,7 +500,7 @@
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
++ library_dirs=['/usr/lib', '/usr/lib/termcap'],
+ extra_link_args=readline_extra_link_args,
+ libraries=readline_libs) )
+ if platform not in ['mac']:
@@ -590,6 +590,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
@@ -27,7 +45,23 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
-@@ -1498,8 +1500,7 @@
+@@ -913,6 +915,7 @@
+ elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
+ curses_libs = ['ncurses']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = curses_libs) )
+ elif (self.compiler.find_library_file(lib_dirs, 'curses')
+ and platform != 'darwin'):
+@@ -932,6 +935,7 @@
+ if (module_enabled(exts, '_curses') and
+ self.compiler.find_library_file(lib_dirs, panel_library)):
+ exts.append( Extension('_curses_panel', ['_curses_panel.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = [panel_library] + curses_libs) )
+
+
+@@ -1515,8 +1519,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install
diff --git a/lang/python27/files/patch-setup.py b/lang/python27/files/patch-setup.py
index 9e4651e91aaa..baa0fcc0c0de 100644
--- a/lang/python27/files/patch-setup.py
+++ b/lang/python27/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Thu Aug 10 08:42:18 2006
-+++ setup.py Thu Oct 5 13:26:43 2006
+--- setup.py.orig Thu Aug 10 07:42:18 2006
++++ setup.py Tue Feb 27 20:27:07 2007
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,6 +9,24 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
+@@ -488,7 +488,7 @@
+
+ readline_libs = ['readline']
+ if self.compiler.find_library_file(lib_dirs,
+- 'ncursesw'):
++ 'xxxncursesw'):
+ readline_libs.append('ncursesw')
+ elif self.compiler.find_library_file(lib_dirs,
+ 'ncurses'):
+@@ -500,7 +500,7 @@
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
++ library_dirs=['/usr/lib', '/usr/lib/termcap'],
+ extra_link_args=readline_extra_link_args,
+ libraries=readline_libs) )
+ if platform not in ['mac']:
@@ -590,6 +590,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
@@ -27,7 +45,23 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
-@@ -1498,8 +1500,7 @@
+@@ -913,6 +915,7 @@
+ elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
+ curses_libs = ['ncurses']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = curses_libs) )
+ elif (self.compiler.find_library_file(lib_dirs, 'curses')
+ and platform != 'darwin'):
+@@ -932,6 +935,7 @@
+ if (module_enabled(exts, '_curses') and
+ self.compiler.find_library_file(lib_dirs, panel_library)):
+ exts.append( Extension('_curses_panel', ['_curses_panel.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = [panel_library] + curses_libs) )
+
+
+@@ -1515,8 +1519,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install
diff --git a/lang/python30/files/patch-setup.py b/lang/python30/files/patch-setup.py
index 9e4651e91aaa..baa0fcc0c0de 100644
--- a/lang/python30/files/patch-setup.py
+++ b/lang/python30/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Thu Aug 10 08:42:18 2006
-+++ setup.py Thu Oct 5 13:26:43 2006
+--- setup.py.orig Thu Aug 10 07:42:18 2006
++++ setup.py Tue Feb 27 20:27:07 2007
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,6 +9,24 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
+@@ -488,7 +488,7 @@
+
+ readline_libs = ['readline']
+ if self.compiler.find_library_file(lib_dirs,
+- 'ncursesw'):
++ 'xxxncursesw'):
+ readline_libs.append('ncursesw')
+ elif self.compiler.find_library_file(lib_dirs,
+ 'ncurses'):
+@@ -500,7 +500,7 @@
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
++ library_dirs=['/usr/lib', '/usr/lib/termcap'],
+ extra_link_args=readline_extra_link_args,
+ libraries=readline_libs) )
+ if platform not in ['mac']:
@@ -590,6 +590,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
@@ -27,7 +45,23 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
-@@ -1498,8 +1500,7 @@
+@@ -913,6 +915,7 @@
+ elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
+ curses_libs = ['ncurses']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = curses_libs) )
+ elif (self.compiler.find_library_file(lib_dirs, 'curses')
+ and platform != 'darwin'):
+@@ -932,6 +935,7 @@
+ if (module_enabled(exts, '_curses') and
+ self.compiler.find_library_file(lib_dirs, panel_library)):
+ exts.append( Extension('_curses_panel', ['_curses_panel.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = [panel_library] + curses_libs) )
+
+
+@@ -1515,8 +1519,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install
diff --git a/lang/python31/files/patch-setup.py b/lang/python31/files/patch-setup.py
index 9e4651e91aaa..baa0fcc0c0de 100644
--- a/lang/python31/files/patch-setup.py
+++ b/lang/python31/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Thu Aug 10 08:42:18 2006
-+++ setup.py Thu Oct 5 13:26:43 2006
+--- setup.py.orig Thu Aug 10 07:42:18 2006
++++ setup.py Tue Feb 27 20:27:07 2007
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,6 +9,24 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
+@@ -488,7 +488,7 @@
+
+ readline_libs = ['readline']
+ if self.compiler.find_library_file(lib_dirs,
+- 'ncursesw'):
++ 'xxxncursesw'):
+ readline_libs.append('ncursesw')
+ elif self.compiler.find_library_file(lib_dirs,
+ 'ncurses'):
+@@ -500,7 +500,7 @@
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
++ library_dirs=['/usr/lib', '/usr/lib/termcap'],
+ extra_link_args=readline_extra_link_args,
+ libraries=readline_libs) )
+ if platform not in ['mac']:
@@ -590,6 +590,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
@@ -27,7 +45,23 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
-@@ -1498,8 +1500,7 @@
+@@ -913,6 +915,7 @@
+ elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
+ curses_libs = ['ncurses']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = curses_libs) )
+ elif (self.compiler.find_library_file(lib_dirs, 'curses')
+ and platform != 'darwin'):
+@@ -932,6 +935,7 @@
+ if (module_enabled(exts, '_curses') and
+ self.compiler.find_library_file(lib_dirs, panel_library)):
+ exts.append( Extension('_curses_panel', ['_curses_panel.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = [panel_library] + curses_libs) )
+
+
+@@ -1515,8 +1519,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install
diff --git a/lang/python32/files/patch-setup.py b/lang/python32/files/patch-setup.py
index 9e4651e91aaa..baa0fcc0c0de 100644
--- a/lang/python32/files/patch-setup.py
+++ b/lang/python32/files/patch-setup.py
@@ -1,5 +1,5 @@
---- setup.py.orig Thu Aug 10 08:42:18 2006
-+++ setup.py Thu Oct 5 13:26:43 2006
+--- setup.py.orig Thu Aug 10 07:42:18 2006
++++ setup.py Tue Feb 27 20:27:07 2007
@@ -15,7 +15,7 @@
from distutils.command.install_lib import install_lib
@@ -9,6 +9,24 @@
def add_dir_to_list(dirlist, dir):
"""Add the directory 'dir' to the list 'dirlist' (at the front) if
+@@ -488,7 +488,7 @@
+
+ readline_libs = ['readline']
+ if self.compiler.find_library_file(lib_dirs,
+- 'ncursesw'):
++ 'xxxncursesw'):
+ readline_libs.append('ncursesw')
+ elif self.compiler.find_library_file(lib_dirs,
+ 'ncurses'):
+@@ -500,7 +500,7 @@
+ 'termcap'):
+ readline_libs.append('termcap')
+ exts.append( Extension('readline', ['readline.c'],
+- library_dirs=['/usr/lib/termcap'],
++ library_dirs=['/usr/lib', '/usr/lib/termcap'],
+ extra_link_args=readline_extra_link_args,
+ libraries=readline_libs) )
+ if platform not in ['mac']:
@@ -590,6 +590,8 @@
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
@@ -27,7 +45,23 @@
curses_libs = ['ncursesw']
# Bug 1464056: If _curses.so links with ncursesw,
# _curses_panel.so must link with panelw.
-@@ -1498,8 +1500,7 @@
+@@ -913,6 +915,7 @@
+ elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
+ curses_libs = ['ncurses']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = curses_libs) )
+ elif (self.compiler.find_library_file(lib_dirs, 'curses')
+ and platform != 'darwin'):
+@@ -932,6 +935,7 @@
+ if (module_enabled(exts, '_curses') and
+ self.compiler.find_library_file(lib_dirs, panel_library)):
+ exts.append( Extension('_curses_panel', ['_curses_panel.c'],
++ library_dirs = ['/usr/lib'],
+ libraries = [panel_library] + curses_libs) )
+
+
+@@ -1515,8 +1519,7 @@
ext_modules=[Extension('_struct', ['_struct.c'])],
# Scripts to install