aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-09-26 22:59:34 +0800
committerkwm <kwm@FreeBSD.org>2015-09-26 22:59:34 +0800
commit7579f6cb2053f17b7b5344edfcffc6183f6c45f3 (patch)
tree40b130f8740a8ac8640b76c881955300acd59773 /lang
parent26e024bbdbff43dece4e929f6104deec587ed50b (diff)
downloadfreebsd-ports-gnome-7579f6cb2053f17b7b5344edfcffc6183f6c45f3.tar.gz
freebsd-ports-gnome-7579f6cb2053f17b7b5344edfcffc6183f6c45f3.tar.zst
freebsd-ports-gnome-7579f6cb2053f17b7b5344edfcffc6183f6c45f3.zip
Relax the BROKEN condition on 10.x.
libc++ on 10.1-R is too old for beignet to build, however beignet builds fine on 10.2-R. Since 10.1-R is use for building packages, this doesn't change the fact that there is no freebsd supplied package sadly.
Diffstat (limited to 'lang')
-rw-r--r--lang/beignet/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/lang/beignet/Makefile b/lang/beignet/Makefile
index 2aeea643fcef..61e94d0a9e4a 100644
--- a/lang/beignet/Makefile
+++ b/lang/beignet/Makefile
@@ -29,7 +29,6 @@ CMAKE_ARGS+= -DLLVM_CONFIG_EXECUTABLE=${LOCALBASE}/bin/llvm-config${LLVMVER}
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= Beignet needs a graphics driver supported by the Intel KMS driver
-BROKEN_FreeBSD_10= Does not build. Help appreciated
BROKEN_FreeBSD_9= Beignet is only supported on FreeBSD 10.1 and newer
# running tests from makefile doesn't work quite yet, so comment them out for now.
@@ -38,6 +37,10 @@ BROKEN_FreeBSD_9= Beignet is only supported on FreeBSD 10.1 and newer
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000 && ${OSVERSION} < 1002000
+BROKEN= Beignet needs FreeBSD 10.2 or newer due to too old libc++ in 10.1-Release
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|llvm-dis|llvm-dis${LLVMVER}|g; \
s|clang |clang${LLVMVER} |g' \