aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-14 07:02:28 +0800
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-14 07:02:28 +0800
commit75bc919f3d02509aa6122e84d1d7a4814e2ba0bf (patch)
treea14bd43167c27c6980eae544463aa727f5afcced /lang
parent2af67e7ff049835b7f0a59789f85fe9bd85cb073 (diff)
downloadfreebsd-ports-gnome-75bc919f3d02509aa6122e84d1d7a4814e2ba0bf.tar.gz
freebsd-ports-gnome-75bc919f3d02509aa6122e84d1d7a4814e2ba0bf.tar.zst
freebsd-ports-gnome-75bc919f3d02509aa6122e84d1d7a4814e2ba0bf.zip
lang/python39: fix build on GCC architectures
Use newer GCC: /wrkdirs/usr/ports/lang/python39/work/Python-3.9.0/Modules/_zoneinfo.c: In function 'calendarrule_new': /wrkdirs/usr/ports/lang/python39/work/Python-3.9.0/Modules/_zoneinfo.c:1227: error: #pragma GCC diagnostic not allowed inside functions /wrkdirs/usr/ports/lang/python39/work/Python-3.9.0/Modules/_zoneinfo.c:1228: error: #pragma GCC diagnostic not allowed inside functions /wrkdirs/usr/ports/lang/python39/work/Python-3.9.0/Modules/_zoneinfo.c:1229: warning: comparison is always false due to limited range of data type /wrkdirs/usr/ports/lang/python39/work/Python-3.9.0/Modules/_zoneinfo.c:1230: error: #pragma GCC diagnostic not allowed inside functions
Diffstat (limited to 'lang')
-rw-r--r--lang/python39/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python39/Makefile b/lang/python39/Makefile
index 53fb18ba0267..9ce6ef92d793 100644
--- a/lang/python39/Makefile
+++ b/lang/python39/Makefile
@@ -14,7 +14,8 @@ COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-USES= cpe ncurses pathfix pkgconfig readline:port shebangfix ssl tar:xz
+USES= compiler:c11 cpe ncurses pathfix pkgconfig readline:port \
+ shebangfix ssl tar:xz
PATHFIX_MAKEFILEIN= Makefile.pre.in
USE_LDCONFIG= yes
GNU_CONFIGURE= yes