aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2011-04-29 23:04:30 +0800
committerbrooks <brooks@FreeBSD.org>2011-04-29 23:04:30 +0800
commit75e14a6d726b6dcabd83d8b3fcc900102ae3f1c6 (patch)
tree4f0a156a1da747258686ecc63f1e18066e16fc13 /lang
parent000ad8aabd608e3a773fcc08e0c54db17516db1d (diff)
downloadfreebsd-ports-gnome-75e14a6d726b6dcabd83d8b3fcc900102ae3f1c6.tar.gz
freebsd-ports-gnome-75e14a6d726b6dcabd83d8b3fcc900102ae3f1c6.tar.zst
freebsd-ports-gnome-75e14a6d726b6dcabd83d8b3fcc900102ae3f1c6.zip
Upgrade LLVM, Clang, and llvm-gcc to 2.9.
Add a number of bug fixes from our base gcc to llvm-gcc.[0] PR: ports/154927 [0] Submitted by: Pedro Giffuni <giffunip at tutopia com> [0]
Diffstat (limited to 'lang')
-rw-r--r--lang/clang/Makefile13
-rw-r--r--lang/clang/distinfo10
-rw-r--r--lang/clang/files/patch-Makefile14
-rw-r--r--lang/clang/files/patch-tools_clang_Makefile14
-rw-r--r--lang/clang/pkg-plist162
-rw-r--r--lang/llvm-gcc4/Makefile2
-rw-r--r--lang/llvm-gcc4/distinfo5
-rw-r--r--lang/llvm-gcc4/files/patch-.._gcc_common.opt16
-rw-r--r--lang/llvm-gcc4/files/patch-.._gcc_config.gcc31
-rw-r--r--lang/llvm-gcc4/files/patch-.._gcc_config_i386_i386.c11
-rw-r--r--lang/llvm-gcc4/files/patch-.._gcc_gthr-posix.h35
11 files changed, 176 insertions, 137 deletions
diff --git a/lang/clang/Makefile b/lang/clang/Makefile
index 50f49b6ab3b5..c38ddd9bf5b1 100644
--- a/lang/clang/Makefile
+++ b/lang/clang/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= clang
-PORTVERSION= 2.8
-PORTREVISION= 2
+PORTVERSION= 2.9
CATEGORIES= lang devel
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
EXTRACT_SUFX= .tgz
@@ -57,9 +56,7 @@ CONFIGURE_ARGS+= --enable-optimized
.endif
.if defined(NOPORTDOCS)
-DOCSRCDIR=
-.else
-DOCSRCDIR= docs
+CONFIGURE_ARGS+= --disable-docs
.endif
MAN1= clang.1
@@ -80,8 +77,6 @@ post-patch:
${WRKSRC}/Makefile.config.in
${REINPLACE_CMD} -e 's|\(PROJ_mandir.*:=\).*$$|\1${MANPREFIX}/man|g' \
${WRKSRC}/Makefile.config.in
- ${REINPLACE_CMD} -e 's|%%DOCSRCDIR%%|${DOCSRCDIR}|' \
- ${WRKSRC}/Makefile ${WRKSRC}/tools/clang/Makefile
${REINPLACE_CMD} -e 's|/usr/bin/env perl|${PERL}|' \
-e 's|%%DATADIR%%|${DATADIR}|' \
${WRKSRC}/tools/clang/tools/scan-build/ccc-analyzer \
@@ -91,7 +86,8 @@ post-patch:
${WRKSRC}/tools/clang/tools/scan-view/scan-view
pre-build:
- ${LN} -s ${LOCALBASE}/include/llvm/Intrinsics.gen ${WRKSRC}/include/llvm/
+ ${LN} -sf ${LOCALBASE}/include/llvm/Intrinsics.gen ${WRKSRC}/include/llvm/
+ cd ${WRKSRC}/utils/unittest && ${GMAKE}
.if defined(NOPORTDOCS)
post-build:
@@ -131,7 +127,6 @@ regression-test: ${BUILD_COOKIE}
PLIST_FILE_LIST= bin/ccc-analyzer \
bin/c++-analyzer \
- bin/c-index-test \
bin/clang \
bin/clang++ \
bin/scan-build \
diff --git a/lang/clang/distinfo b/lang/clang/distinfo
index cc5227dab937..2702663a0017 100644
--- a/lang/clang/distinfo
+++ b/lang/clang/distinfo
@@ -1,6 +1,4 @@
-MD5 (clang-2.8.tgz) = 10e14c901fc3728eecbd5b829e011b59
-SHA256 (clang-2.8.tgz) = ed83481553e6a39a8a2953e89630d881d87833506f096a90f18d93ec2bdee0c1
-SIZE (clang-2.8.tgz) = 5666777
-MD5 (llvm-2.8.tgz) = 220d361b4d17051ff4bb21c64abe05ba
-SHA256 (llvm-2.8.tgz) = 25addb742f1c6cc12877ed0ee924dda962d848368ee095be8e48342ae613d43b
-SIZE (llvm-2.8.tgz) = 9112527
+SHA256 (clang-2.9.tgz) = 70c41f3f782a71cbaa7bc8d6ea29fce4263ad3e8558dfecc6dc11cdef17909df
+SIZE (clang-2.9.tgz) = 6243772
+SHA256 (llvm-2.9.tgz) = 661236cfa17428b48cfa9cbb9909f7569c64b8ecd219fd91dbc00e3b557b3779
+SIZE (llvm-2.9.tgz) = 9574781
diff --git a/lang/clang/files/patch-Makefile b/lang/clang/files/patch-Makefile
deleted file mode 100644
index 2c887b01275d..000000000000
--- a/lang/clang/files/patch-Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.orig
-+++ Makefile
-@@ -31,7 +31,7 @@
- OPTIONAL_DIRS :=
- else
- DIRS := lib/System lib/Support utils lib/VMCore lib tools/llvm-shlib \
-- tools/llvm-config tools runtime docs unittests
-+ tools/llvm-config tools runtime %%DOCSRCDIR%% unittests
- OPTIONAL_DIRS := projects bindings
- endif
-
diff --git a/lang/clang/files/patch-tools_clang_Makefile b/lang/clang/files/patch-tools_clang_Makefile
deleted file mode 100644
index 331b1a29c15e..000000000000
--- a/lang/clang/files/patch-tools_clang_Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- tools/clang/Makefile.orig
-+++ tools/clang/Makefile
-@@ -14,7 +14,7 @@
-
- IS_TOP_LEVEL := 1
- CLANG_LEVEL := .
--DIRS := include lib tools runtime docs
-+DIRS := include lib tools runtime %%DOCSRCDIR%%
-
- PARALLEL_DIRS :=
-
diff --git a/lang/clang/pkg-plist b/lang/clang/pkg-plist
index dfc49ae6dd9e..2af2781663cc 100644
--- a/lang/clang/pkg-plist
+++ b/lang/clang/pkg-plist
@@ -1,5 +1,4 @@
bin/c++-analyzer
-bin/c-index-test
bin/ccc-analyzer
bin/clang
bin/clang++
@@ -12,6 +11,7 @@ include/clang/AST/ASTConsumer.h
include/clang/AST/ASTContext.h
include/clang/AST/ASTDiagnostic.h
include/clang/AST/ASTImporter.h
+include/clang/AST/ASTMutationListener.h
include/clang/AST/ASTVector.h
include/clang/AST/Attr.h
include/clang/AST/AttrImpl.inc
@@ -32,11 +32,12 @@ include/clang/AST/DeclTemplate.h
include/clang/AST/DeclVisitor.h
include/clang/AST/DeclarationName.h
include/clang/AST/DependentDiagnostic.h
+include/clang/AST/EvaluatedExprVisitor.h
include/clang/AST/Expr.h
include/clang/AST/ExprCXX.h
include/clang/AST/ExprObjC.h
include/clang/AST/ExternalASTSource.h
-include/clang/AST/FullExpr.h
+include/clang/AST/Mangle.h
include/clang/AST/NestedNameSpecifier.h
include/clang/AST/OperationKinds.h
include/clang/AST/ParentMap.h
@@ -44,10 +45,6 @@ include/clang/AST/PrettyPrinter.h
include/clang/AST/RecordLayout.h
include/clang/AST/RecursiveASTVisitor.h
include/clang/AST/Redeclarable.h
-include/clang/AST/Release/AttrImpl.inc.tmp
-include/clang/AST/Release/Attrs.inc.tmp
-include/clang/AST/Release/DeclNodes.inc.tmp
-include/clang/AST/Release/StmtNodes.inc.tmp
include/clang/AST/Stmt.h
include/clang/AST/StmtCXX.h
include/clang/AST/StmtGraphTraits.h
@@ -59,7 +56,6 @@ include/clang/AST/TemplateBase.h
include/clang/AST/TemplateName.h
include/clang/AST/Type.h
include/clang/AST/TypeLoc.h
-include/clang/AST/TypeLocBuilder.h
include/clang/AST/TypeLocNodes.def
include/clang/AST/TypeLocVisitor.h
include/clang/AST/TypeNodes.def
@@ -67,15 +63,18 @@ include/clang/AST/TypeOrdering.h
include/clang/AST/TypeVisitor.h
include/clang/AST/UnresolvedSet.h
include/clang/AST/UsuallyTinyPtrVector.h
+include/clang/Analysis/Analyses/CFGReachabilityAnalysis.h
include/clang/Analysis/Analyses/FormatString.h
include/clang/Analysis/Analyses/LiveVariables.h
include/clang/Analysis/Analyses/PseudoConstantAnalysis.h
include/clang/Analysis/Analyses/ReachableCode.h
include/clang/Analysis/Analyses/UninitializedValues.h
+include/clang/Analysis/Analyses/UninitializedValuesV2.h
include/clang/Analysis/AnalysisContext.h
include/clang/Analysis/AnalysisDiagnostic.h
include/clang/Analysis/CFG.h
include/clang/Analysis/CFGStmtMap.h
+include/clang/Analysis/DomainSpecific/CocoaConventions.h
include/clang/Analysis/FlowSensitive/DataflowSolver.h
include/clang/Analysis/FlowSensitive/DataflowValues.h
include/clang/Analysis/ProgramPoint.h
@@ -85,6 +84,7 @@ include/clang/Analysis/Support/SaveAndRestore.h
include/clang/Analysis/Visitors/CFGRecStmtDeclVisitor.h
include/clang/Analysis/Visitors/CFGRecStmtVisitor.h
include/clang/Analysis/Visitors/CFGStmtVisitor.h
+include/clang/Basic/ABI.h
include/clang/Basic/AttrKinds.h
include/clang/Basic/AttrList.inc
include/clang/Basic/Builtins.def
@@ -100,31 +100,23 @@ include/clang/Basic/DiagnosticCommonKinds.inc
include/clang/Basic/DiagnosticDriverKinds.inc
include/clang/Basic/DiagnosticFrontendKinds.inc
include/clang/Basic/DiagnosticGroups.inc
+include/clang/Basic/DiagnosticIDs.h
include/clang/Basic/DiagnosticLexKinds.inc
include/clang/Basic/DiagnosticParseKinds.inc
include/clang/Basic/DiagnosticSemaKinds.inc
include/clang/Basic/FileManager.h
+include/clang/Basic/FileSystemOptions.h
+include/clang/Basic/FileSystemStatCache.h
include/clang/Basic/IdentifierTable.h
include/clang/Basic/LangOptions.h
include/clang/Basic/Linkage.h
include/clang/Basic/MacroBuilder.h
include/clang/Basic/OnDiskHashTable.h
+include/clang/Basic/OpenCLExtensions.def
include/clang/Basic/OperatorKinds.def
include/clang/Basic/OperatorKinds.h
include/clang/Basic/PartialDiagnostic.h
include/clang/Basic/PrettyStackTrace.h
-include/clang/Basic/Release/AttrList.inc.tmp
-include/clang/Basic/Release/DiagnosticASTKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticAnalysisKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticCommonKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticDriverKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticFrontendKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticGroups.inc.tmp
-include/clang/Basic/Release/DiagnosticLexKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticParseKinds.inc.tmp
-include/clang/Basic/Release/DiagnosticSemaKinds.inc.tmp
-include/clang/Basic/Release/Version.inc.tmp
-include/clang/Basic/Release/arm_neon.inc.tmp
include/clang/Basic/SourceLocation.h
include/clang/Basic/SourceManager.h
include/clang/Basic/SourceManagerInternals.h
@@ -138,44 +130,8 @@ include/clang/Basic/TokenKinds.h
include/clang/Basic/TypeTraits.h
include/clang/Basic/Version.h
include/clang/Basic/Version.inc
+include/clang/Basic/Visibility.h
include/clang/Basic/arm_neon.inc
-include/clang/Checker/AnalysisConsumer.h
-include/clang/Checker/BugReporter/BugReporter.h
-include/clang/Checker/BugReporter/BugType.h
-include/clang/Checker/BugReporter/PathDiagnostic.h
-include/clang/Checker/Checkers/DereferenceChecker.h
-include/clang/Checker/Checkers/LocalCheckers.h
-include/clang/Checker/DomainSpecific/CocoaConventions.h
-include/clang/Checker/FrontendActions.h
-include/clang/Checker/ManagerRegistry.h
-include/clang/Checker/PathDiagnosticClients.h
-include/clang/Checker/PathSensitive/AnalysisManager.h
-include/clang/Checker/PathSensitive/BasicValueFactory.h
-include/clang/Checker/PathSensitive/Checker.h
-include/clang/Checker/PathSensitive/CheckerHelpers.h
-include/clang/Checker/PathSensitive/CheckerVisitor.def
-include/clang/Checker/PathSensitive/CheckerVisitor.h
-include/clang/Checker/PathSensitive/ConstraintManager.h
-include/clang/Checker/PathSensitive/Environment.h
-include/clang/Checker/PathSensitive/ExplodedGraph.h
-include/clang/Checker/PathSensitive/GRAuditor.h
-include/clang/Checker/PathSensitive/GRBlockCounter.h
-include/clang/Checker/PathSensitive/GRCoreEngine.h
-include/clang/Checker/PathSensitive/GRExprEngine.h
-include/clang/Checker/PathSensitive/GRExprEngineBuilders.h
-include/clang/Checker/PathSensitive/GRSimpleAPICheck.h
-include/clang/Checker/PathSensitive/GRState.h
-include/clang/Checker/PathSensitive/GRStateTrait.h
-include/clang/Checker/PathSensitive/GRSubEngine.h
-include/clang/Checker/PathSensitive/GRTransferFuncs.h
-include/clang/Checker/PathSensitive/GRWorkList.h
-include/clang/Checker/PathSensitive/MemRegion.h
-include/clang/Checker/PathSensitive/SVals.h
-include/clang/Checker/PathSensitive/SValuator.h
-include/clang/Checker/PathSensitive/Store.h
-include/clang/Checker/PathSensitive/SummaryManager.h
-include/clang/Checker/PathSensitive/SymbolManager.h
-include/clang/Checker/PathSensitive/ValueManager.h
include/clang/CodeGen/BackendUtil.h
include/clang/CodeGen/CodeGenAction.h
include/clang/CodeGen/ModuleBuilder.h
@@ -197,9 +153,6 @@ include/clang/Driver/Option.h
include/clang/Driver/Options.h
include/clang/Driver/Options.inc
include/clang/Driver/Phases.h
-include/clang/Driver/Release/CC1AsOptions.inc.tmp
-include/clang/Driver/Release/CC1Options.inc.tmp
-include/clang/Driver/Release/Options.inc.tmp
include/clang/Driver/Tool.h
include/clang/Driver/ToolChain.h
include/clang/Driver/Types.def
@@ -214,12 +167,8 @@ include/clang/Frontend/CodeGenOptions.h
include/clang/Frontend/CommandLineSourceLoc.h
include/clang/Frontend/CompilerInstance.h
include/clang/Frontend/CompilerInvocation.h
-include/clang/Frontend/DeclContextXML.def
-include/clang/Frontend/DeclXML.def
include/clang/Frontend/DependencyOutputOptions.h
include/clang/Frontend/DiagnosticOptions.h
-include/clang/Frontend/DocumentXML.def
-include/clang/Frontend/DocumentXML.h
include/clang/Frontend/FrontendAction.h
include/clang/Frontend/FrontendActions.h
include/clang/Frontend/FrontendDiagnostic.h
@@ -228,12 +177,11 @@ include/clang/Frontend/FrontendPluginRegistry.h
include/clang/Frontend/HeaderSearchOptions.h
include/clang/Frontend/LangStandard.h
include/clang/Frontend/LangStandards.def
+include/clang/Frontend/MultiplexConsumer.h
include/clang/Frontend/PreprocessorOptions.h
include/clang/Frontend/PreprocessorOutputOptions.h
-include/clang/Frontend/StmtXML.def
include/clang/Frontend/TextDiagnosticBuffer.h
include/clang/Frontend/TextDiagnosticPrinter.h
-include/clang/Frontend/TypeXML.def
include/clang/Frontend/Utils.h
include/clang/Frontend/VerifyDiagnosticsClient.h
include/clang/FrontendTool/Utils.h
@@ -250,6 +198,7 @@ include/clang/Index/Program.h
include/clang/Index/STLExtras.h
include/clang/Index/SelectorMap.h
include/clang/Index/TranslationUnit.h
+include/clang/Lex/AttrSpellings.inc
include/clang/Lex/CodeCompletionHandler.h
include/clang/Lex/DirectoryLookup.h
include/clang/Lex/ExternalPreprocessorSource.h
@@ -310,28 +259,60 @@ include/clang/Sema/TemplateDeduction.h
include/clang/Serialization/ASTBitCodes.h
include/clang/Serialization/ASTDeserializationListener.h
include/clang/Serialization/ASTReader.h
+include/clang/Serialization/ASTSerializationListener.h
include/clang/Serialization/ASTWriter.h
include/clang/Serialization/AttrPCHRead.inc
include/clang/Serialization/AttrPCHWrite.inc
-include/clang/Serialization/Release/AttrPCHRead.inc.tmp
-include/clang/Serialization/Release/AttrPCHWrite.inc.tmp
-lib/clang/2.8/include/arm_neon.h
-lib/clang/2.8/include/emmintrin.h
-lib/clang/2.8/include/immintrin.h
-lib/clang/2.8/include/mm_malloc.h
-lib/clang/2.8/include/mmintrin.h
-lib/clang/2.8/include/nmmintrin.h
-lib/clang/2.8/include/pmmintrin.h
-lib/clang/2.8/include/smmintrin.h
-lib/clang/2.8/include/tmmintrin.h
-lib/clang/2.8/include/wmmintrin.h
-lib/clang/2.8/include/xmmintrin.h
+include/clang/StaticAnalyzer/Checkers/DereferenceChecker.h
+include/clang/StaticAnalyzer/Checkers/LocalCheckers.h
+include/clang/StaticAnalyzer/Core/BugReporter/BugReporter.h
+include/clang/StaticAnalyzer/Core/BugReporter/BugType.h
+include/clang/StaticAnalyzer/Core/BugReporter/PathDiagnostic.h
+include/clang/StaticAnalyzer/Core/Checker.h
+include/clang/StaticAnalyzer/Core/CheckerManager.h
+include/clang/StaticAnalyzer/Core/CheckerProvider.h
+include/clang/StaticAnalyzer/Core/PathDiagnosticClients.h
+include/clang/StaticAnalyzer/Core/PathSensitive/AnalysisManager.h
+include/clang/StaticAnalyzer/Core/PathSensitive/BasicValueFactory.h
+include/clang/StaticAnalyzer/Core/PathSensitive/BlockCounter.h
+include/clang/StaticAnalyzer/Core/PathSensitive/CheckerContext.h
+include/clang/StaticAnalyzer/Core/PathSensitive/CheckerHelpers.h
+include/clang/StaticAnalyzer/Core/PathSensitive/ConstraintManager.h
+include/clang/StaticAnalyzer/Core/PathSensitive/CoreEngine.h
+include/clang/StaticAnalyzer/Core/PathSensitive/Environment.h
+include/clang/StaticAnalyzer/Core/PathSensitive/ExplodedGraph.h
+include/clang/StaticAnalyzer/Core/PathSensitive/ExprEngine.h
+include/clang/StaticAnalyzer/Core/PathSensitive/ExprEngineBuilders.h
+include/clang/StaticAnalyzer/Core/PathSensitive/GRState.h
+include/clang/StaticAnalyzer/Core/PathSensitive/GRStateTrait.h
+include/clang/StaticAnalyzer/Core/PathSensitive/MemRegion.h
+include/clang/StaticAnalyzer/Core/PathSensitive/ObjCMessage.h
+include/clang/StaticAnalyzer/Core/PathSensitive/SValBuilder.h
+include/clang/StaticAnalyzer/Core/PathSensitive/SVals.h
+include/clang/StaticAnalyzer/Core/PathSensitive/Store.h
+include/clang/StaticAnalyzer/Core/PathSensitive/SubEngine.h
+include/clang/StaticAnalyzer/Core/PathSensitive/SummaryManager.h
+include/clang/StaticAnalyzer/Core/PathSensitive/SymbolManager.h
+include/clang/StaticAnalyzer/Core/PathSensitive/TransferFuncs.h
+include/clang/StaticAnalyzer/Core/PathSensitive/WorkList.h
+include/clang/StaticAnalyzer/Frontend/CheckerRegistration.h
+include/clang/StaticAnalyzer/Frontend/FrontendActions.h
+lib/clang/2.9/include/arm_neon.h
+lib/clang/2.9/include/emmintrin.h
+lib/clang/2.9/include/immintrin.h
+lib/clang/2.9/include/mm_malloc.h
+lib/clang/2.9/include/mmintrin.h
+lib/clang/2.9/include/nmmintrin.h
+lib/clang/2.9/include/pmmintrin.h
+lib/clang/2.9/include/smmintrin.h
+lib/clang/2.9/include/tmmintrin.h
+lib/clang/2.9/include/wmmintrin.h
+lib/clang/2.9/include/xmmintrin.h
lib/libclang.a
lib/libclang.so
lib/libclangAST.a
lib/libclangAnalysis.a
lib/libclangBasic.a
-lib/libclangChecker.a
lib/libclangCodeGen.a
lib/libclangDriver.a
lib/libclangFrontend.a
@@ -342,6 +323,9 @@ lib/libclangParse.a
lib/libclangRewrite.a
lib/libclangSema.a
lib/libclangSerialization.a
+lib/libclangStaticAnalyzerCheckers.a
+lib/libclangStaticAnalyzerCore.a
+lib/libclangStaticAnalyzerFrontend.a
%%DATADIR%%/scanview.css
%%DATADIR%%/sorttable.js
%%PORTDOCS%%%%DOCSDIR%%/html.tar.gz
@@ -364,10 +348,15 @@ lib/libclangSerialization.a
%%PYTHON_SITELIBDIR%%/Resources/bugcatcher.ico
%%PYTHON_SITELIBDIR%%/ScanView.py
%%PYTHON_SITELIBDIR%%/startfile.py
-@dirrm lib/clang/2.8/include
-@dirrm lib/clang/2.8
+@dirrm lib/clang/2.9/include
+@dirrm lib/clang/2.9
@dirrm lib/clang
-@dirrm include/clang/Serialization/Release
+@dirrm include/clang/StaticAnalyzer/Frontend
+@dirrm include/clang/StaticAnalyzer/Core/PathSensitive
+@dirrm include/clang/StaticAnalyzer/Core/BugReporter
+@dirrm include/clang/StaticAnalyzer/Core
+@dirrm include/clang/StaticAnalyzer/Checkers
+@dirrm include/clang/StaticAnalyzer
@dirrm include/clang/Serialization
@dirrm include/clang/Sema
@dirrm include/clang/Rewrite
@@ -376,22 +365,15 @@ lib/libclangSerialization.a
@dirrm include/clang/Index
@dirrm include/clang/FrontendTool
@dirrm include/clang/Frontend
-@dirrm include/clang/Driver/Release
@dirrm include/clang/Driver
@dirrm include/clang/CodeGen
-@dirrm include/clang/Checker/PathSensitive
-@dirrm include/clang/Checker/DomainSpecific
-@dirrm include/clang/Checker/Checkers
-@dirrm include/clang/Checker/BugReporter
-@dirrm include/clang/Checker
-@dirrm include/clang/Basic/Release
@dirrm include/clang/Basic
@dirrm include/clang/Analysis/Visitors
@dirrm include/clang/Analysis/Support
@dirrm include/clang/Analysis/FlowSensitive
+@dirrm include/clang/Analysis/DomainSpecific
@dirrm include/clang/Analysis/Analyses
@dirrm include/clang/Analysis
-@dirrm include/clang/AST/Release
@dirrm include/clang/AST
@dirrm include/clang-c
@dirrm include/clang
diff --git a/lang/llvm-gcc4/Makefile b/lang/llvm-gcc4/Makefile
index bf0ff00e3f09..8affd42d48e9 100644
--- a/lang/llvm-gcc4/Makefile
+++ b/lang/llvm-gcc4/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gcc4
-PORTVERSION= 2.8
+PORTVERSION= 2.9
CATEGORIES= lang devel
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
PKGNAMEPREFIX= llvm-
diff --git a/lang/llvm-gcc4/distinfo b/lang/llvm-gcc4/distinfo
index 5e4c0ca0c1f5..9312812cf3a8 100644
--- a/lang/llvm-gcc4/distinfo
+++ b/lang/llvm-gcc4/distinfo
@@ -1,3 +1,2 @@
-MD5 (llvm-gcc-4.2-2.8.source.tgz) = e5b0569f5f018086c62201d87e161154
-SHA256 (llvm-gcc-4.2-2.8.source.tgz) = 04785a0031c1aa1e3a89926ac6a069c96276074ea711958306b8bf96d9d49e4d
-SIZE (llvm-gcc-4.2-2.8.source.tgz) = 55748118
+SHA256 (llvm-gcc-4.2-2.9.source.tgz) = 2ad04e0bbedb9781aa068e216d455b92ba5e577db6ae24aef9ac449cb2eb7f54
+SIZE (llvm-gcc-4.2-2.9.source.tgz) = 53637392
diff --git a/lang/llvm-gcc4/files/patch-.._gcc_common.opt b/lang/llvm-gcc4/files/patch-.._gcc_common.opt
new file mode 100644
index 000000000000..22cdc80ddb4f
--- /dev/null
+++ b/lang/llvm-gcc4/files/patch-.._gcc_common.opt
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- ../gcc/common.opt.orig
++++ ../gcc/common.opt
+@@ -730,8 +730,8 @@
+
+ ; APPLE LOCAL begin optimization pragmas 3124235/3420242
+ fmath-errno
+-Common Report Var(flag_errno_math) Init(1) PerFunc
+-Set errno after built-in math functions
++Common Report Var(flag_errno_math) Init(0) PerFunc
++FreeBSD does not set errno after built-in math functions
+ ; APPLE LOCAL end optimization pragmas 3124235/3420242
+
+ fmem-report
diff --git a/lang/llvm-gcc4/files/patch-.._gcc_config.gcc b/lang/llvm-gcc4/files/patch-.._gcc_config.gcc
new file mode 100644
index 000000000000..092883adc7a2
--- /dev/null
+++ b/lang/llvm-gcc4/files/patch-.._gcc_config.gcc
@@ -0,0 +1,31 @@
+--- ../gcc/config.gcc.orig 2011-02-23 22:07:15.000000000 +0000
++++ ../gcc/config.gcc 2011-02-24 10:11:03.000000000 +0000
+@@ -1131,9 +1131,11 @@
+ ;;
+ i[34567]86-*-freebsd*)
+ tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h ${fbsd_tm_file} i386/freebsd.h"
++ tmake_file="$(tmake_file) i386/t-crtstuff"
+ ;;
+ x86_64-*-freebsd*)
+ tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h ${fbsd_tm_file} i386/x86-64.h i386/freebsd.h i386/freebsd64.h"
++ tmake_file="$(tmake_file) i386/t-crtstuff"
+ ;;
+ i[34567]86-*-netbsdelf*)
+ tm_file="${tm_file} i386/unix.h i386/att.h dbxelf.h elfos.h netbsd.h netbsd-elf.h i386/netbsd-elf.h"
+@@ -2629,6 +2631,16 @@
+ # A Cirrus ARM variant.
+ with_cpu="ep9312"
+ ;;
++ i386-*-freebsd*)
++ if test $fbsd_major -ge 6; then
++ arch=i486
++ else
++ arch=i386
++ fi
++ cpu=generic
++ arch_without_sse2=yes
++ arch_without_64bit=yes
++ ;;
+ # APPLE LOCAL begin mainline 2006-04-19 4434601
+ i386-*-*)
+ with_cpu=i386
diff --git a/lang/llvm-gcc4/files/patch-.._gcc_config_i386_i386.c b/lang/llvm-gcc4/files/patch-.._gcc_config_i386_i386.c
new file mode 100644
index 000000000000..28c5e57b8d69
--- /dev/null
+++ b/lang/llvm-gcc4/files/patch-.._gcc_config_i386_i386.c
@@ -0,0 +1,11 @@
+--- ../gcc/config/i386/i386.c.orig 2011-02-20 21:45:59.000000000 +0000
++++ ../gcc/config/i386/i386.c 2011-02-20 21:47:35.000000000 +0000
+@@ -1762,7 +1762,7 @@
+ "-mtune=generic instead as appropriate.");
+
+ if (!ix86_arch_string)
+- ix86_arch_string = TARGET_64BIT ? "x86-64" : "i386";
++ ix86_arch_string = TARGET_64BIT ? "x86-64" : "i486";
+ /* APPLE LOCAL begin mainline */
+ else
+ ix86_arch_specified = 1;
diff --git a/lang/llvm-gcc4/files/patch-.._gcc_gthr-posix.h b/lang/llvm-gcc4/files/patch-.._gcc_gthr-posix.h
new file mode 100644
index 000000000000..6f8f3dd0a15a
--- /dev/null
+++ b/lang/llvm-gcc4/files/patch-.._gcc_gthr-posix.h
@@ -0,0 +1,35 @@
+--- ../gcc/gthr-posix.h 2007/08/14 02:45:23 171825
++++ ../gcc/gthr-posix.h 2008/04/21 20:40:42 178388
+@@ -152,9 +152,12 @@
+ it is passed so we cannot pretend that the interface is active if -pthreads
+ is not specified. On Solaris 2.5.1, the interface is not exposed at all so
+ we need to play the usual game with weak symbols. On Solaris 10 and up, a
+- working interface is always exposed. */
++ working interface is always exposed. On FreeBSD 6 and later, libc also
++ exposes a dummy POSIX threads interface, similar to what Solaris 2.6 up
++ to 9 does. FreeBSD >= 700014 even provides a pthread_cancel stub in libc,
++ which means the alternate __gthread_active_p below cannot be used there. */
+
+-#if defined(__sun) && defined(__svr4__)
++#if defined(__FreeBSD__) || (defined(__sun) && defined(__svr4__))
+
+ static volatile int __gthread_active = -1;
+
+@@ -197,7 +200,7 @@
+ return __gthread_active_latest_value != 0;
+ }
+
+-#else /* not Solaris */
++#else /* neither FreeBSD nor Solaris */
+
+ static inline int
+ __gthread_active_p (void)
+@@ -207,7 +210,7 @@
+ return __gthread_active_ptr != 0;
+ }
+
+-#endif /* Solaris */
++#endif /* FreeBSD or Solaris */
+
+ #else /* not SUPPORTS_WEAK */
+