aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-08-08 20:33:55 +0800
committergahr <gahr@FreeBSD.org>2013-08-08 20:33:55 +0800
commit7828f7125b7af5d0e938cd8f3b69b89c321e2910 (patch)
treebe00b7daee78f6e1b5aa8b04ae8088e0b10fc624 /lang
parentb9b3d6d1e9b3f46ab01671347c2c8653f583ba26 (diff)
downloadfreebsd-ports-gnome-7828f7125b7af5d0e938cd8f3b69b89c321e2910.tar.gz
freebsd-ports-gnome-7828f7125b7af5d0e938cd8f3b69b89c321e2910.tar.zst
freebsd-ports-gnome-7828f7125b7af5d0e938cd8f3b69b89c321e2910.zip
- Update to 05_20130805a
20130805: * The functions hashCode in complex.s7i, duration.s7i, rational.s7i and time.s7i have been improved to avoid an integer overflow. Thanks to Pietro Cerutti, for reporting this problem. * The description of the Seed7 installation in doc/install.txt has been improved. * The new library sha1.s7i, which defines a message digest with the SHA-1 secure hash algorithm, has been added. * Definitions of the operators &:= and |:= have been added to bin32.s7i. * The functions int64AsBytesBytesLe, int64AsEightBytesBe and bytesBeAsInt have been added to bytedata.s7i. * Interpreter and compiler have been improved to support the actions INT_AND_ASSIGN and INT_OR_ASSIGN. * A bug in the function conText (file con_win.c) has been fixed. * Debug code has been added to kbd_inf.c and kbd_poll.c. * The makefile mk_cygw.mak has been improved to avoid problems with the console keyboard. 20130722: * Spelling errors in chlog.txt, faq.htm and faq.txt have been fixed. * The function conText (in con_win.c) has been improved to work correctly for long strings. The underlying function WriteConsoleW fails for string lengths above some limit between 26000 to 32000. * The functions find_window, remove_window, gkbGetc, gkbKeyPressed, gkbButtonPressed, gkbRawGetc, gkbWindow, gkbButtonXpos and gkbButtonYpos have been moved from drw_win.c to the new file gkb_win.c. * In the functions drwPCircle, drwPFCircle, drwPFEllipse and drwFPolyLine (file drw_win.c) wrong usages of inIntRange have been replaced with better code. * In con_win.c the table map_key has been improved such that kbdGetc recognizes the key F12. * In gkb_x11.c the functions find_window, enter_window and remove_window have been improved. * The makefiles mk_bcc32.mak, mk_bccv5.mak, mk_mingc.mak, mk_mingw.mak, mk_msvc.mak, mk_msys.mak and mk_nmake.mak have been changed to use the new file gkb_win.c. * The program chk_all.sd7 has been improved to call chkhsh.sd7. * The program chkhsh.sd7 has been improved. * The compiler has been improved to generate compare functions with the correct prototype. * The functions bitSize and process_generic_cmp_declaration have been added to s7c.sd7. * In flt_rtl.c the function fltCpy has been renamed to fltCpyGeneric. * The functions dump_hash and dump_helem have been added to hsh_rtl.c. * The function new_type in typeutl.c has been changed to add the new type to the parameter owningProg instead of the global prog.
Diffstat (limited to 'lang')
-rw-r--r--lang/seed7/Makefile7
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/files/patch-makefile13
-rw-r--r--lang/seed7/files/patch-mk_clang.mak6
-rw-r--r--lang/seed7/pkg-plist1
5 files changed, 18 insertions, 13 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index bf4baefc1efd..239b370ed8e9 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20130704
+DISTVERSION= 05_20130805
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -25,7 +25,6 @@ MAKE_ENV+= S7_LIB_DIR=${S7_LIB_DIR} \
SEED7_LIBRARY=${SEED7_LIBRARY} \
C_COMPILER=${CC} \
CPLUSPLUS_COMPILER=${CPP}
-ALL_TARGET= depend s7 s7c
SEED7_LIBRARY= ${PREFIX}/lib/${PORTNAME}/lib
S7_LIB_DIR= ${PREFIX}/lib/${PORTNAME}/bin
@@ -46,6 +45,10 @@ post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;' ${WRKSRC}/makefile ${WRKSRC}/mk_clang.mak
${REINPLACE_CMD} -e '/FLOATTYPE_DOUBLE/s|undef|define|' ${WRKSRC}/config.h
+do-build:
+ cd ${WRKSRC} && ${GMAKE} -f ${MAKEFILE} depend
+ cd ${WRKSRC} && ${GMAKE} -f ${MAKEFILE} s7 s7c
+
do-install:
# install interpreter and compiler
${INSTALL_PROGRAM} ${WRKSRC}/../bin/s7 ${PREFIX}/bin
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index f6bd891f15bd..7bbf4a576592 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20130704.tgz) = 5bb6007df5301711e8f44ae0314a18592bd2723b194baeb53e27a7864be0859e
-SIZE (seed7_05_20130704.tgz) = 1921412
+SHA256 (seed7_05_20130805.tgz) = 723bef358b15064dad8a43f3c4c0f6c67710fcf3f7c03d172f08a07a3041d149
+SIZE (seed7_05_20130805.tgz) = 1926873
diff --git a/lang/seed7/files/patch-makefile b/lang/seed7/files/patch-makefile
index 76026d4d3f84..5d5890abe1bf 100644
--- a/lang/seed7/files/patch-makefile
+++ b/lang/seed7/files/patch-makefile
@@ -1,15 +1,16 @@
---- makefile.orig 2012-11-27 13:49:47.000000000 +0100
-+++ makefile 2012-11-27 13:50:36.000000000 +0100
+--- makefile.orig 2013-06-16 12:54:40.000000000 +0200
++++ makefile 2013-07-30 10:01:44.000000000 +0200
@@ -12,7 +12,7 @@
# CFLAGS = -O2 -fomit-frame-pointer -Wall -Wextra -Wswitch-default -Wcast-qual -Waggregate-return -Wwrite-strings -Winline -Wconversion -Wshadow -Wpointer-arith -Wmissing-noreturn -Wno-multichar
# CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -ftrapv
# CFLAGS = -O2 -g -x c++ -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
-CFLAGS = -O2 -g -ffunction-sections -fdata-sections -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
-+CFLAGS += -ffunction-sections -fdata-sections -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -I%%LOCALBASE%%/include
++CFLAGS = -ffunction-sections -fdata-sections -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -I%%LOCALBASE%%/include
# CFLAGS = -O2 -g -ffunction-sections -fdata-sections -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
- # CFLAGS = -O2 -g -std=c99 -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
+ # CFLAGS = -O2 -g -std=c99 -D_POSIX_SOURCE -ffunction-sections -fdata-sections -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -g -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
-@@ -21,6 +21,6 @@
+@@ -20,7 +20,7 @@
+ # CFLAGS = -O2 -g -pg -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -fomit-frame-pointer -funroll-loops -Wall
# CFLAGS = -O2 -funroll-loops -Wall -pg
-LDFLAGS = -Wl,--gc-sections
@@ -17,7 +18,7 @@
# LDFLAGS = -pg
# LDFLAGS = -pg -lc_p
SYSTEM_LIBS = -lm
-@@ -39,7 +40,7 @@
+@@ -40,7 +40,7 @@
COMPILER_LIB = s7_comp.a
ALL_S7_LIBS = ../bin/$(COMPILER_LIB) ../bin/$(COMP_DATA_LIB) ../bin/$(DRAW_LIB) ../bin/$(CONSOLE_LIB) ../bin/$(SEED7_LIB)
# CC = g++
diff --git a/lang/seed7/files/patch-mk_clang.mak b/lang/seed7/files/patch-mk_clang.mak
index f5ac65ff5aee..05a3b3aeb1ee 100644
--- a/lang/seed7/files/patch-mk_clang.mak
+++ b/lang/seed7/files/patch-mk_clang.mak
@@ -1,11 +1,11 @@
---- mk_clang.mak.orig 2013-01-21 11:50:32.000000000 +0100
-+++ mk_clang.mak 2013-01-21 11:52:56.000000000 +0100
+--- mk_clang.mak.orig 2013-07-29 10:57:30.000000000 +0200
++++ mk_clang.mak 2013-07-29 10:58:03.000000000 +0200
@@ -10,7 +10,7 @@
# CFLAGS = -O2 -g -Wall -Wextra -Wswitch-default -Wswitch-enum -Wcast-qual -Waggregate-return -Wwrite-strings -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -Wmissing-noreturn -Wno-multichar -Wc++-compat
# CFLAGS = -O2 -g -x c++ -Wall -Wextra -Wswitch-default -Wswitch-enum -Wcast-qual -Waggregate-return -Wwrite-strings -Winline -Wconversion -Wshadow -Wpointer-arith -Wmissing-noreturn -Wno-multichar
# CFLAGS = -O2 -fomit-frame-pointer -Wall -Wextra -Wswitch-default -Wcast-qual -Waggregate-return -Wwrite-strings -Winline -Wconversion -Wshadow -Wpointer-arith -Wmissing-noreturn -Wno-multichar
-CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -ftrapv
-+CFLAGS += -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -ftrapv -I%%LOCALBASE%%/include
++CFLAGS = -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -ftrapv -I%%LOCALBASE%%/include
# CFLAGS = -O2 -g -x c++ -Wall -Winline -Wconversion -Wshadow -Wpointer-arith -ftrapv
# CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -g -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
index adbac3ded30b..4c24030bab1b 100644
--- a/lang/seed7/pkg-plist
+++ b/lang/seed7/pkg-plist
@@ -91,6 +91,7 @@ lib/seed7/lib/scanfile.s7i
lib/seed7/lib/scanstri.s7i
lib/seed7/lib/seed7_05.s7i
lib/seed7/lib/set.s7i
+lib/seed7/lib/sha1.s7i
lib/seed7/lib/shell.s7i
lib/seed7/lib/sockbase.s7i
lib/seed7/lib/socket.s7i