aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-05-07 22:47:28 +0800
committerale <ale@FreeBSD.org>2006-05-07 22:47:28 +0800
commit79ced2badac6329ff52ca3826b69d9685ed30247 (patch)
treebc0807cdcf998b6371e48169fec58b2a59ab3731 /lang
parentc59e479ab495cfaa4da694421a611fc2da6d2171 (diff)
downloadfreebsd-ports-gnome-79ced2badac6329ff52ca3826b69d9685ed30247.tar.gz
freebsd-ports-gnome-79ced2badac6329ff52ca3826b69d9685ed30247.tar.zst
freebsd-ports-gnome-79ced2badac6329ff52ca3826b69d9685ed30247.zip
Add WITH_ZEND_VM knob to customize vm behaviour:
- CALL is the default one - SWITCH should be slightly faster - GOTO should boost performance (and increase compilation time) Suggested by: Michael Josic <systemoperator@gmail.com>
Diffstat (limited to 'lang')
-rw-r--r--lang/php5/Makefile8
-rw-r--r--lang/php53/Makefile8
2 files changed, 16 insertions, 0 deletions
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 47a564c6e1c8..36a0f5256094 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -115,6 +115,14 @@ CONFIGURE_ARGS+=--with-regex=system
CONFIGURE_ARGS+=--with-regex=apache
.endif
+.if !defined(WITH_ZEND_VM) || ${WITH_ZEND_VM} == "CALL"
+CONFIGURE_ARGS+=--with-zend-vm=CALL
+.elif defined(WITH_ZEND_VM) && ${WITH_ZEND_VM} == "SWITCH"
+CONFIGURE_ARGS+=--with-zend-vm=SWITCH
+.elif defined(WITH_ZEND_VM) && ${WITH_ZEND_VM} == "GOTO"
+CONFIGURE_ARGS+=--with-zend-vm=GOTO
+.endif
+
CONFIGURE_ENV+= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
ac_cv_pthreads_cflags=${PTHREAD_CFLAGS} \
pthreads_working="yes"
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 47a564c6e1c8..36a0f5256094 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -115,6 +115,14 @@ CONFIGURE_ARGS+=--with-regex=system
CONFIGURE_ARGS+=--with-regex=apache
.endif
+.if !defined(WITH_ZEND_VM) || ${WITH_ZEND_VM} == "CALL"
+CONFIGURE_ARGS+=--with-zend-vm=CALL
+.elif defined(WITH_ZEND_VM) && ${WITH_ZEND_VM} == "SWITCH"
+CONFIGURE_ARGS+=--with-zend-vm=SWITCH
+.elif defined(WITH_ZEND_VM) && ${WITH_ZEND_VM} == "GOTO"
+CONFIGURE_ARGS+=--with-zend-vm=GOTO
+.endif
+
CONFIGURE_ENV+= ac_cv_pthreads_lib=${PTHREAD_LIBS} \
ac_cv_pthreads_cflags=${PTHREAD_CFLAGS} \
pthreads_working="yes"