aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2016-12-26 05:03:54 +0800
committergerald <gerald@FreeBSD.org>2016-12-26 05:03:54 +0800
commit7dfe051482416711c3fcbda5eb7b597f848cece2 (patch)
tree4505aa35b8ef4a2d6669a8a9cfaa9a6a6b6ea0a1 /lang
parentc6f989858ecdf719c8fced710dcf1a6beb5fb0ee (diff)
downloadfreebsd-ports-gnome-7dfe051482416711c3fcbda5eb7b597f848cece2.tar.gz
freebsd-ports-gnome-7dfe051482416711c3fcbda5eb7b597f848cece2.tar.zst
freebsd-ports-gnome-7dfe051482416711c3fcbda5eb7b597f848cece2.zip
Update to the GCC 6.3 release which brings a number of bugfixes.
Omit the definition of DISTVERSION which is only necessary for ports tracking snapshots of GCC and simplify the definition of GCC_VERSION (but keep the latter as a variable to align the gcc6-devel and gcc6 ports). Remove files/patch-unwind-ia64.h since we have not been supporting ia64 with this release series (ONLY_FOR_ARCHS has not been including ia64).
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc6/Makefile9
-rw-r--r--lang/gcc6/distinfo6
-rw-r--r--lang/gcc6/files/patch-unwind-ia64.h21
3 files changed, 5 insertions, 31 deletions
diff --git a/lang/gcc6/Makefile b/lang/gcc6/Makefile
index 8b11dc816c92..5953f776a450 100644
--- a/lang/gcc6/Makefile
+++ b/lang/gcc6/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 6.2.0
+PORTVERSION= 6.3.0
CATEGORIES= lang java
MASTER_SITES= GCC/releases/gcc-${DISTVERSION}
PKGNAMESUFFIX= ${SUFFIX}
@@ -28,12 +28,7 @@ BUILD_DEPENDS+= runtest:misc/dejagnu
CPE_VENDOR= gnu
CPE_VERSION= ${GCC_VERSION}
-# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
-# of executables and directories once installed. A PORTVERSION of
-# Y.2.1.s20140817 results in values of Y-20140817, Y.2.1, and Y
-# for these three.
-DISTVERSION= ${PORTVERSION:C/([0-9]+).*\.s([0-9]+)/\1-\2/}
-GCC_VERSION= ${PORTVERSION:C/(.+)\.s[0-9]{8}/\1/}
+GCC_VERSION= ${PORTVERSION}
SUFFIX= ${PORTVERSION:C/([0-9]+).*/\1/}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64 arm armv6 armv6hf
USES= compiler cpe gmake iconv libtool makeinfo perl5 tar:bzip2
diff --git a/lang/gcc6/distinfo b/lang/gcc6/distinfo
index cf2beaab873c..921e87c4f1cf 100644
--- a/lang/gcc6/distinfo
+++ b/lang/gcc6/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1471862430
-SHA256 (gcc-6.2.0.tar.bz2) = 9944589fc722d3e66308c0ce5257788ebd7872982a718aa2516123940671b7c5
-SIZE (gcc-6.2.0.tar.bz2) = 99778648
+TIMESTAMP = 1482692157
+SHA256 (gcc-6.3.0.tar.bz2) = f06ae7f3f790fbf0f018f6d40e844451e6bc3b7bc96e128e63b09825c1f8b29f
+SIZE (gcc-6.3.0.tar.bz2) = 99903185
diff --git a/lang/gcc6/files/patch-unwind-ia64.h b/lang/gcc6/files/patch-unwind-ia64.h
deleted file mode 100644
index 82e103a543c5..000000000000
--- a/lang/gcc6/files/patch-unwind-ia64.h
+++ /dev/null
@@ -1,21 +0,0 @@
-2012-12-17 Gerald Pfeifer <gerald@pfeifer.com>
- Anton Shterenlikht <mexas@bristol.ac.uk>
-
- PR target/45650
- * config/ia64/unwind-ia64.h: Do not mark _Unwind_FindTableEntry
- hidden on FreeBSD.
-
---- UTC
-Index: libgcc/config/ia64/unwind-ia64.h
-===================================================================
---- libgcc/config/ia64/unwind-ia64.h
-+++ libgcc/config/ia64/unwind-ia64.h (working copy)
-@@ -49,4 +49,7 @@
- extern struct unw_table_entry *
- _Unwind_FindTableEntry (void *pc, unw_word *segment_base,
- unw_word *gp, struct unw_table_entry *ent)
-- __attribute__ ((__visibility__ ("hidden")));
-+#ifndef __FreeBSD__
-+ __attribute__ ((__visibility__ ("hidden")))
-+#endif
-+ ;