aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-12-17 20:58:58 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-12-17 20:58:58 +0800
commit80a077ab1042129eff5ae6b3c8e50beb84c425aa (patch)
treea37f84b8ba0b4d65a9ba166596e175433e1312df /lang
parent4e6de80740bf9dd8b3a7646ff4e07f7d0bc222b1 (diff)
downloadfreebsd-ports-gnome-80a077ab1042129eff5ae6b3c8e50beb84c425aa.tar.gz
freebsd-ports-gnome-80a077ab1042129eff5ae6b3c8e50beb84c425aa.tar.zst
freebsd-ports-gnome-80a077ab1042129eff5ae6b3c8e50beb84c425aa.zip
- USe DISTVERSIONPREFIX instead of DISTNAME
- Add missing OPTIONS_DEFINE=DOCS - Use USES=makeinfo instead of hard-coded BUILD_DEPENDS - Convert to options helper - Convert to options target helper - While I'm here, fix indent Approved by: portmgr (blanket)
Diffstat (limited to 'lang')
-rw-r--r--lang/twelf/Makefile33
1 files changed, 13 insertions, 20 deletions
diff --git a/lang/twelf/Makefile b/lang/twelf/Makefile
index bb8a309d8e08..d47e0d1523c5 100644
--- a/lang/twelf/Makefile
+++ b/lang/twelf/Makefile
@@ -3,10 +3,10 @@
PORTNAME= twelf
PORTVERSION= 1.7.1
+DISTVERSIONPREFIX= src-
CATEGORIES= lang math
MASTER_SITES= http://twelf.plparty.org/releases/ \
- http://www-2.cs.cmu.edu/~twelf/dist/ http://www.cs.cmu.edu/~twelf/dist/
-DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+ http://www-2.cs.cmu.edu/~twelf/dist/ http://www.cs.cmu.edu/~twelf/dist/
MAINTAINER= beyert@cs.ucr.edu
COMMENT= Meta-logical framework for deductive systems
@@ -18,43 +18,36 @@ RUN_DEPENDS= mlton:lang/mlton
BUILD_DEPENDS= mlton:lang/mlton \
texi2html:textproc/texi2html
-USES= gmake
+OPTIONS_DEFINE= DOCS
+
+USES= gmake
ALL_TARGET= mlton
PLIST_FILES= bin/${PORTNAME}-server
PORTDATA= emacs examples examples-clp examples-delphin tex vim README
PORTDOCS= dvi html info pdf ps
+WRKSRC= ${WRKDIR}/twelf
+INFO= twelf
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-USE_TEX= tex:build dvipsk:build
-BUILD_DEPENDS+= ${LOCALBASE}/bin/makeinfo:print/texinfo
-.endif
+DOCS_USE= TEX=dvipsk:build,tex:build
+DOCS_USES= makeinfo
-post-patch:
-.if ${PORT_OPTIONS:MDOCS}
+post-patch-DOCS-on:
@${REINPLACE_CMD} 's|-number|-number-sections|g' \
${WRKSRC}/doc/guide/Makefile
@${REINPLACE_CMD} 's|twelf_\*.html|twelf/\*.html|g' \
${WRKSRC}/doc/guide/Makefile
-.endif
-post-build:
-.if ${PORT_OPTIONS:MDOCS}
+post-build-DOCS-on:
cd ${WRKSRC}/doc/guide && ${MAKE} all ${INSTALL_TARGET}
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME}-server \
${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA}" ${STAGEDIR}${DATADIR}
-.if ${PORT_OPTIONS:MDOCS}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "${PORTDOCS}" ${STAGEDIR}${DOCSDIR}
-.endif
-
-WRKSRC= ${WRKDIR}/twelf
-INFO= twelf
.include <bsd.port.mk>