aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2015-04-29 07:40:37 +0800
committergerald <gerald@FreeBSD.org>2015-04-29 07:40:37 +0800
commit811433c395bdefedc1760c01eaf09c3fd115e7e7 (patch)
tree3cd26bb69287bf26ffac1af6452174009edbf517 /lang
parente1ecf2da76f416c7615b5aa3ecf56c32ae624653 (diff)
downloadfreebsd-ports-gnome-811433c395bdefedc1760c01eaf09c3fd115e7e7.tar.gz
freebsd-ports-gnome-811433c395bdefedc1760c01eaf09c3fd115e7e7.tar.zst
freebsd-ports-gnome-811433c395bdefedc1760c01eaf09c3fd115e7e7.zip
With lang/gcc5 now tracking GCC 5 releases, this new port -- gcc5-devel
-- is going to track regular development snapshots of GCC 5.
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gcc5-devel/Makefile164
-rw-r--r--lang/gcc5-devel/Makefile.DragonFly9
-rw-r--r--lang/gcc5-devel/distinfo2
-rw-r--r--lang/gcc5-devel/files/java-patch-hier11
-rw-r--r--lang/gcc5-devel/files/patch-arm-unwind-cxx-support105
-rw-r--r--lang/gcc5-devel/files/patch-unwind-ia64.h20
-rw-r--r--lang/gcc5-devel/files/pkg-message.in7
-rw-r--r--lang/gcc5-devel/pkg-descr7
-rw-r--r--lang/gcc5-devel/pkg-plist78
10 files changed, 404 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index e084e12602b2..3f074397d150 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -90,6 +90,7 @@
SUBDIR += gcc49
SUBDIR += gcc5
SUBDIR += gcc5-aux
+ SUBDIR += gcc5-devel
SUBDIR += gcc6-devel
SUBDIR += gcl
SUBDIR += gforth
diff --git a/lang/gcc5-devel/Makefile b/lang/gcc5-devel/Makefile
new file mode 100644
index 000000000000..e399f28c10e7
--- /dev/null
+++ b/lang/gcc5-devel/Makefile
@@ -0,0 +1,164 @@
+# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gcc
+PORTVERSION= 5.0.1.s20150421
+CATEGORIES= lang java
+MASTER_SITES= GCC/snapshots/${DISTVERSION}
+PKGNAMESUFFIX= ${SUFFIX}
+
+MAINTAINER= gerald@FreeBSD.org
+COMMENT= GNU Compiler Collection 5
+
+LICENSE= GPLv3 GPLv3RLE
+LICENSE_COMB= multi
+
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libmpfr.so:${PORTSDIR}/math/mpfr \
+ libmpc.so:${PORTSDIR}/math/mpc
+BUILD_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+RUN_DEPENDS+= ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
+
+.if defined(MAINTAINER_MODE)
+BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
+.endif
+
+CPE_VENDOR= gnu
+CPE_VERSION= ${GCC_VERSION}
+UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
+
+# DISTVERSION relates to downloads, GCC_VERSION and SUFFIX to names
+# of executables and directories once installed. A PORTVERSION of
+# Y.2.1.s20140817 results in values of Y-20140817, Y.2.1, and Y
+# for these three.
+DISTVERSION= ${PORTVERSION:C/([0-9]+).*\.s([0-9]+)/\1-\2/}
+GCC_VERSION= ${PORTVERSION:C/(.+)\.s[0-9]{8}/\1/}
+SUFFIX= ${PORTVERSION:C/([0-9]+).*/\1/}
+ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64 arm armv6 armv6hf
+USES= cpe gmake iconv libtool makeinfo perl5 tar:bzip2
+USE_BINUTILS= yes
+USE_PERL5= build
+SSP_UNSAFE= yes
+
+PATCH_WRKSRC= ${SRCDIR}
+CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
+
+OPTIONS_DEFINE= BOOTSTRAP
+OPTIONS_DEFINE_i386= JAVA
+OPTIONS_DEFINE_amd64= JAVA
+OPTIONS_DEFAULT= BOOTSTRAP
+OPTIONS_DEFAULT_i386= JAVA
+OPTIONS_DEFAULT_amd64= JAVA
+OPTIONS_EXCLUDE_DragonFly= JAVA
+BOOTSTRAP_DESC= Build using a full bootstrap
+
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
+.else
+CONFIGURE_TARGET= ${ARCH}-portbld-${OPSYS:tl}${OSREL}
+.endif
+
+.if ${ARCH} == powerpc64
+CONFIGURE_ENV+= UNAME_m="powerpc64"
+.endif
+
+.if ${ARCH} == "armv6" || ${ARCH} == "armv6hf"
+. if ${COMPILER_TYPE} == clang
+. if empty(PORT_OPTIONS:MBOOTSTRAP)
+MAKE_ARGS+=CXXFLAGS=-fbracket-depth=512
+. else
+MAKE_ARGS+=STAGE1_CXXFLAGS=-fbracket-depth=512
+. endif
+. endif
+.endif
+
+LANGUAGES:= c,c++,objc,fortran
+SRCDIR= ${WRKDIR}/gcc-${DISTVERSION}
+WRKSRC= ${WRKDIR}/build
+TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
+LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
+GNU_CONFIGURE= yes
+.if empty(PORT_OPTIONS:MBOOTSTRAP)
+CONFIGURE_ARGS+=--disable-bootstrap
+.else
+CONFIGURE_ARGS+=--with-build-config=bootstrap-debug
+ALL_TARGET= bootstrap-lean
+.endif
+CONFIGURE_ARGS+=--disable-nls \
+ --enable-gnu-indirect-function \
+ --libdir=${TARGLIB} \
+ --libexecdir=${LIBEXEC} \
+ --program-suffix=${SUFFIX} \
+ --with-as=${LOCALBASE}/bin/as \
+ --with-gmp=${LOCALBASE} \
+ --with-gxx-include-dir=${TARGLIB}/include/c++/ \
+ --with-ld=${LOCALBASE}/bin/ld \
+ ${ICONV_CONFIGURE_ARG} \
+ --with-pkgversion="FreeBSD Ports Collection" \
+ --with-system-zlib
+MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
+USE_LDCONFIG= ${TARGLIB}
+PLIST_SUB= GCC_VERSION=${GCC_VERSION} \
+ GNU_HOST=${CONFIGURE_TARGET} \
+ SUFFIX=${SUFFIX}
+INFO= gcc${SUFFIX}/cpp \
+ gcc${SUFFIX}/cppinternals \
+ gcc${SUFFIX}/gcc \
+ gcc${SUFFIX}/gccinstall \
+ gcc${SUFFIX}/gccint \
+ gcc${SUFFIX}/gfortran \
+ gcc${SUFFIX}/libgomp
+.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+INFO+= gcc${SUFFIX}/libquadmath \
+ gcc${SUFFIX}/libitm
+.endif
+SUB_FILES= pkg-message
+SUB_LIST+= TARGLIB=${TARGLIB}
+
+.if ${PORT_OPTIONS:MJAVA}
+ECJ_JAR= ${LOCALBASE}/share/java/ecj-4.5.jar
+BUILD_DEPENDS+= ${ECJ_JAR}:${PORTSDIR}/lang/gcc-ecj45 \
+ zip:${PORTSDIR}/archivers/zip
+RUN_DEPENDS+= ${ECJ_JAR}:${PORTSDIR}/lang/gcc-ecj45
+EXTRA_PATCHES+= ${FILESDIR}/java-patch-hier
+CONFIGURE_ARGS+=--with-ecj-jar=${ECJ_JAR}
+LANGUAGES:= ${LANGUAGES},java
+INFO+= gcc${SUFFIX}/cp-tools \
+ gcc${SUFFIX}/gcj
+PLIST_SUB+= JAVA=""
+.else
+CONFIGURE_ARGS+=--disable-libgcj
+PLIST_SUB+= JAVA="@comment "
+.endif
+CONFIGURE_ARGS+=--enable-languages=${LANGUAGES}
+
+pre-everything::
+ @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${CONFIGURE_TARGET} [${LANGUAGES}]"
+
+pre-configure:
+ cd ${SRCDIR} ; contrib/gcc_update --touch
+ @${RM} -f ${SRCDIR}/gcc/*/*.info*
+ @${MKDIR} ${CONFIGURE_WRKSRC}
+
+.if defined(MAINTAINER_MODE)
+full-regression-test: build
+ cd ${WRKSRC}; ${MAKE_CMD} -sk check \
+ ; ${SRCDIR}/contrib/test_summary
+.endif
+
+post-stage:
+ ${RM} -f ${STAGEDIR}${PREFIX}/man/man7/*
+ ${RM} -f ${STAGEDIR}${PREFIX}/bin/rebuild-gcj-db${SUFFIX} \
+ ${STAGEDIR}${PREFIX}/man/man1/rebuild-gcj-db${SUFFIX}.1
+ # Add target libraries and include files to packaging list.
+ ${RM} -f ${WRKDIR}/PLIST.lib
+.for d in ${TARGLIB:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///} include/gcj include/gnu include/java include/javax
+ cd ${STAGEDIR}${PREFIX} ; if [ -d $d ]; then \
+ ${FIND} $d -type f -o -type l >>${WRKDIR}/PLIST.lib ;\
+ fi
+.endfor
+ cd ${WRKDIR} ; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/lang/gcc5-devel/Makefile.DragonFly b/lang/gcc5-devel/Makefile.DragonFly
new file mode 100644
index 000000000000..7163f7d76237
--- /dev/null
+++ b/lang/gcc5-devel/Makefile.DragonFly
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+# The following modification to CXXFLAGS is needed in the case of DragonFly
+# 4.1+ building lang/gcc5 with the gcc50 base compiler when the system
+# libraries were built by the gcc47 base compiler. The sys.mk file
+# automatically adds -D_GLIBCXX_USE_CXX11_ABI=0 to CXXFLAGS in that case,
+# which will break the build.
+
+CXXFLAGS:= ${CXXFLAGS:N-D_GLIBCXX_USE_CXX11_ABI*}
diff --git a/lang/gcc5-devel/distinfo b/lang/gcc5-devel/distinfo
new file mode 100644
index 000000000000..d3817484f991
--- /dev/null
+++ b/lang/gcc5-devel/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gcc-5-20150421.tar.bz2) = b738e5f202dc99709c8f11d0d7f1e1274026d322eabeb1aec2a0ca6b321f4716
+SIZE (gcc-5-20150421.tar.bz2) = 90708748
diff --git a/lang/gcc5-devel/files/java-patch-hier b/lang/gcc5-devel/files/java-patch-hier
new file mode 100644
index 000000000000..8dd7f4637f70
--- /dev/null
+++ b/lang/gcc5-devel/files/java-patch-hier
@@ -0,0 +1,11 @@
+--- libjava/Makefile.in 2013-05-26 22:33:07.000000000 +0000
++++ libjava/Makefile.in 2013-05-31 21:19:23.000000000 +0000
+@@ -941,7 +941,7 @@
+ @BUILD_SUBLIBS_FALSE@LIBJAVA_CORE_EXTRA =
+ @BUILD_SUBLIBS_TRUE@LIBJAVA_CORE_EXTRA = @LIBGCJ_SUBLIB_CORE_EXTRA_DEPS@
+ dbexec_LTLIBRARIES = libjvm.la
+-pkgconfigdir = $(toolexeclibdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ jardir = $(datadir)/java
+ jar_DATA = libgcj-$(gcc_version).jar libgcj-tools-$(gcc_version).jar \
+ $(am__append_5)
diff --git a/lang/gcc5-devel/files/patch-arm-unwind-cxx-support b/lang/gcc5-devel/files/patch-arm-unwind-cxx-support
new file mode 100644
index 000000000000..6dbe567b6081
--- /dev/null
+++ b/lang/gcc5-devel/files/patch-arm-unwind-cxx-support
@@ -0,0 +1,105 @@
+Index: gcc/ginclude/unwind-arm-common.h
+===================================================================
+--- gcc/ginclude/unwind-arm-common.h (revision 219113)
++++ gcc/ginclude/unwind-arm-common.h (working copy)
+@@ -82,7 +82,11 @@
+
+ struct _Unwind_Control_Block
+ {
++#ifdef __FreeBSD__
++ unsigned exception_class __attribute__((__mode__(__DI__)));
++#else
+ char exception_class[8];
++#endif
+ void (*exception_cleanup)(_Unwind_Reason_Code, _Unwind_Control_Block *);
+ /* Unwinder cache, private fields for the unwinder's use */
+ struct
+@@ -181,7 +185,11 @@
+
+ /* Support functions for the PR. */
+ #define _Unwind_Exception _Unwind_Control_Block
++#ifdef __FreeBSD__
++ typedef unsigned _Unwind_Exception_Class __attribute__((__mode__(__DI__)));
++#else
+ typedef char _Unwind_Exception_Class[8];
++#endif
+
+ void * _Unwind_GetLanguageSpecificData (_Unwind_Context *);
+ _Unwind_Ptr _Unwind_GetRegionStart (_Unwind_Context *);
+Index: libstdc++-v3/libsupc++/unwind-cxx.h
+===================================================================
+--- libstdc++-v3/libsupc++/unwind-cxx.h (revision 219147)
++++ libstdc++-v3/libsupc++/unwind-cxx.h (working copy)
+@@ -235,7 +235,7 @@
+ return reinterpret_cast<__cxa_dependent_exception *>(exc + 1) - 1;
+ }
+
+-#ifdef __ARM_EABI_UNWINDER__
++#if defined(__ARM_EABI_UNWINDER__) && !defined(__FreeBSD__)
+ static inline bool
+ __is_gxx_exception_class(_Unwind_Exception_Class c)
+ {
+@@ -309,13 +309,7 @@
+ c[6] = 'R';
+ c[7] = '\0';
+ }
+-
+-static inline void*
+-__gxx_caught_object(_Unwind_Exception* eo)
+-{
+- return (void*)eo->barrier_cache.bitpattern[0];
+-}
+-#else // !__ARM_EABI_UNWINDER__
++#else // !__ARM_EABI_UNWINDER__ || __FreeBSD__
+ // This is the primary exception class we report -- "GNUCC++\0".
+ const _Unwind_Exception_Class __gxx_primary_exception_class
+ = ((((((((_Unwind_Exception_Class) 'G'
+@@ -339,6 +333,16 @@
+ << 8 | (_Unwind_Exception_Class) '+')
+ << 8 | (_Unwind_Exception_Class) '\x01');
+
++const _Unwind_Exception_Class __gxx_forced_unwind_class
++= ((((((((_Unwind_Exception_Class) 'G'
++ << 8 | (_Unwind_Exception_Class) 'N')
++ << 8 | (_Unwind_Exception_Class) 'U')
++ << 8 | (_Unwind_Exception_Class) 'C')
++ << 8 | (_Unwind_Exception_Class) 'F')
++ << 8 | (_Unwind_Exception_Class) 'O')
++ << 8 | (_Unwind_Exception_Class) 'R')
++ << 8 | (_Unwind_Exception_Class) '\0');
++
+ static inline bool
+ __is_gxx_exception_class(_Unwind_Exception_Class c)
+ {
+@@ -346,6 +350,12 @@
+ || c == __gxx_dependent_exception_class;
+ }
+
++static inline bool
++__is_gxx_forced_unwind_class(_Unwind_Exception_Class c)
++{
++ return c == __gxx_forced_unwind_class;
++}
++
+ // Only checks for primary or dependent, but not that it is a C++ exception at
+ // all.
+ static inline bool
+@@ -357,7 +367,18 @@
+ #define __GXX_INIT_PRIMARY_EXCEPTION_CLASS(c) c = __gxx_primary_exception_class
+ #define __GXX_INIT_DEPENDENT_EXCEPTION_CLASS(c) \
+ c = __gxx_dependent_exception_class
++#define __GXX_INIT_FORCED_UNWIND_CLASS(c) c = __gxx_forced_unwind_class
++#endif // __ARM_EABI_UNWINDER__ && !__FreeBSD__
+
++#ifdef __ARM_EABI_UNWINDER__
++static inline void*
++__gxx_caught_object(_Unwind_Exception* eo)
++{
++ return (void*)eo->barrier_cache.bitpattern[0];
++}
++
++#else // !__ARM_EABI_UNWINDER__
++
+ // GNU C++ personality routine, Version 0.
+ extern "C" _Unwind_Reason_Code __gxx_personality_v0
+ (int, _Unwind_Action, _Unwind_Exception_Class,
diff --git a/lang/gcc5-devel/files/patch-unwind-ia64.h b/lang/gcc5-devel/files/patch-unwind-ia64.h
new file mode 100644
index 000000000000..57f97172e207
--- /dev/null
+++ b/lang/gcc5-devel/files/patch-unwind-ia64.h
@@ -0,0 +1,20 @@
+2012-12-17 Gerald Pfeifer <gerald@pfeifer.com>
+ Anton Shterenlikht <mexas@bristol.ac.uk>
+
+ PR target/45650
+ * config/ia64/unwind-ia64.h: Do not mark _Unwind_FindTableEntry
+ hidden on FreeBSD.
+
+Index: libgcc/config/ia64/unwind-ia64.h
+===================================================================
+--- libgcc/config/ia64/unwind-ia64.h
++++ libgcc/config/ia64/unwind-ia64.h (working copy)
+@@ -49,4 +49,7 @@
+ extern struct unw_table_entry *
+ _Unwind_FindTableEntry (void *pc, unw_word *segment_base,
+ unw_word *gp, struct unw_table_entry *ent)
+- __attribute__ ((__visibility__ ("hidden")));
++#ifndef __FreeBSD__
++ __attribute__ ((__visibility__ ("hidden")))
++#endif
++ ;
diff --git a/lang/gcc5-devel/files/pkg-message.in b/lang/gcc5-devel/files/pkg-message.in
new file mode 100644
index 000000000000..433c37a3f89b
--- /dev/null
+++ b/lang/gcc5-devel/files/pkg-message.in
@@ -0,0 +1,7 @@
+To ensure binaries built with this toolchain find appropriate versions
+of the necessary run-time libraries, you may want to link using
+
+ -Wl,-rpath=%%TARGLIB%%
+
+For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
+transparently.
diff --git a/lang/gcc5-devel/pkg-descr b/lang/gcc5-devel/pkg-descr
new file mode 100644
index 000000000000..f63adcd21639
--- /dev/null
+++ b/lang/gcc5-devel/pkg-descr
@@ -0,0 +1,7 @@
+GCC, the GNU Compiler Collection, supports a number of languages. This
+port installs the C, C++, Fortran and Java front ends as gcc5, g++5,
+gfortran5, and gcj5, respectively.
+
+WWW: http://gcc.gnu.org/
+
+Gerald Pfeifer <gerald@FreeBSD.org>
diff --git a/lang/gcc5-devel/pkg-plist b/lang/gcc5-devel/pkg-plist
new file mode 100644
index 000000000000..c2ed474740cd
--- /dev/null
+++ b/lang/gcc5-devel/pkg-plist
@@ -0,0 +1,78 @@
+bin/%%GNU_HOST%%-c++%%SUFFIX%%
+bin/%%GNU_HOST%%-g++%%SUFFIX%%
+bin/%%GNU_HOST%%-gcc%%SUFFIX%%
+bin/%%GNU_HOST%%-gcc-%%GCC_VERSION%%
+bin/%%GNU_HOST%%-gcc-ar%%SUFFIX%%
+bin/%%GNU_HOST%%-gcc-nm%%SUFFIX%%
+bin/%%GNU_HOST%%-gcc-ranlib%%SUFFIX%%
+bin/%%GNU_HOST%%-gfortran%%SUFFIX%%
+bin/c++%%SUFFIX%%
+bin/cpp%%SUFFIX%%
+bin/g++%%SUFFIX%%
+bin/gcc%%SUFFIX%%
+bin/gcc-ar%%SUFFIX%%
+bin/gcc-nm%%SUFFIX%%
+bin/gcc-ranlib%%SUFFIX%%
+bin/gcov%%SUFFIX%%
+bin/gcov-tool%%SUFFIX%%
+bin/gfortran%%SUFFIX%%
+@comment info/gcc%%SUFFIX%%/dir
+man/man1/cpp%%SUFFIX%%.1.gz
+man/man1/g++%%SUFFIX%%.1.gz
+man/man1/gcc%%SUFFIX%%.1.gz
+man/man1/gcov%%SUFFIX%%.1.gz
+man/man1/gfortran%%SUFFIX%%.1.gz
+%%JAVA%%share/gcc-%%GCC_VERSION%%/python/libjava/aotcompile.py
+%%JAVA%%share/gcc-%%GCC_VERSION%%/python/libjava/classfile.py
+share/gcc-%%GCC_VERSION%%/python/libstdcxx/__init__.py
+share/gcc-%%GCC_VERSION%%/python/libstdcxx/v6/__init__.py
+share/gcc-%%GCC_VERSION%%/python/libstdcxx/v6/printers.py
+share/gcc-%%GCC_VERSION%%/python/libstdcxx/v6/xmethods.py
+%%JAVA%%bin/%%GNU_HOST%%-gcj%%SUFFIX%%
+%%JAVA%%bin/aot-compile%%SUFFIX%%
+%%JAVA%%bin/gappletviewer%%SUFFIX%%
+%%JAVA%%bin/gc-analyze%%SUFFIX%%
+%%JAVA%%bin/gcj%%SUFFIX%%
+%%JAVA%%bin/gcj-dbtool%%SUFFIX%%
+%%JAVA%%bin/gcjh%%SUFFIX%%
+%%JAVA%%bin/gij%%SUFFIX%%
+%%JAVA%%bin/gjar%%SUFFIX%%
+%%JAVA%%bin/gjarsigner%%SUFFIX%%
+%%JAVA%%bin/gjavah%%SUFFIX%%
+%%JAVA%%bin/gkeytool%%SUFFIX%%
+%%JAVA%%bin/gnative2ascii%%SUFFIX%%
+%%JAVA%%bin/gorbd%%SUFFIX%%
+%%JAVA%%bin/grmic%%SUFFIX%%
+%%JAVA%%bin/grmid%%SUFFIX%%
+%%JAVA%%bin/grmiregistry%%SUFFIX%%
+%%JAVA%%bin/gserialver%%SUFFIX%%
+%%JAVA%%bin/gtnameserv%%SUFFIX%%
+%%JAVA%%bin/jcf-dump%%SUFFIX%%
+%%JAVA%%bin/jv-convert%%SUFFIX%%
+%%JAVA%%libdata/pkgconfig/libgcj-5.pc
+%%JAVA%%man/man1/aot-compile%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gappletviewer%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gc-analyze%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gcj%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gcj-dbtool%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gcjh%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gij%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gjar%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gjarsigner%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gjavah%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gjdoc%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gkeytool%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gnative2ascii%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gorbd%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/grmic%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/grmid%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/grmiregistry%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gserialver%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/gtnameserv%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/jcf-dump%%SUFFIX%%.1.gz
+%%JAVA%%man/man1/jv-convert%%SUFFIX%%.1.gz
+%%JAVA%%share/java/libgcj-%%GCC_VERSION%%.jar
+%%JAVA%%share/java/libgcj-tools-%%GCC_VERSION%%.jar
+@exec if type ccache-update-links >/dev/null 2>&1; then ccache-update-links -v; fi
+@unexec if type ccache-update-links >/dev/null 2>&1; then ccache-update-links -v; fi
+@comment Insert PLIST.lib here