aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-12-11 19:31:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-12-11 19:31:07 +0800
commit865afd68645f18fd8f044f9af13cd205d18cc929 (patch)
tree4c687954fe96e690e6ff5e29a31e3d7804bdef48 /lang
parent1e9ea99d16e9c4fb2c8f9e0354b4a5c886a9e7cd (diff)
downloadfreebsd-ports-gnome-865afd68645f18fd8f044f9af13cd205d18cc929.tar.gz
freebsd-ports-gnome-865afd68645f18fd8f044f9af13cd205d18cc929.tar.zst
freebsd-ports-gnome-865afd68645f18fd8f044f9af13cd205d18cc929.zip
- Update USE_PYTHON
- Fix shebang for users with python3x as default python interpreter Submitted by: sunpoet (myself) Approved by: vanilla (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/v8/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index 49d4c44076c2..e350bd1a0e92 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
USES= gmake
USE_XZ= yes
-USE_PYTHON= 2.6+
+USE_PYTHON= 2.6-2.7
USE_LDCONFIG= yes
ALL_TARGET= native
MAKE_ARGS= library=shared
@@ -38,6 +38,7 @@ ONLY_FOR_ARCHS= i386 amd64
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/build/common.gypi ${WRKSRC}/tools/gyp/v8.gyp
+ @${REINPLACE_CMD} -e '1 s|${SETENV} python|&2|' ${WRKSRC}/build/gyp/gyp
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/out/native/d8 ${STAGEDIR}/${PREFIX}/bin/d8