aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-08-04 08:42:14 +0800
committerbapt <bapt@FreeBSD.org>2013-08-04 08:42:14 +0800
commit867849eb555acd720f0fb7f5d5a3db2f8db1304b (patch)
tree5bcd34e8e01fda81120e6129a4f5c311311ddd61 /lang
parent1de8b218fd33905d48a73ed4906b6b46f428d676 (diff)
downloadfreebsd-ports-gnome-867849eb555acd720f0fb7f5d5a3db2f8db1304b.tar.gz
freebsd-ports-gnome-867849eb555acd720f0fb7f5d5a3db2f8db1304b.tar.zst
freebsd-ports-gnome-867849eb555acd720f0fb7f5d5a3db2f8db1304b.zip
Add USE_GCC=any as build fails with clang.
Pass CC to build env to properly using the compiler desired This fixes build on head without gcc
Diffstat (limited to 'lang')
-rw-r--r--lang/go/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/go/Makefile b/lang/go/Makefile
index faf6a9f4ce91..599497e2f18f 100644
--- a/lang/go/Makefile
+++ b/lang/go/Makefile
@@ -24,6 +24,7 @@ sh_OLD_CMD= ${SETENV} bash
sh_CMD= ${SH}
WRKSRC= ${WRKDIR}/go
+USE_GCC= any
ONLY_FOR_ARCHS= i386 amd64
SUB_FILES= pkg-message
SUB_LIST+= GOOBJ=${GOOBJ} \
@@ -50,6 +51,7 @@ post-patch:
do-build:
cd ${WRKSRC}/src && \
+ CC=${CC} \
GOROOT=${WRKSRC} GOROOT_FINAL=${PREFIX}/go \
GOBIN= GOARCH=${GOARCH} GOOS=${OPSYS:L} \
${SH} make.bash