aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-09-01 22:14:44 +0800
committerMathieu Arnold <mat@FreeBSD.org>2016-09-01 22:14:44 +0800
commit870fd9b8faafef3bb3281bf55b40ebe0446c59a1 (patch)
tree654938802b90aba0f3479ec8d05296c3f2e84866 /lang
parent4940776700ec280918660ed877e6f597f5cca2de (diff)
downloadfreebsd-ports-gnome-870fd9b8faafef3bb3281bf55b40ebe0446c59a1.tar.gz
freebsd-ports-gnome-870fd9b8faafef3bb3281bf55b40ebe0446c59a1.tar.zst
freebsd-ports-gnome-870fd9b8faafef3bb3281bf55b40ebe0446c59a1.zip
Fix running make test for php extensions (and maybe php itself)
With the default configuration, all the directives are removed from with egrep. Then, egrep, seeing that it does not output any line, will exit(1). With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'lang')
-rw-r--r--lang/php55/Makefile2
-rw-r--r--lang/php55/files/patch-Makefile.global19
-rw-r--r--lang/php56/Makefile2
-rw-r--r--lang/php56/files/patch-Makefile.global19
-rw-r--r--lang/php70/Makefile2
-rw-r--r--lang/php70/files/patch-Makefile.global19
6 files changed, 60 insertions, 3 deletions
diff --git a/lang/php55/Makefile b/lang/php55/Makefile
index 3aec315aa773..6b72c328fd98 100644
--- a/lang/php55/Makefile
+++ b/lang/php55/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php55
PORTVERSION= 5.5.38
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php55/files/patch-Makefile.global b/lang/php55/files/patch-Makefile.global
new file mode 100644
index 000000000000..318b25294ceb
--- /dev/null
+++ b/lang/php55/files/patch-Makefile.global
@@ -0,0 +1,19 @@
+--- Makefile.global.orig 2016-07-20 08:41:48 UTC
++++ Makefile.global
+@@ -89,14 +89,14 @@ test: all
+ @if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
+ INI_FILE=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r 'echo php_ini_loaded_file();' 2> /dev/null`; \
+ if test "$$INI_FILE"; then \
+- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini; \
++ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini || :; \
+ else \
+ echo > $(top_builddir)/tmp-php.ini; \
+ fi; \
+ INI_SCANNED_PATH=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r '$$a = explode(",\n", trim(php_ini_scanned_files())); echo $$a[0];' 2> /dev/null`; \
+ if test "$$INI_SCANNED_PATH"; then \
+ INI_SCANNED_PATH=`$(top_srcdir)/build/shtool path -d $$INI_SCANNED_PATH`; \
+- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini; \
++ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini || :; \
+ fi; \
+ TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
+ TEST_PHP_SRCDIR=$(top_srcdir) \
diff --git a/lang/php56/Makefile b/lang/php56/Makefile
index 47634b236ef7..25a69851c6d2 100644
--- a/lang/php56/Makefile
+++ b/lang/php56/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php56
PORTVERSION= 5.6.25
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php56/files/patch-Makefile.global b/lang/php56/files/patch-Makefile.global
new file mode 100644
index 000000000000..5ef5f013a49a
--- /dev/null
+++ b/lang/php56/files/patch-Makefile.global
@@ -0,0 +1,19 @@
+--- Makefile.global.orig 2016-08-18 11:07:46 UTC
++++ Makefile.global
+@@ -89,14 +89,14 @@ test: all
+ @if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
+ INI_FILE=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r 'echo php_ini_loaded_file();' 2> /dev/null`; \
+ if test "$$INI_FILE"; then \
+- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini; \
++ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini || :; \
+ else \
+ echo > $(top_builddir)/tmp-php.ini; \
+ fi; \
+ INI_SCANNED_PATH=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r '$$a = explode(",\n", trim(php_ini_scanned_files())); echo $$a[0];' 2> /dev/null`; \
+ if test "$$INI_SCANNED_PATH"; then \
+ INI_SCANNED_PATH=`$(top_srcdir)/build/shtool path -d $$INI_SCANNED_PATH`; \
+- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini; \
++ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini || :; \
+ fi; \
+ TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
+ TEST_PHP_SRCDIR=$(top_srcdir) \
diff --git a/lang/php70/Makefile b/lang/php70/Makefile
index 20a03e96a53e..18e7cd0cc2f3 100644
--- a/lang/php70/Makefile
+++ b/lang/php70/Makefile
@@ -3,7 +3,7 @@
PORTNAME= php70
PORTVERSION= 7.0.10
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
DISTNAME= php-${PORTVERSION}
diff --git a/lang/php70/files/patch-Makefile.global b/lang/php70/files/patch-Makefile.global
new file mode 100644
index 000000000000..dda63ac4508e
--- /dev/null
+++ b/lang/php70/files/patch-Makefile.global
@@ -0,0 +1,19 @@
+--- Makefile.global.orig 2016-08-17 19:50:48 UTC
++++ Makefile.global
+@@ -89,14 +89,14 @@ test: all
+ @if test ! -z "$(PHP_EXECUTABLE)" && test -x "$(PHP_EXECUTABLE)"; then \
+ INI_FILE=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r 'echo php_ini_loaded_file();' 2> /dev/null`; \
+ if test "$$INI_FILE"; then \
+- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini; \
++ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_FILE" > $(top_builddir)/tmp-php.ini || :; \
+ else \
+ echo > $(top_builddir)/tmp-php.ini; \
+ fi; \
+ INI_SCANNED_PATH=`$(PHP_EXECUTABLE) -d 'display_errors=stderr' -r '$$a = explode(",\n", trim(php_ini_scanned_files())); echo $$a[0];' 2> /dev/null`; \
+ if test "$$INI_SCANNED_PATH"; then \
+ INI_SCANNED_PATH=`$(top_srcdir)/build/shtool path -d $$INI_SCANNED_PATH`; \
+- $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini; \
++ $(EGREP) -h -v $(PHP_DEPRECATED_DIRECTIVES_REGEX) "$$INI_SCANNED_PATH"/*.ini >> $(top_builddir)/tmp-php.ini || :; \
+ fi; \
+ TEST_PHP_EXECUTABLE=$(PHP_EXECUTABLE) \
+ TEST_PHP_SRCDIR=$(top_srcdir) \