aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2009-09-27 06:08:43 +0800
committergerald <gerald@FreeBSD.org>2009-09-27 06:08:43 +0800
commit8a16aff8c34aa88c3bab31409edc6c2b18b4ac7a (patch)
treeb2c0df782adad18c55febde62fae247d65a5a4c4 /lang
parentdb640306ff2fcacc75407a530c4323b985628e45 (diff)
downloadfreebsd-ports-gnome-8a16aff8c34aa88c3bab31409edc6c2b18b4ac7a.tar.gz
freebsd-ports-gnome-8a16aff8c34aa88c3bab31409edc6c2b18b4ac7a.tar.zst
freebsd-ports-gnome-8a16aff8c34aa88c3bab31409edc6c2b18b4ac7a.zip
For GCC 4.5 libgcj has been broken up such compilation no longer requires
more than half a GB of memory. Accordingly, we can now remove the build- time test for that from pre-everything. Feature safe: yes
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc/Makefile9
-rw-r--r--lang/gcc45/Makefile9
-rw-r--r--lang/gcc46/Makefile9
-rw-r--r--lang/gcc47/Makefile9
-rw-r--r--lang/gcc48/Makefile9
5 files changed, 0 insertions, 45 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index 658a1b116cc7..c659957b834b 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -137,15 +137,6 @@ PLIST_SUB+= JAVA="@comment "
pre-everything::
@${ECHO_MSG} "Making GCC ${PORTVERSION} for ${OPSYS} ${OSREL} target=${CONFIGURE_TARGET}"
-.if ! defined(WITHOUT_JAVA)
- @DSIZ=700000; DSIZBYTE=734003200; \
- if [ `ulimit -d` -lt $$DSIZ ]; then \
- echo "You need to increase the datasize limit to at least $$DSIZ \
- (and set kern.maxdsiz=\"$$DSIZBYTE\" in /boot/loader.conf) to \
- build with Java support." | ${FMT} -s; \
- exit 1; \
- fi
-.endif
pre-extract:
@# Building libgcj with lang/gcc295 installed is causing a failure