aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorandreast <andreast@FreeBSD.org>2018-12-29 23:41:44 +0800
committerandreast <andreast@FreeBSD.org>2018-12-29 23:41:44 +0800
commit8bbbd158e1ff73018f5dafe9d422909050eab221 (patch)
tree302294cde14a5d2c0588fbda8c459a16414be412 /lang
parent37a2103b28c6c202d4330b258a7fc31277d89091 (diff)
downloadfreebsd-ports-gnome-8bbbd158e1ff73018f5dafe9d422909050eab221.tar.gz
freebsd-ports-gnome-8bbbd158e1ff73018f5dafe9d422909050eab221.tar.zst
freebsd-ports-gnome-8bbbd158e1ff73018f5dafe9d422909050eab221.zip
Install 32-bit libraries for powerpc64 if built.
Approved by: gerald@
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc9-devel/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/lang/gcc9-devel/Makefile b/lang/gcc9-devel/Makefile
index a77fa28889e5..993450b40c5e 100644
--- a/lang/gcc9-devel/Makefile
+++ b/lang/gcc9-devel/Makefile
@@ -70,6 +70,7 @@ CONFIGURE_ARGS+= --with-cpu=8540 --enable-e500_double --without-fp
LANGUAGES:= c,c++,objc,fortran
TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
+TARGLIB32= ${PREFIX}/lib32 # The version information is added later
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
@@ -139,7 +140,13 @@ post-stage:
${RM} -r ${STAGEDIR}${TARGLIB}/gcc/*/${GCC_VERSION}/include-fixed/
# Add target libraries and include files to packaging list.
${RM} ${WRKDIR}/PLIST.lib
-.for d in ${TARGLIB:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///}
+
+.if ${ARCH} == powerpc64 && ${PORT_OPTIONS:MMULTILIB}
+ ${MKDIR} ${STAGEDIR}${TARGLIB32}/gcc${SUFFIX}
+ ${MV} ${STAGEDIR}${PREFIX}/lib/lib32/* ${STAGEDIR}${TARGLIB32}/gcc${SUFFIX}
+.endif
+
+.for d in ${TARGLIB:S/^${PREFIX}\///} ${TARGLIB32:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///}
cd ${STAGEDIR}${PREFIX} ; if [ -d $d ]; then \
${FIND} $d -type f -o -type l >>${WRKDIR}/PLIST.lib ;\
fi