aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
committernetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
commit8d63fa8ce3e1cb7a464d405732fcf971c5848297 (patch)
treebef012ab5e448ce5c144b7bb40139ba1dfd902a6 /lang
parent5f5845bb3ad1db90d601456aaaea7343c4dabfc6 (diff)
downloadfreebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.gz
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.zst
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Diffstat (limited to 'lang')
-rw-r--r--lang/compaq-cc/Makefile4
-rw-r--r--lang/freetxl/Makefile9
-rw-r--r--lang/icc/Makefile8
-rw-r--r--lang/icc7/Makefile6
-rw-r--r--lang/ifc/Makefile7
-rw-r--r--lang/ifc7/Makefile6
-rw-r--r--lang/linux-j/Makefile2
-rw-r--r--lang/visualworks/Makefile2
8 files changed, 23 insertions, 21 deletions
diff --git a/lang/compaq-cc/Makefile b/lang/compaq-cc/Makefile
index e767565034b4..c3067af81f74 100644
--- a/lang/compaq-cc/Makefile
+++ b/lang/compaq-cc/Makefile
@@ -40,9 +40,7 @@ EXTRACT_AFTER_ARGS= |${CPIO} -idum
EXTRACT_ONLY=
NO_WRKSUBDIR= yes
NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
-NO_MTREE= yes
-USE_LINUX?= yes
+USE_LINUX= yes
.include <bsd.port.pre.mk>
diff --git a/lang/freetxl/Makefile b/lang/freetxl/Makefile
index f7e5a843154d..9fa645c87cc9 100644
--- a/lang/freetxl/Makefile
+++ b/lang/freetxl/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freetxl
PORTVERSION= 10.3
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= ftp://ftp.sasknow.com/pub/txl/
DISTNAME= txl${PORTVERSION}.linux
@@ -14,15 +15,17 @@ DISTNAME= txl${PORTVERSION}.linux
MAINTAINER= ryan@sasknow.com
COMMENT= The TXL Programming Language (transformation by example)
-USE_LINUX?= yes
-STRIP=
-NO_BUILD= yes
+USE_LINUX= yes
MAN1= txl.1 txlc.1 txldb.1 txlp.1
PORTDOCS= 00README.txt COPYRIGHT.txt Documents.html Examples.html \
FILES.txt Learning.html Support.html
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/bin/txl \
+ ${WRKSRC}/bin/txldb
+
do-install:
${INSTALL_PROGRAM} \
${WRKSRC}/bin/txl \
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 623f73484a05..f4bde4aef709 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -18,7 +18,7 @@ PATCHLEVEL= ${PORTVERSION:C/(.+p)(.+)$/pe\2/}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
.if ${PORTVERSION} != ${PATCHLEVEL}
DISTFILES+= ${DISTNAME}_${PATCHLEVEL}${EXTRACT_SUFX}
-PATCH_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
+PATCH_DEPENDS= ${LINUX_BASE_PORT}
.endif
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
@@ -30,9 +30,8 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
CONFLICTS= linux_devtools*
-USE_LINUX?= yes
+USE_LINUX= yes
USE_REINPLACE= yes
-NO_FILTER_SHLIBS= yes
COMPILERDIR= intel_cc_80
PLIST_SUB= COMPILERDIR=${COMPILERDIR}
@@ -219,7 +218,8 @@ do-build:
@${CC} ${CFLAGS} -o \
${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld \
${FILESDIR}/ld.c
- @${STRIP_CMD} ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
+# We can't use STRIP_CMD, since we need the FreeBSD one, not the Linux one.
+ @/usr/bin/strip ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
@${CHMOD} 755 ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
# Make ICC happy with regards to crtbegin.o, crtend.o and libgcc.a which it
# expects to find in GXX_ROOT.
diff --git a/lang/icc7/Makefile b/lang/icc7/Makefile
index 2b53d3fc3c7b..1aab74063658 100644
--- a/lang/icc7/Makefile
+++ b/lang/icc7/Makefile
@@ -25,10 +25,9 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
CONFLICTS= linux_devtools* ifc*
-USE_LINUX?= yes
+USE_LINUX= yes
USE_REINPLACE= yes
NO_WRKSUBDIR= yes
-NO_FILTER_SHLIBS= yes
COMPILERDIR= compiler70
PLIST_SUB= COMPILERDIR=${COMPILERDIR}
@@ -160,7 +159,8 @@ do-build:
@${CC} ${CFLAGS} -o \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld \
${FILESDIR}/ld.c
- @${STRIP_CMD} ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
+# We can't use STRIP_CMD, since we need the FreeBSD one, not the Linux one.
+ @/usr/bin/strip ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
@${CHMOD} 755 ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
do-install:
diff --git a/lang/ifc/Makefile b/lang/ifc/Makefile
index 4287cd8a7603..9865fd6d544c 100644
--- a/lang/ifc/Makefile
+++ b/lang/ifc/Makefile
@@ -18,7 +18,7 @@ PATCHLEVEL= ${PORTVERSION:C/(.+p)(.+)$/pe\2/}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
.if ${PORTVERSION} != ${PATCHLEVEL}
DISTFILES+= ${DISTNAME}_${PATCHLEVEL}${EXTRACT_SUFX}
-PATCH_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8
+PATCH_DEPENDS= ${LINUX_BASE_PORT}
.endif
EXTRACT_DEPENDS= rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
@@ -30,7 +30,7 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
CONFLICTS= linux_devtools*
-USE_LINUX?= yes
+USE_LINUX= yes
USE_REINPLACE= yes
NO_FILTER_SHLIBS= yes
@@ -191,7 +191,8 @@ do-build:
@${CC} ${CFLAGS} -o \
${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld \
${FILESDIR}/ld.c
- @${STRIP_CMD} ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
+# We can't use STRIP_CMD, since we need the FreeBSD one, not the Linux one.
+ @/usr/bin/strip ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
@${CHMOD} 755 ${WRKSRC}/opt/${COMPILERDIR}/bin/ldwrapper/ld
do-install:
diff --git a/lang/ifc7/Makefile b/lang/ifc7/Makefile
index d5cb8fd02ad6..06eed2750ba0 100644
--- a/lang/ifc7/Makefile
+++ b/lang/ifc7/Makefile
@@ -24,10 +24,9 @@ NO_CDROM= ${RESTRICTED}
ONLY_FOR_ARCHS= i386
-USE_LINUX?= yes
+USE_LINUX= yes
USE_REINPLACE= yes
NO_WRKSUBDIR= yes
-NO_FILTER_SHLIBS= yes
COMPILERDIR= compiler70
PLIST_SUB= COMPILERDIR=${COMPILERDIR}
@@ -158,7 +157,8 @@ do-build:
@${CC} ${CFLAGS} -o \
${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld \
${FILESDIR}/ld.c
- @${STRIP_CMD} ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
+# We can't use STRIP_CMD, since we need the FreeBSD one, not the Linux one.
+ @/usr/bin/strip ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
@${CHMOD} 755 ${WRKSRC}/opt/intel/${COMPILERDIR}/ia32/bin/ldwrapper/ld
do-install:
diff --git a/lang/linux-j/Makefile b/lang/linux-j/Makefile
index f041750145ff..8d2fcbf86667 100644
--- a/lang/linux-j/Makefile
+++ b/lang/linux-j/Makefile
@@ -17,7 +17,7 @@ COMMENT= A general purpose programming language
RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
-USE_LINUX?= yes
+USE_LINUX= yes
USE_JAVA= yes
JAVA_VERSION= 1.3+
diff --git a/lang/visualworks/Makefile b/lang/visualworks/Makefile
index 22f46ff08290..74d71e8f1aa7 100644
--- a/lang/visualworks/Makefile
+++ b/lang/visualworks/Makefile
@@ -18,7 +18,7 @@ EXTRACT_ONLY=
MAINTAINER= chris@chrisburkert.de
COMMENT= A high performance Smalltalk environment
-USE_LINUX?= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
NO_BUILD= yes
PLIST_FILES= bin/visual