aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-04-25 23:14:43 +0800
committersylvio <sylvio@FreeBSD.org>2010-04-25 23:14:43 +0800
commit8fe6e5daf3db231687f13e53d5e5cc7909557048 (patch)
treef8e98ac92490ed1ff63ad5c3893ce702bac443a8 /lang
parent8fb60319215383b6f6a86ce9ce8cc1c458cbdabf (diff)
downloadfreebsd-ports-gnome-8fe6e5daf3db231687f13e53d5e5cc7909557048.tar.gz
freebsd-ports-gnome-8fe6e5daf3db231687f13e53d5e5cc7909557048.tar.zst
freebsd-ports-gnome-8fe6e5daf3db231687f13e53d5e5cc7909557048.zip
- This library's module, Test::XPath, provides an interface for testing the
content and structure of XML and HTML documents using XPath query expressions. This will be most useful for those who need to write TAP-emitting unit tests for HTML or XML output. WWW: http://search.cpan.org/dist/Test-XPath/ PR: ports/146035 Submitted by: Jonathan Chu <milki@rescomp.berkeley.edu>
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/p5-Test-XPath/Makefile26
-rw-r--r--lang/p5-Test-XPath/distinfo3
-rw-r--r--lang/p5-Test-XPath/pkg-descr6
-rw-r--r--lang/p5-Test-XPath/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 21b80481fdaf..fe865eacdfaf 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -231,6 +231,7 @@
SUBDIR += p5-Scalar-List-Utils
SUBDIR += p5-Switch
SUBDIR += p5-Tcl
+ SUBDIR += p5-Test-XPath
SUBDIR += p5-Try-Tiny
SUBDIR += p5-TryCatch
SUBDIR += p5-ePerl
diff --git a/lang/p5-Test-XPath/Makefile b/lang/p5-Test-XPath/Makefile
new file mode 100644
index 000000000000..2b05b60932b4
--- /dev/null
+++ b/lang/p5-Test-XPath/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Test-XPath
+# Date created: 25 April 2010
+# Whom: milki
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-XPath
+PORTVERSION= 0.12
+CATEGORIES= lang perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/D/DW/DWHEELER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= milki@rescomp.berkeley.edu
+COMMENT= Test XML and HTML content and structure with XPath expressions
+
+BUILD_DEPENDS= p5-Test-Simple>=0.70:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Module-Build>=0.30:${PORTSDIR}/devel/p5-Module-Build
+RUN_DEPENDS= p5-XML-LibXML>=1.69:${PORTSDIR}/textproc/p5-XML-LibXML
+
+PERL_MODBUILD= YES
+
+MAN3= Test::XPath.3
+
+.include <bsd.port.mk>
diff --git a/lang/p5-Test-XPath/distinfo b/lang/p5-Test-XPath/distinfo
new file mode 100644
index 000000000000..a3000f2e5ba8
--- /dev/null
+++ b/lang/p5-Test-XPath/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-XPath-0.12.tar.gz) = a26cbae4e57196af39606d3f30b178ac
+SHA256 (Test-XPath-0.12.tar.gz) = 1e1c93b1c9457993e298933e126af99b07ecf9aed53b36061d4eb9aeef3ed4c6
+SIZE (Test-XPath-0.12.tar.gz) = 13222
diff --git a/lang/p5-Test-XPath/pkg-descr b/lang/p5-Test-XPath/pkg-descr
new file mode 100644
index 000000000000..2180c69b3f77
--- /dev/null
+++ b/lang/p5-Test-XPath/pkg-descr
@@ -0,0 +1,6 @@
+This library's module, Test::XPath, provides an interface for testing the
+content and structure of XML and HTML documents using XPath query expressions.
+This will be most useful for those who need to write TAP-emitting unit tests
+for HTML or XML output.
+
+WWW: http://search.cpan.org/dist/Test-XPath/
diff --git a/lang/p5-Test-XPath/pkg-plist b/lang/p5-Test-XPath/pkg-plist
new file mode 100644
index 000000000000..7385ffd4200f
--- /dev/null
+++ b/lang/p5-Test-XPath/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Test/XPath.pm
+@dirrmtry %%SITE_PERL%%//Test