aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2014-05-31 06:08:55 +0800
committertdb <tdb@FreeBSD.org>2014-05-31 06:08:55 +0800
commit9006f4e78b1ceb77d6571a3d6a275fc09db7b351 (patch)
treeaf7b727235b64286596a0ec884fa892a8e326c6a /lang
parent3a2b435c43844c958ed600d4162d8e6677caaf3c (diff)
downloadfreebsd-ports-gnome-9006f4e78b1ceb77d6571a3d6a275fc09db7b351.tar.gz
freebsd-ports-gnome-9006f4e78b1ceb77d6571a3d6a275fc09db7b351.tar.zst
freebsd-ports-gnome-9006f4e78b1ceb77d6571a3d6a275fc09db7b351.zip
Stage support.
PR: ports/190384 Submitted by: Julian H. Stacey <jhs@berklix.com> (maintainer)
Diffstat (limited to 'lang')
-rw-r--r--lang/pbasic/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/lang/pbasic/Makefile b/lang/pbasic/Makefile
index 1762aca2960b..a4fffc0070f1 100644
--- a/lang/pbasic/Makefile
+++ b/lang/pbasic/Makefile
@@ -15,8 +15,7 @@ COMMENT= Phil Cockroft's Basic Interpreter (previously Rabbit Basic)
ALL_TARGET= freebsd
MAKEFILE= makefile
-MAN1= pbasic.1
-PLIST_FILES= bin/pbasic
+PLIST_FILES= bin/pbasic man/man1/pbasic.1.gz
post-patch: .SILENT
${REINPLACE_CMD} -e '/^CC/s/=/?=/' \
@@ -24,13 +23,12 @@ post-patch: .SILENT
${WRKSRC}/freebsd/makefile
${ECHO_CMD} '.PHONY: $$(SYSTEMS)' >>${WRKSRC}/makefile
-NO_STAGE= yes
do-configure:
-cd ${WRKSRC} ; ${RM} -rf termio m68000 msdos vax pyramid ns32000 \
pdp11 cursor/cursor.dos cursor/cursor.ukc
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/basic ${PREFIX}/bin/pbasic
- ${INSTALL_MAN} ${WRKSRC}/docs/basic.1 ${PREFIX}/man/man1/pbasic.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/basic ${STAGEDIR}${PREFIX}/bin/pbasic
+ ${INSTALL_MAN} ${WRKSRC}/docs/basic.1 ${STAGEDIR}${PREFIX}/man/man1/pbasic.1
.include <bsd.port.mk>