aboutsummaryrefslogtreecommitdiffstats
path: root/lang
diff options
context:
space:
mode:
authorrpaulo <rpaulo@FreeBSD.org>2014-05-12 01:12:11 +0800
committerrpaulo <rpaulo@FreeBSD.org>2014-05-12 01:12:11 +0800
commit91d6dae7c792334d6f54fd9ed1bcc65864a447e9 (patch)
tree99bf8e50e3f6afce6a2ce3005b8d9ba627c6f942 /lang
parentab8fe9531a96156b78603b7748ff54824a769514 (diff)
downloadfreebsd-ports-gnome-91d6dae7c792334d6f54fd9ed1bcc65864a447e9.tar.gz
freebsd-ports-gnome-91d6dae7c792334d6f54fd9ed1bcc65864a447e9.tar.zst
freebsd-ports-gnome-91d6dae7c792334d6f54fd9ed1bcc65864a447e9.zip
Add a new port py-clojure.
A implementation of Clojure in pure (dynamic) Python. Reviewed by: bapt Approved by: bapt
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/py-clojure/Makefile20
-rw-r--r--lang/py-clojure/distinfo2
-rw-r--r--lang/py-clojure/pkg-descr3
4 files changed, 26 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 5ff7da2f2f9c..d942de818787 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -249,6 +249,7 @@
SUBDIR += polyml
SUBDIR += ptoc
SUBDIR += pure
+ SUBDIR += py-clojure
SUBDIR += py-mx-base
SUBDIR += py-prolog
SUBDIR += pypy
diff --git a/lang/py-clojure/Makefile b/lang/py-clojure/Makefile
new file mode 100644
index 000000000000..a83d977e5db2
--- /dev/null
+++ b/lang/py-clojure/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= clojure
+PORTVERSION= 0.2.4
+CATEGORIES= lang python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}_py-${PORTVERSION}
+DIST_SUBDIR= python
+
+MAINTAINER= rpaulo@FreeBSD.org
+COMMENT= Implementation of Clojure in Python
+
+LICENSE= EPL
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/lang/py-clojure/distinfo b/lang/py-clojure/distinfo
new file mode 100644
index 000000000000..8b1fc8c56b6b
--- /dev/null
+++ b/lang/py-clojure/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python/clojure_py-0.2.4.tar.gz) = 688943c6e9fce571b81c5d0f4c09dd5d7ef4444e49d93b2e9a9e1bd4fa773abd
+SIZE (python/clojure_py-0.2.4.tar.gz) = 100732
diff --git a/lang/py-clojure/pkg-descr b/lang/py-clojure/pkg-descr
new file mode 100644
index 000000000000..ea504c661f2b
--- /dev/null
+++ b/lang/py-clojure/pkg-descr
@@ -0,0 +1,3 @@
+A implementation of Clojure in pure (dynamic) Python.
+
+WWW: https://github.com/halgari/clojure-py